Thread Tools
Jan 15, 2013, 08:21 PM
AMA 667982 KG7NKY
starcad's Avatar
Glad to hear you have it working Miniclip, good news.
Sign up now
to remove ads between posts
Jan 15, 2013, 08:35 PM
Registered User
The electronic governor is not initialized
Oct 31, 2014, 12:10 PM
Registered User
Quote:
Originally Posted by Rich in ILM
Take the prop off.
Turn on your radio and push the throttle all the way up.
Connect the battery to your plane.
As soon as you hear 2 beeps close the throttle all the way.

If that works you are in business, if not, reverse the throttle and do he above again.
Thanks Rich,

I tried this and it worked great! But does anyone know what to do if my motor is running backwards? Instead of pulling the plane forward, it pushes it back.

Thanks,

-Wyatt
Oct 31, 2014, 12:13 PM
http://www.sgvhumane.org/
cmdl's Avatar
Quote:
Originally Posted by NinjaZebra
Thanks Rich,

I tried this and it worked great! But does anyone know what to do if my motor is running backwards? Instead of pulling the plane forward, it pushes it back.

Thanks,

-Wyatt
assuming your prop is on the right way (numbers facing forward), if the plane is being pushed back, swap any two motor wires connected to the ESC.
Oct 31, 2014, 12:45 PM
Registered User
Clive66's Avatar
Quote:
Originally Posted by cmdl
assuming your prop is on the right way (numbers facing forward), if the plane is being pushed back, swap any two motor wires connected to the ESC.
If the prop is backwards, it does not change if it is pulling or pushing.
Just affects the amount of thrust.
Oct 31, 2014, 12:53 PM
http://www.sgvhumane.org/
cmdl's Avatar
^^ ah true. missed that one. definitely a wire swap. couldn't hurt to check though that prop is on the right way.
Oct 31, 2014, 01:23 PM
Registered User
E-Challenged's Avatar
Some speed control arming procedures are different than others. Read and follow the speed control directions carefully if provided with your model. If your motor battery is not charged, the speed control may not arm. If your motor battery has a bad cell, speed control may not arm. If there is a poor or broken connection between speed control and motor leads motor won't run. Always turn on transmitter and have throttle stick in lowest position BEFORE you connect motor battery. If throttle stick is above lowest position and throttle trim is also set above lowest position, speed control will not arm for your safety. Be careful not to knock transmitter over or otherwise accidentally raise the throttle stick and start the motor with prop on the model. Cheap transmitters usually have no throttle lock or other safety feature to protect from accidental throttle -up.
Oct 31, 2014, 04:50 PM
Registered User
i think that switch on top left of the tx has to be pulled forward, then turn on tx,plug in battery, after 3 beeps push that switch back, this is how it worked on my first plane the hawksky with the tx that came with it.
Oct 31, 2014, 10:13 PM
Registered User
Quote:
Originally Posted by cmdl
assuming your prop is on the right way (numbers facing forward), if the plane is being pushed back, swap any two motor wires connected to the ESC.
So, any two wires? When I was reading an Instructable on connecting RC airplane parts, it said I could put the wires on any way. Guess he was wrong! Lol. Anyways, thanks for the help!

-Wyatt
Oct 31, 2014, 10:34 PM
Registered User
Alright yeah, sorry about 2 posts in a row lol, but I switched the VCC and Ground wires for the motor and now it's working properly! Thanks for the help guys!

Friendly regards,

-Wyatt


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion RC tug Southampton + Spektrum Receiver (ESC not working) fy789 Scale Boats 16 Oct 07, 2012 10:08 PM
Alert Throttle not working Sach Batteries and Chargers 8 Jul 24, 2012 03:51 PM
Discussion My plane will not work... GUSTAV6 Electric Plane Talk 9 Apr 13, 2012 03:02 PM
Question Weird problem with New Y-6... Throttle works, but not Pitch Roll or Yaw Adidas4275 Aerial Photography 4 Apr 02, 2012 11:21 AM
Help! 2 different planes, not getting any throttle ? fltekdiver Power Systems 3 Mar 08, 2012 08:16 PM