Hubsan x4 Problems - RC Groups
Thread Tools
Jan 04, 2013, 11:33 PM
Registered User
Discussion

Hubsan x4 Problems


Hi guys,

Just wondering if anyone would have any advice regarding a problem I am having with a Hubsan X4 i got recently. Ever since first flying it, it won't hover. Whenever i press the throttle up to take off, it immediately flys off to the left hand side ( eyes facing away from me, white rotors towards me) and slightly back to the white rotors. I have fiddled with the trim in a hope to fix it, however it has not seem to have done anything. I stumbled across a post on here on resetting the accelerometer which I do, however it continues to fly away when raising the throttle rapidly to the side without any movement to the control pad. I have experienced lesser problems with RC mini helicopters however this is easily fixed with a small movement of the trim.

Any help or advice would be greatly appreciated.
Sign up now
to remove ads between posts
Jan 05, 2013, 12:35 AM
Finding Creative Ways To Crash
RCCrashTestDummy's Avatar
Here you go brother: Make sure to read the paragraph marked as "Additional info" You basically have to raise the quad in the direction it's drifting towards, then recalibrate. You might get lucky the first time, but It took me several tries of raising it up and down to get it real close without any trim. Make sure to do this with a full batt. It's eyes will begin to blink rapidly once the batt wears down, kinda cool.

https://www.rcgroups.com/forums/show...&postcount=410

Good luck,

-Pat
Jan 05, 2013, 08:25 AM
Registered User
Thanks for the help Pat, much appreciated! will give this a shot when im home this evening.
Oct 07, 2014, 10:14 AM
Registered User

Hubsan


Is there a way to recalibrate a motor? Blade snapped off and I put on a new blade. When I try to fly that motor/blade keeps the Hubsan grounded???
Oct 07, 2014, 10:17 AM
Team AlienWarpSquad
Quote:
Originally Posted by tdenoyer
Is there a way to recalibrate a motor? Blade snapped off and I put on a new blade. When I try to fly that motor/blade keeps the Hubsan grounded???
Very possible that motor was damaged and needs to be replaced.
First check that there is nothing keeping the motor shaft from turning like fuzz, hairs or the prop guard. If all clean then the motor is bad.
The motors on these tiny quads are a bit fragile. I have gone through a few motors.
Oct 07, 2014, 10:25 AM
Registered User
Double check and make sure the replacement blade is correct. If you used the wrong one it will push air up instead of down.

Quote:
Originally Posted by tdenoyer
Is there a way to recalibrate a motor? Blade snapped off and I put on a new blade. When I try to fly that motor/blade keeps the Hubsan grounded???
Nov 29, 2014, 11:11 AM
Registered User
Trisnpod's Avatar

I had this problem too!


Hi! I have just recently got the hubsan x4 (with camera) and I really messed up with this problem. When the quad originally arrived, I was waiting for the battery to charge and decided I might as well try putting on the protective cover, so I took all the blades off, put the cover on, and then when the battery was charged I tried flying it, but it kept trying to flip and wouldn't take off. Unfortunately I stupidly thought it must be faulty, and sent it back, but then I had exactly the same problem with the new one. This time however, I found the FAQ section at the back of the instructions and it said I had put the props on wrong. Apparently there is an A prop and a B prop of each colour, and they have to go in the right place. The letters are on the top of each prop in tiny font. After this the quad worked great, but I was kicking myself for sending the old one back and not reading the instructions properly. I really hope this helps someone, so no more great quads get wasted
Thanks, Tristan
Feb 10, 2015, 04:46 PM
Registered User
Yes I've been reading on this thread and I have the same problem. I was flying today and landed then when I went to take back off it would only come off the ground a few inches. After checking blades and battery where good I tried again. But this time I have nothing at all I could spin the front blade by thumping it and it would try to spin but now It does nothing at all. It just don't make seance that all motors just quit working. I have crashed many times so could be possible just don't see all going bad at once. Can anyone please give me ideals to search for. Thank you.
Apr 02, 2015, 10:24 PM
Registered User
Wally_Dad's Avatar

Short Flight Time


HELP! My cool Hubsan X4 is now flashing after only 30 seconds or so. I don't think it's the batteries (I have several). When I check voltage after the flight, they are only down to 3.9v at most. I did change the body and replace a motor, but this seems to have happened well after that. Any ideas?
Aug 08, 2015, 12:27 AM
Registered User
greetings forum,
I created an account to share this quick info, and hopefully save a stranger some time.

If your video feed sucks on your h107d, make sure you don't have an unsupported microSD card in your tx like I did.

The associate at the store very confidently told me class2 32GB. I stupidly listened without my usual, "let google and me double check you real quick" first.. lesson learned.
Dec 26, 2016, 09:59 AM
Registered User

Help


Hello, I got A 502s for Christmas today. I flew it one time. When the battery was close to dead I stopped and brought it inside to charge. Fast forward a couple hours, I hook the battery back up and only the blue light on the very bottom of the drone body comes on and it blinks slow and steady. No other lights come on and the transmitter doesn't read the drone being on or active. I tried re-binding to the transmitter and no change. And the bottom of the drone gets hot when the battery is connected. Any Help is Appreciated!
Dec 27, 2016, 03:51 PM
Registered User
Trisnpod's Avatar
Did you crash it when you flew it at all? Did it get wet? And have you tried changing the batteries in the transmitter? I know this is a pretty basic thing to try but it might be the source of the problem.
Also did you plug the battery charger into a computer usb socket or a phone charger?
Jan 12, 2017, 03:42 AM
Registered User

transmitter black screen


Hello... I made a mistake. I have updated firmware for my hubsan h501s pro for drone and transmitter. it clearly said do not update a transmitter... now when I turn on trans its a black screen and dron is flashing like it does when trans is off ((( Dont know what to do. Help me guys. .. Can I reset a transmitter to default firmware and get it back in normal again. Help me.
Best regards
Feb 22, 2017, 06:57 PM
Registered User
Download This
https://drive.google.com/file/d/0B2N...hWejA1cUk/view

The firmware for the FPV1 advanced transmitter is in the zip. Just use the Hubsan utility to install the ROM
Feb 22, 2017, 07:03 PM
Registered User
Nikolasss

There is a youtube video -
Hubsan H501S Firmware Update / Upgrade Video Tutorial! Guida Aggiornamento FC / RX / TX / RC FPV1! (13 min 48 sec)


I know its in Italian -

Look in the video description (its in english) . The firmware for the advanced controller, and various versions of it is contained within that archive.
I had the same problem and fixed it - BUT after getting the controller working again, I am still not able to bind the 501 to my FPV1 controller.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion The Hubsan X4 youxif Multirotor Drone Talk 102 Feb 20, 2017 06:43 PM
Discussion Hubsan x4 6axis scousethief Mini Multirotor Drones 301 May 13, 2015 10:31 AM
Discussion Hubsan X4 Mini Quad dc9guy Mini Multirotor Drones 32 Feb 04, 2013 11:14 PM