Shop our Airplanes Products Drone Products Sales
Thread Tools
Jan 03, 2013, 09:46 PM
Registered User
Help!

LiFe - no balancing connector


The Any Link cable adaptor TACM0005 has a 6.6V 200mAh LiFe battery but does not have a balancing connector. My Onyx 235 charger does not allow me to charge this battery given that I cannot connect the balancing port up to the battery. - Error: BAL. CON. -ERROR-

Is there a way to do this with the Onyx 235? If not is there an inexpensive charger/method for charging this battery safely?

Thanks!
Sign up now
to remove ads between posts
Jan 04, 2013, 07:37 AM
Southern Pride
everydayflyer's Avatar
Can your charger be set to 6volts Pb ( lead acid) and 0.2A, if so such setting will work fine.

LiFePO4 cells are a lot more forgiving than LiPoly cells and thus balancing is more of an option than a requirement. I use a 4S2P as a starting battery for a 16 HP lawn mower and while it does have balancing leads (left over from when I used it for electric flight) it never requires balancing.

FYI I flew a 3S 2300 mAh A123 battery for over 500 flights ,it was charged at very high rates and never required balancing.

Charles
Mar 29, 2013, 01:09 PM
Safety : practice & promote!
RoboHeli's Avatar
I've got a similar problem with my Thundepower AC6. I can connect it to the charger using the LiFe settings as specified above but when I start charging, it says it's done after about 40 seconds. I then measure the voltage afterwards and it's clear that only a little charge went into it.
Mar 29, 2013, 07:26 PM
Registered User
tacx's Avatar
So, The Any Link adapter cable comes with a rechargable battery, but provides no means to charge it?
Mar 29, 2013, 07:43 PM
Safety : practice & promote!
RoboHeli's Avatar
The manual recommends three specific chargers:
  1. LifeSource AC/DC Balancing Charger (HCAM6375) which is like $40 or so.
  2. Triton EQ by Electrify (GPMM3155) which is around $80
  3. Triton2 EQ by Electrify (GPMM3156) which is close to $120

My ThunderPower AC6 handles LiFe batteries but doesn't seem to charge a 2S LiFe very well without a balance charge connector--which the TACM0005 does not have.

I looked up the manual for the LifeSource charger and it looks like it's got some sort of adapter that might be helpful but I'm really not sure exactly how it's supposed to work.
May 27, 2013, 09:00 AM
Registered User
exact same issue with a Hyperion Super Duo... error.
seems crazy to have to buy a $40 charger for ONE tiny little battery, but my 1sq quad is dead in the water with out it!
May 27, 2013, 01:23 PM
Safety : practice & promote!
RoboHeli's Avatar
So now that I've spent some time using my TACM0005 cable, it seems to actually work very well. My concerns about it not being charged properly really weren't that justified. I've used it for about an hour's worth of flying and it took a few minutes to charge up after that. So far I've quite honestly found that it works very well!
Jul 15, 2013, 11:04 PM
Registered User
netarc's Avatar
Do u need a special adapter to charge the cable from a Triton EQ, or can you connect it directly to the balance board to charge from their (ie, without connection the red/black power leads on triton)
Jul 17, 2013, 08:58 AM
Safety : practice & promote!
RoboHeli's Avatar
Quote:
Originally Posted by netarc View Post
Do u need a special adapter to charge the cable from a Triton EQ, or can you connect it directly to the balance board to charge from their (ie, without connection the red/black power leads on triton)

Are you talking about the TACM0005 cable that I was referring to? The only thing you can charge it with is a Futaba-style servo plug that connects to your charger.

I *believe* this is the part that will work for it (I got my cable with my Thunderpower AC6 charger from hobbypartz.com):

http://www.hobbyking.com/hobbyking/s...dproduct=32966

I'm planning on buying this Futaba-to-banana-plug connector so I have a spare cable for my iCharger.
Jul 19, 2013, 12:37 AM
Registered User
netarc's Avatar
Yes I was wondering how to go about charging the TACM0005 cable. thanks for the tip
Jul 19, 2013, 09:53 AM
Safety : practice & promote!
RoboHeli's Avatar
I connect my TACM0005 to my iCharger 1006b (or Thunderpower AC6) with this futaba-style connector. I set the charger to LiFe mode and then charge it with the settings that are listed on the TACM0005 itself. It only takes a few minutes as I charge it whenever I charge my main transmitter pack.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Imax balance connector - Can I use it without a balance board? DudeInMyrtleBch Batteries and Chargers 2 Dec 29, 2012 05:43 PM
Help! Hyperion LBA10 balancer - confused about balance connector to use Fly-CH Batteries and Chargers 3 Dec 19, 2012 12:47 AM
Discussion Can I use a Multiplex Type 6-Pin Gold Connector as a balanced connector for a 5s pack tasso del miele Batteries and Chargers 2 May 18, 2012 06:14 PM
Discussion Hyperion Litestorm 3S400 -no balancing connector? Fly-CH Batteries and Chargers 5 Apr 21, 2007 01:16 PM
Discussion My LiPo's have no balancing connectors!? helibobber Batteries and Chargers 15 Jun 12, 2006 07:38 AM