Thread Tools
Old Jan 02, 2013, 09:11 PM
OhNoMrBill is offline
Find More Posts by OhNoMrBill
Registered User

Champ controller stuck?

I have a Hobbyzone Champ that is a 1 years old with a bit of flying in. For Christmas I got a Blade MCX2 (RTF with own remote) for my son. During a flight the Heli lost forward and reverse. In order to find out what was up the heli, I tried to bind the Champ remote to the MCX2 with no success. Now, I cannot get the Champ remote to go into bind mode to reconnect. It beeps twice when you push the stick in and turn it on. At no time does if flash the LED or appear to go into bind mode. I have tried on mode 1 and mode 2. I can get the Blade remote to bind to the Champ without issue.

It seems that the Champ remote is stuck in some kind of odd mode. I have changed batteries, move away, gotten close, nothing is working.

Any tips?
Sign up now
to remove ads between posts
Old Jan 03, 2013, 11:41 AM
cmdl is offline
Find More Posts by cmdl
cmdl's Avatar
i don't have a champ but i do have a um and i know i have to keep some distance between the plane and the tx for it to bind. dunno if that helps.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion stuck control inputs? Kmart Hoverfly Technologies 8 Jun 14, 2012 07:31 PM
Discussion after getting stuck in a tree my champ only half works? stevenator128 Beginner Training Area (Aircraft-Electric) 8 Apr 14, 2012 06:51 PM
Discussion Champ stuck in tree. hosj Beginner Training Area (Aircraft-Electric) 16 Sep 30, 2011 10:14 PM
Discussion Elevator stuck on my new Hobbyzone Champ ! $50 part ?! dllhg Electric Plane Talk 31 Sep 26, 2011 06:46 PM
Discussion Got my Champ stuck in a tree... trying_to_fly Beginner Training Area (Aircraft-Electric) 14 Sep 12, 2011 03:54 PM