Vapor binding trouble - RC Groups
Thread Tools
Dec 10, 2012, 12:51 AM
Registered User
Discussion

Vapor binding trouble


Hello, I have a Vapor BNF which I was using with a Spektrum DX4e transmitter without any problems. For some reason I now cannot get the transmitter and receiver to bind successfully. I have followed the instructions carefully, reset the transmitter and so on but cannot get it to bind at all now.

I have fully charged batts in both Tx and Rx

Any suggestions?

thanks
Sign up now
to remove ads between posts
Dec 10, 2012, 05:39 AM
Registered User
JoeSay's Avatar
This happened to me just a few weeks ago. My DX6i suddenly lost its bind and then wouldn't rebind. Turns out it was the circuit board. Something went randomly wrong so I had to get a new one.

Sorry to Be the bearer of bad news.
Dec 10, 2012, 05:54 AM
Registered User
You may want to try move the Tx farther from your plane, some time too close it also can not bind
Dec 10, 2012, 06:55 AM
Power Wheels Guru
UNGN's Avatar
If it's an original Vapor, and the board doesn't have a green sticker on the board, it uses a different binding procedure from all modern HH planes.

On the Original Vapors, you had only 5 seconds after you plugged in the battery to turn on the TX holding the Bind button... instead of waiting for the Board LED to flash.
Dec 10, 2012, 08:15 AM
Gravity is a harsh mistress.
Tim Wolff's Avatar
The original Vapor bricks were flaky binding even when working properly. Like UNGN said, the binding process is different from the newer generation of bricks.

Turn on the TX in bind mode then promptly connect the battery to the RX.
Move the TX 4 or more ft. away from the RX when binding.
Turn off any 2.4 GHz wireless phones or wireless network equipment that is nearby.
Dec 10, 2012, 09:12 AM
Registered User
Tim Wolff,

I second that procedure. And to do it requires three or four hands. But I can do it with two if I use a rubber band to hold the Bind switch on the TX in the Bind position while I use my only two hands to hold the Vapor and attach the 1S.

Jim R.
Dec 15, 2012, 06:04 AM
Registered User
Worked a treat - thanks guys


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Trouble binding my walkera devo 8s to RX802 brad1601 Radios 7 Sep 20, 2012 11:44 AM
Help! Trouble binding DX7 to AR6100E cassb Radios 19 Jun 15, 2012 03:00 PM
Discussion trouble binding socommk23 Radios 4 Mar 29, 2012 07:39 AM
Discussion Troubles With Vapor`s Binding J. NORBERT Scratchbuilt Indoor and Micro Models 0 Sep 22, 2009 03:21 AM
Question vapor binding troubles bottomofth9th Scratchbuilt Indoor and Micro Models 1 Aug 12, 2008 11:35 PM