Thread Tools
Old Dec 09, 2012, 07:38 PM
Jakethedog is offline
Find More Posts by Jakethedog
Registered User
Discussion

No led light


Hi I have a 2d-3d stabilizer have it all plugged in and it is working but the led won't light up ,did I miss a step I have two plugs left over gain and the one for having duel aleron servo , also my gear is dx7 can some one help I have watched the video 20 times and have read the instructions , and now have my self so confused thanks I really need your help. George
Sign up now
to remove ads between posts
Old Dec 10, 2012, 09:51 PM
Jakethedog is offline
Find More Posts by Jakethedog
Registered User
Does eagle tree look at these threads or do I have to contact them direct ,there web directed me to here ??????
Old Dec 12, 2012, 02:59 PM
billpa is offline
Find More Posts by billpa
billpa's Avatar
Hi, unfortunately that sounds like the LED on your board is not functioning correctly, assuming you are looking through the clear LED window at the TOP of the board.

if this is the case, could you please open a ticket with us at http://ticket.eagletreesystems.com and we'll get the unit replaced for you. Sorry for the trouble!
Site Sponsor


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold HPI Baja 5 LED Light controller and two Baja led lights ronzer Cars - Trucks and Parts (FS/W) 0 Aug 16, 2012 11:46 PM
Discussion eLogger v3 - no LED light roystor Eagle Tree Systems 1 May 06, 2010 02:34 AM
Question Blade mSR help no blue LED light Billv2 Micro Helis 4 Oct 26, 2009 11:11 AM
Discussion WK-0701 Transmitter - NO LED lights, NOT WORKING! nomis23uk Radios 4 Jul 17, 2006 11:37 PM