Thread Tools
Dec 03, 2012, 11:18 PM
STOP CALLING THEM "DRONES!!!"
Captain Ron's Avatar
Help!

Bad lipo


Hello,

I recently purchased a 2 cell sky lipo 5000mah hardcase for my new slash and I can't get the lipo to work properly. When I first received the lipo I checked the cells and they were not abnormal at all. (I don't remember the exact number for each cell) I cut off the red plug that it came with and soldered on a deans plug and charged the lipo up with my thunder charger. I went to the rc track to run my truck and the truck will not go. As soon as I pull the trigger the truck acts like the esc is at low-voltage cut off. The truck just crawls. Both cells are at 4.20 but the battery acts like it is dead. I tried to cycle the battery a few times with my charger but didn't help at all. I plugged in a airplane lipo I use for my planes and the truck works fine. I think I have a bad lipo. Is it possible to return it or exchange it for another?

Here is my order number:

yhst-62196343123315-346392

Thank you .
Ron
Sign up now
to remove ads between posts
Dec 04, 2012, 12:10 PM
HobbypartZ Support
I'll have a RMA sent out to you so you can return the battery to get exchanged, you should be receiving the RMA shortly and it'll have the instructions on how to return the battery.

-Charlie
Dec 04, 2012, 09:40 PM
STOP CALLING THEM "DRONES!!!"
Captain Ron's Avatar
Awesome, I'll be on the lookout for the RMA. I hate to be petty but can I take the deans plug off of the lipo before I send it back? I don't have any more female deans left. Thank you!
Dec 05, 2012, 11:42 AM
HobbypartZ Support
Sure you can go ahead and keep the deans connectors. Make sure to shrink wrap the ends of the wires and tape them separately from each other to the battery so they don't touch while coming back to us.

-Charlie
Dec 05, 2012, 11:19 PM
STOP CALLING THEM "DRONES!!!"
Captain Ron's Avatar
Charlie, I have the battery ready to mail back but still no RMA in my email.
Dec 06, 2012, 11:30 AM
HobbypartZ Support
I emailed it to the email that we have on file for the order. Just in case I PMed you the RMA form.

-Charlie
Dec 06, 2012, 02:20 PM
STOP CALLING THEM "DRONES!!!"
Captain Ron's Avatar
Got the PM thanks!
Dec 18, 2012, 08:15 PM
STOP CALLING THEM "DRONES!!!"
Captain Ron's Avatar
I received my replacement lipo today. I tried it out and so far it seems to be working properly. Thanks for your help RaidenCharlie!


This is the first time I have needed to return something to hobbypartz and I have to say that regardless of the bashing I hear about hobbypartz or nitroplanes customer service my problem was handled perfectly. I had a problem, I contacted someone, they issued an RMA, I returned the item and was given an exchange. Thanks Hobbypartz.com and RaidenCharlie!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Is this behavior a sign of a bad lipo cell? Fred Methot Batteries and Chargers 15 May 11, 2012 05:36 PM
Help! When do lipos go bad? cadcyg Scratchbuilt Indoor and Micro Models 6 Apr 22, 2012 09:40 PM
Discussion Bad Day with new Venom Lipos wagondriver42 Racing Boats - Electric 47 Apr 22, 2012 01:12 PM
Discussion Will lipo go bad on first charge N2RYD Batteries and Chargers 3 Apr 01, 2012 02:05 PM
Discussion Brand New Lipo with bad / low voltage cell... NorCalMatCat Batteries and Chargers 10 Mar 05, 2012 03:59 PM