Thread Tools
Jun 05, 2013, 06:32 PM
swiss fpv beginner
Prefect's Avatar
Juhu, got new OrangeTX and RX hodules from hobbyking.

I flashed them again, this time with the 5V pin plugged out of the FTDI adapter.

Flashing worked, I can access the serial-menu on the tx (cool stuff kha! :-)

Binding only works half the way through: I can enter binding mode on the TX (rapid beeping), plug in the RX and the first and shortly after the second LED lights up. But the TX never exits binding mode and the blue LED does not come up.

What am I doing wrong?
Sign up now
to remove ads between posts
Jun 05, 2013, 06:39 PM
Registered User
Turn off TX and then back on, should bind!
Jun 05, 2013, 07:27 PM
swiss fpv beginner
Prefect's Avatar
I tried binding many times. I turned off the TX every time, pressed the button, switched on the Turnigy 9XR and let go the button after a second. Beeping starts, but it never turns on the blue led.
Jun 06, 2013, 12:46 AM
kha
kha
openLRSng haxor
Quote:
Originally Posted by Prefect View Post
I tried binding many times. I turned off the TX every time, pressed the button, switched on the Turnigy 9XR and let go the button after a second. Beeping starts, but it never turns on the blue led.
To enter normal mode you just turn TX on without pressing the button.

Also note that the TX blue led will not light up until it receives PPM from the radio, i.e. if there is switch/throttle warning shown the TX won'd activate.
Jun 06, 2013, 03:22 AM
Registered User
EricBx's Avatar
Couldn't we make a thread to report result of antenna and firmware combination ?
Style :
Firmware : OpenLRSNG 2.1 / Tx : Nagoya 771 / Rx : ReadyMade RC Sander Style / Distance reached : : 800m.
Jun 06, 2013, 05:42 AM
Build to Fly? FLY to BUILD!
Legot's Avatar
Quote:
Originally Posted by EricBx View Post
Couldn't we make a thread to report result of antenna and firmware combination ?
Style :
Firmware : OpenLRSNG 2.1 / Tx : Nagoya 771 / Rx : ReadyMade RC Sander Style / Distance reached : : 800m.
No, because everything depends on the RF environment, a firmware range thread (where antennas and everything are identical) in the same location at the same time of day by one person would be the best indication of which firmware gives more range. The same could be done with antennas (on a constant firmware), but it would be less useful.

Just do your research and use good antennas. "Sander style" antennas are just crappy 1/4 wave monopoles, try converting that into a 1/2 wave dipole and check your range again
Jun 06, 2013, 02:37 PM
Registered User
EricBx's Avatar
Well i'm flying with multis, so i'm not seeking to reach 10km at all, i would just be sure to have 2km which can match the multi autonomy. 1/4 wave sounded "enough" to have that, it's just very disapointing to loose control at 400m... May be i should resell all that crap and stay on 2.4Ghz where the 2km are not a fantasy.
Jun 06, 2013, 02:48 PM
RC beginner
lol! all things equal 433mhz will always have the edge in penetration and free space range over 2.4ghz simply due to laws of physics. of course proper setup required for either to work.
Jun 07, 2013, 12:28 AM
Registered User
EricBx's Avatar
Clearly this is what i was thinking too, but pratically it does not happen. My basic TGY9X 2.4ghz with stock antennnas as more range than the OrangeRx 433 with 1/4wave antennas. So you can laugh but explaining me what i'm doing wrong would be more helpfull.
Jun 07, 2013, 12:41 AM
Registered User
Hi Gang

I've managed to upload Open LRSng 2.0. I've a question with regard to using the Command Line Interface (CLI). I'm able to get to the 'menu' but I'm unable to 'edit parameters'. Specifically, I would like to change the baudrate to 0 for maximum range. If I type '6' I get the message 'Set Baudrate (0-2):'. I type '0' and press enter. I then type '?' and press enter to see 'current settings' but I get nothing. Can someone please step me through this process?

Cheers

Jase
Jun 07, 2013, 03:05 AM
Build to Fly? FLY to BUILD!
Legot's Avatar
Quote:
Originally Posted by EricBx View Post
Clearly this is what i was thinking too, but pratically it does not happen. My basic TGY9X 2.4ghz with stock antennnas as more range than the OrangeRx 433 with 1/4wave antennas. So you can laugh but explaining me what i'm doing wrong would be more helpfull.
You're using 1/4 wave monopoles.
They are crap.

You're welcome
Jun 07, 2013, 03:17 AM
kha
kha
openLRSng haxor
Quote:
Originally Posted by ilovetoflyfpv View Post
Hi Gang

I've managed to upload Open LRSng 2.0. I've a question with regard to using the Command Line Interface (CLI). I'm able to get to the 'menu' but I'm unable to 'edit parameters'. Specifically, I would like to change the baudrate to 0 for maximum range. If I type '6' I get the message 'Set Baudrate (0-2):'. I type '0' and press enter. I then type '?' and press enter to see 'current settings' but I get nothing. Can someone please step me through this process?

Cheers

Jase
There is no need to use '?' just hitting enter should print the settings out.
try changing the linefeed setting to CR/LF (lower right).
Jun 07, 2013, 03:34 AM
Registered User

Open LRS Datalink on 459 MHz


Hi all

I'm new here - but I have been playing with Open LRS quite a bit.

I just got my Open LRS set up working on 459MHz using Nigel's UK firmware with transparent serial bridge for data down to my ground station.

I'm using a 9XR Transmitter, Hobbyking's Open LRS, APM2.5 and APM Planner.

A few things I noticed.

The antenna's that come with Hobbykings Open LRS gear are not much good - I don't think they are a good match at 433Mhz let alone 459Mhz which is what I use them on. I asked Rob at FPV plastics to make me some that match at 459 Mhz with much better SWR. I think getting the right antenna's on these modules is critical.

http://fpvlab.com/forums/showthread....inverted-V-uhf

http://www.fpv-plastics.com/FPV-Plastics/Welcome.html

I haven't range tested them yet but I think they will be loads better than the junk HK are shipping with them.

APM planner will only connect properly if I set the baud rate from the APM to the receiver to 4800. If I set the baud rate to 9600 APM Planner complains when it tries to download the APM parameters - it will connect at 9600 if you press Ctrl T and connect without parameters.

It's fairly straight forward to reduce the number of MAVLINK packets sent by APM by changing the GCS_Mavlink file in the Arduino enviroment and uploading the changes to the APM - APM Planner doesn't seem to complain if you send less packet types - it just doesn't update the variables that you remove from the data stream.

I'm going to have a look at OpenLRSSng next - it looks like I might be able to improve the data rate across the link - which would be great !!

Regards
Chris
Last edited by ChrisWX8; Jun 07, 2013 at 03:40 AM.
Jun 07, 2013, 05:48 AM
throw new IOPilotException();
IceWind's Avatar
@Legot, not necessarily. I'm using 1/4 wave monopoles with my EzUHF kit (low mode) and the range is far more than I'll ever need.

@ChrisWX8, just out of curiosity did you measured or have the results from the ones that come with the KIT for 433Mhz (possibly for 459Mhz as well)?
Jun 07, 2013, 06:16 AM
Registered User
Hi Kha

Worked a treat. Now all I need to do is rebind?

Cheers

Jase

Quote:
Originally Posted by kha View Post
There is no need to use '?' just hitting enter should print the settings out.
try changing the linefeed setting to CR/LF (lower right).


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted Anyone got a good 433mhz UHF RX Antenna? wamdue FPV Equipment (FS/W) 4 Nov 18, 2016 04:06 AM
Question 'Sander' 1/4 wave monopole - correct length for 433MHz UHF? Kahnx FPV Equipment 11 Dec 23, 2013 10:19 AM
For Sale Chainlink UHF system + few matching Rx's i3dm FPV Equipment (FS/W) 0 Apr 22, 2012 06:58 AM
Discussion stiff antenna for 433Mhz UHF Rx ? i3dm FPV Talk 14 Feb 17, 2012 02:25 PM
Sold HK "Orange" Satellite for HK "Orange" Rx rikybob Aircraft - General - Radio Equipment (FS/W) 1 Jan 29, 2011 04:19 PM