DX18 firmware update failure - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Nov 13, 2012, 08:14 PM
Registered User

DX18 firmware update failure

Hello. I am attempting to update the firmware on my new DX18, and it's not going well. I downloaded the firmware, saved it to an SD card, inserted card, powered up transmitter. Next a screen with a progress bar appeared, as expected. The backlight flashed on and off a few times, the bar disappeared, reappeared, disappeared, reappeared. Strange, but there's a note on the download page saying this is normal. After that however, nothing. The radio is stuck with the backlight off, the progress bar on the screen is not updating (going on 10 minutes now). Seems like a borked update. The instructions say not to interrupt the process, but I'm not sure what else to do at this point. It'll be pretty disappointing if the radio is bricked before I've even flown it!

Thanks in advance for any tips/pointers.

Sign up now
to remove ads between posts
Nov 13, 2012, 08:46 PM
Surface, Air & Water Rc Toys..
freechip's Avatar
DX8 and DX18 owner here with plenty of updating experience and never once had any issues with updating.

Yes some of the updates do cause a lot of flashing/disappearing/reappearing to happen but never had one get stuck.
Nov 13, 2012, 09:02 PM
Registered User
Unfortunately I'm not so lucky; over an hour on the dark progress bar screen and it hasn't budged. I guess I'll be on the horn with Horizon in the morning to figure out what to do. Not the first evening with the 18 I was hoping for.
Nov 13, 2012, 09:08 PM
Surface, Air & Water Rc Toys..
freechip's Avatar
At this point being you say over an hour I would if it were my radio removed the SD card and format it. Download the update again making sure not to change the name of the file nor the extension.

Then power off the radio, insert the SD card and reboot the radio and hope this procedure worked out.

That's if this was my radio.
Nov 13, 2012, 09:21 PM
Registered User
Thanks, yeah, tried that right after I posted. I used a different CF card, freshly formatted, downloaded FW from different computer, wrote it with a different card reader/writer, same result. And of course with a partial update done, the transmitter is dead. It's strange that it seems to go ok until it stops... oh well.
Nov 13, 2012, 09:23 PM
Surface, Air & Water Rc Toys..
freechip's Avatar
Hope HH resolves this for you quickly and to your satisfactory.
Nov 13, 2012, 09:28 PM
AndyKunz's Avatar
If you have a different SD card, you ought to give that a try, too.

Here's the sequence they'll tell you on the phone if your update failed.

1) Format card, copy download to it again.
2) Make sure file is named exatly SPMTX.SAX on the card. Select EJECT before removing card!
3) Attempt update.

If update fails in the same manner as yours did:

4) Use a different card.
5) Make sure file is named exatly SPMTX.SAX on the card. Select EJECT before removing card!
6) Attempt update.

I don't think we've had more than 3 or 4 radios that haven't been fixed by this point that I've heard of. And guess what those turned out to be? Yup, the second SD card was bad too.

Nov 13, 2012, 09:40 PM
Registered User
Andy thanks for the reply. I have now tried two SD cards, and multiple sd card writers. Do all previous updates to 1.03 need to be installed in order to install 1.03? I have also tried to format the cards both FAT and FAT32, doesn't seem to make a difference.
Nov 13, 2012, 09:49 PM
Surface, Air & Water Rc Toys..
freechip's Avatar
You don't need to install the older updates, just the most recent.
Nov 13, 2012, 09:50 PM
AndyKunz's Avatar
Only install the latest version. The older versions should all have been disabled. Do NOT go backwards!

The radio accepts FAT or FAT32 just fine. It will take anything from an ancient 512K MMC up to 32 gig MicroSD if you can afford one.

One of the key steps is to click on the Eject for the SD card. This causes the PC to flush the cache to the card immediately. If it doesn't do that, you really only get a partial copy of the SAX file on your SD even though it looks like the whole thing is there.

Nov 13, 2012, 10:01 PM
Registered User
Ok, thanks again. At this point I have tried 3 cards, 2 card reader/writers, 2 filesystems, have ejected every time, re-downloaded the firmware, same behavior. We'll see what they say tomorrow.
Nov 13, 2012, 10:06 PM
AndyKunz's Avatar
How about downloading another copy?
Nov 13, 2012, 10:15 PM
Registered User
Yep, downloaded the EN/DE/FR, and the EN/IT, multiple times
Nov 13, 2012, 10:22 PM
Registered User
This is how the process goes:
update issue (0 min 23 sec)
Nov 14, 2012, 02:12 PM
Registered User
So as expected, the remedy is a trip to the service center. Oh well, it's an r/c transmitter, not a defibrillator; the wait won't kill.

Thanks again Andy and Freechip for the ideas.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-HowTo Update Firmware for Devo TX - Import/Export Devo TX Models - Update Devo RX Firmware Tom Z Micro Helis 22 Jun 28, 2015 01:20 AM
Discussion Phoenix sim update failures tripleup05 Simulators 6 Jun 11, 2013 12:26 PM
Discussion DJI Naza firmware update failure seojeff Multirotor Drone Talk 15 Mar 20, 2012 09:23 AM
Help! Firmware update error with OSD pro ONLY Data Logger and Gardian firmware update works whosthebaddest Eagle Tree Systems 10 Mar 17, 2012 06:26 AM
Discussion Cant use update client or firmware update jaysbay Aerial Photography 6 Nov 07, 2011 11:19 PM