Thread Tools
Nov 12, 2012, 08:13 AM
Rotorhead
Help!

Crius Multiwii SE trouble...


Hi there, all you experienced Multiwii users!

Iīm kinda new to all this multirotor stuff, but slowly learning, so please bare with me...

I have two problems with my Crius Multiwii SE...

Yesterday I used the Arduino app/program to dump the Multiwii_2_1.ino to the board, after making a few tweaks to the config, board type and mode and such...

Or did I...???

I honestly donīt know, because when I fire up the MultiwiiConf_2_1.exe, thereīs no way of getting it to talk to the board, no movements, displays all zeros and generally just plain dead...

Unless...

...I do the .ino dumping and start the MultiWiiConf in one go!
That is, if I donīt unplug the USB/FTDI thing in between, the board and the software make contact and everythingīs fine!

But of course, if I unplug and replug to do some tweaking... no contact at all...

This makes me think that maybe the board doesnīt save the contents of the .ino... Maybe it just resets to... I donīt know... blank!

So, finally, question number one... Is there something I have to do to save the .ino on the board before powering down?


Now for question two... and this is really weird!

I noticed there was a mixup between the pitch and yaw channels when I tried my DX8 with the board, so naturally I double-checked to see if I had made the connection between board and RX wrong. I had not.

So I thought that maybe the top of the OrangeRX DSM2 reciever were mislabeled, you know, a knock-off product from China and all that...
But I checked all RX outputs with a servo and they sure followed the correct sticks and axis...

And then I noticed that the same channel mix-up also occured when I moved the board around!
That is, when I yawed the board by hand one way, it answered with revving up the two rearmost motors, as if countering a disturbance in the pitch axis!
And tilting the board in the pitch axis resulted in revving up of front left - rear right or front right - rear left, as if I had tried to force a yaw movement

It seems like this is some kind of confusion from within the board itself, and I donīt know what to do!

So, is there anything I can do? I just donīt understand this...

Seeing how many hours I spent last night on this, Iīm starting to think I might as well rip this board out and get me a KK 2.0 instead...


..unless you guys can talk me out of such ideas...!
Sign up now
to remove ads between posts
Nov 12, 2012, 08:33 AM
Splat
So when you hook it up to the PC USB port with nothing else attached to the board, does the comm port in the upper left show the port your usb is attached to? Then, if the correct comm is selected, hit START and the board should start talking to the MultiWii config program.
There is a ton of info about these boards in the discussion here called Crius MultiWii AIO boards .
Nov 13, 2012, 10:33 AM
Rotorhead
Yes, if I press start the software and the board are talking just fine...

But only if I first dump the firmware to the board and then start up the MultiWiiConf without disconnectng the USB cable!

As soon as the contact has been broken, I can not get them to communicate at all... Only solution Iīve found is to transfer the firmware again.

Thatīs why Iīm thinking the board doesnīt save the firmware...
Nov 13, 2012, 04:44 PM
Splat
I generally use Artuino 1.0.1 to load the multiWii 2.1 files into the board after I set up the Config.h file with the correct settings for the board type and configuration etc. After that I fire up multiwii config program and run the board. I can unplug the board and plug it back in and the programming is still there. I don't know much about loading the .ino files from the multiwii config program, I am still too new to this.
Nov 13, 2012, 05:28 PM
Registered User
just a guess but you might try mwc 2.0 to read your board without trying to upload anything, sounds like it's not loading the 2.1. i have a different mw board and i was unable to upload 2.1 but it had already 2.0 loaded. did you install the ftdi driver from arduino 1.01? any errors on the upload? also double check that your esc's are connected properly to the board.
Nov 13, 2012, 06:24 PM
Registered User
Mortimer's Avatar
Quote:
Originally Posted by myrslakt View Post
Iīm thinking the board doesnīt save the firmware...
There might be something wrong with your way to proceed.
The following way works perfectly for me: https://www.rcgroups.com/forums/show...postcount=2681
Nov 13, 2012, 07:12 PM
Splat
Mortimer,
That is the process I use and have not had any isue with the board. One its loaded, I can connect to MultiWii config, select the comm port and hit start and its running. I can disconnect everything and fire it up days later and everything still works fine.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Noobie MultiWii SE Troubles brettwal Multirotor Talk 9 Jun 01, 2012 01:39 AM
Discussion Freeflight FF or Crius Multiwii se araz_baldar Multirotor Talk 1 May 16, 2012 05:18 PM
Discussion Help with the CRIUS SE multiwii based board vcazan Multirotor Talk 7 May 07, 2012 04:38 PM
Sold crius multiwii se alcrsh01 Aircraft - Electric - Multirotor (FS/W) 1 Apr 20, 2012 11:09 AM
Sold CRIUS MultiWii SE V2.0 Talajouy Aircraft - Electric - Multirotor (FS/W) 4 Apr 19, 2012 01:06 AM