Thread Tools
Old Mar 29, 2013, 05:18 AM
ridge_racer is offline
Find More Posts by ridge_racer
Registered User
Quote:
Originally Posted by prop bender View Post
I hope they improved the material in the mounting lugs. The last set of 933's I used had very brittle mounting lugs,other than that they worked OK.
That's the first thing I consider with servos nowaday...I hate when the mounting lugs or case breaks.
Sign up now
to remove ads between posts
Old Mar 29, 2013, 11:11 AM
prop bender is offline
Find More Posts by prop bender
Registered User
The only differance I can find between the 933 and the 337 ( without actualy testing ) is the 337 is a tad faster, I like the spects,I worry about the mounting lugs though. Ed
Old Mar 29, 2013, 07:13 PM
beenflying is offline
Find More Posts by beenflying
as much as I can
beenflying's Avatar
Quote:
Originally Posted by prop bender View Post
The only differance I can find between the 933 and the 337 ( without actualy testing ) is the 337 is a tad faster, I like the spects,I worry about the mounting lugs though. Ed
They're using a new plastic now that is much better:
Quote:
Use Japanese raw material to produce outer shell, which is more sturdy and durable and can bear 120℃ temperature.
Old May 08, 2013, 08:54 AM
jaguar1126 is offline
Find More Posts by jaguar1126
Registered User
Hi is there any manual to this VCTRC 3GX Flybarless 3-Axis Gyro?
Old May 08, 2013, 08:57 AM
jaguar1126 is offline
Find More Posts by jaguar1126
Registered User
Hi, is there any manual for this VCTRC 3GX Flybarless 3-Axis Gyro
Old May 08, 2013, 12:45 PM
ridge_racer is offline
Find More Posts by ridge_racer
Registered User
Quote:
Originally Posted by jaguar1126 View Post
Hi, is there any manual for this VCTRC 3GX Flybarless 3-Axis Gyro
http://www.beastx.com/manuals/MICROBEAST_PV_ENG.pdf
Old Dec 08, 2013, 09:34 AM
Luchsalt is offline
Find More Posts by Luchsalt
Registered User

No collective


I am aware that this discussion is old but I am having a problem with the vtrc 3gx/spectrum dx6i setup that I am trying to create on my 450 trex clone.

I have followed the instructions from the manual to the letter and find that the system works perfectly except for a total lack of collective.

I am a complete noob with fbl and wonder if I am missing something really obvious.

Help

Luch SALT
Old Dec 09, 2013, 06:55 PM
ridge_racer is offline
Find More Posts by ridge_racer
Registered User
Quote:
Originally Posted by Luchsalt View Post
I am aware that this discussion is old but I am having a problem with the vtrc 3gx/spectrum dx6i setup that I am trying to create on my 450 trex clone.

I have followed the instructions from the manual to the letter and find that the system works perfectly except for a total lack of collective.

I am a complete noob with fbl and wonder if I am missing something really obvious.

Help

Luch SALT
So basically on step K you set it for -/+12 degs and once you exit setup it doesn't have the same pitch range? Did you set the pitch curve in the tx to 0-100%? Is the radio set to single servo H1?
Old Dec 11, 2013, 05:47 PM
Luchsalt is offline
Find More Posts by Luchsalt
Registered User
Quote:
Originally Posted by ridge_racer View Post
So basically on step K you set it for -/+12 degs and once you exit setup it doesn't have the same pitch range? Did you set the pitch curve in the tx to 0-100%? Is the radio set to single servo H1?
Step k on my instructions for this flybarless unit adjusts tail gain.

The adjustment for collective is on Function D and there is no response from the collective either up or down in order to adjust it!

The cyclic works beautifully reacting to pitch and yaw adjustments instantly but I cannot get the collective to respond at all.

This is a Spectrum dx6i and is set to 0-100% pitch curve and 1 servo 90deg (only other option is 120 deg)


Ah! You have used the microbeast instructions. At step K there IS no collective to adjust. The collective doesnt do anything. Could this be a Spectrum specific problem??

Thanks
I just checked all the steps in the manual again - all correct.
Last edited by Luchsalt; Dec 11, 2013 at 06:19 PM. Reason: Additional information
Old Dec 11, 2013, 09:07 PM
ridge_racer is offline
Find More Posts by ridge_racer
Registered User
Quote:
Originally Posted by Luchsalt View Post
Step k on my instructions for this flybarless unit adjusts tail gain.

The adjustment for collective is on Function D and there is no response from the collective either up or down in order to adjust it!

The cyclic works beautifully reacting to pitch and yaw adjustments instantly but I cannot get the collective to respond at all.

This is a Spectrum dx6i and is set to 0-100% pitch curve and 1 servo 90deg (only other option is 120 deg)


Ah! You have used the microbeast instructions. At step K there IS no collective to adjust. The collective doesnt do anything. Could this be a Spectrum specific problem??

Thanks
I just checked all the steps in the manual again - all correct.
Are you sure you are using version 1 of the microbeast manual?
Old Dec 14, 2013, 11:51 AM
Luchsalt is offline
Find More Posts by Luchsalt
Registered User
Hi Thanks for replying again

I am using, firstly the manual supplied with the vctrc fbl unit, then I checked on the instructions supplied by you above in order to understand your reference to 'K' but neither seem to work.
Last edited by Luchsalt; Dec 14, 2013 at 11:51 AM. Reason: spelling mistake
Old Dec 14, 2013, 02:02 PM
prop bender is offline
Find More Posts by prop bender
Registered User
Quote:
Originally Posted by Luchsalt View Post
Step k on my instructions for this flybarless unit adjusts tail gain.

The adjustment for collective is on Function D and there is no response from the collective either up or down in order to adjust it!

The cyclic works beautifully reacting to pitch and yaw adjustments instantly but I cannot get the collective to respond at all.

This is a Spectrum dx6i and is set to 0-100% pitch curve and 1 servo 90deg (only other option is 120 deg)


Ah! You have used the microbeast instructions. At step K there IS no collective to adjust. The collective doesnt do anything. Could this be a Spectrum specific problem??

Thanks
I just checked all the steps in the manual again - all correct.

Hi! I used to fly with a dx6i, it seems to me I set the swash on one servo 120 degres for a collective pitch heli. Try that. It will either work or prove I have a faulty memory
Old Dec 21, 2013, 05:22 PM
Luchsalt is offline
Find More Posts by Luchsalt
Registered User
Hi, Thanks for that. I tx does not allow for that - in fact the only two options are 1 servo 90deg or 3 servo 120deg.

So no joy at the moment.

I think I will try another make of radio system - I have a KDS k7x11 but need to buy another receiver, I will report back soon.
Old Jan 07, 2014, 08:01 AM
Luchsalt is offline
Find More Posts by Luchsalt
Registered User
I have tried the KDS tx/rx combo with the vctrc 3gx and success first try - so it appears to be a Spectrum specific problem.

Thanks for the help
Old Jan 07, 2014, 04:49 PM
prop bender is offline
Find More Posts by prop bender
Registered User
Quote:
Originally Posted by Luchsalt View Post
I have tried the KDS tx/rx combo with the vctrc 3gx and success first try - so it appears to be a Spectrum specific problem.

Thanks for the help
Glad to see you have it sorted out


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion ALZRC 3GY V2/Robird G31 Flybarless 3-Axis Gyro beenflying Mini Helis 1974 Aug 07, 2016 12:24 PM
New Product Vctrc 3gx fbl keris Mini Helis 2 Sep 20, 2012 12:41 AM
Alert Hobby King NEW 3 Axis Gyro Flybarless system w/USB Programmer $45 Mahu Hot Online Deals 6 Jun 20, 2012 04:45 AM
Discussion Hobbyking ZYX 3-Axis Flybarless System Gyro old4570 Electric Heli Talk 4 Mar 15, 2012 11:18 PM