E_Logger v4 and Osd Pro Error!! - RC Groups
Thread Tools
Oct 20, 2012, 02:25 PM
Registered User

E_Logger v4 and Osd Pro Error!!

Hi Guys my problem has started a week ago

when i connect to eloggerv4 to my laptop via usb port it works and computer recognize it but if i connect osd pro to e_loggerv4 the flash on elogger doesnt work and computer doesnt recognize it system says "Usb Device Not Recognized"

Pls Help me What should i do?
Sign up now
to remove ads between posts
Oct 21, 2012, 12:47 PM
Seems like a lot of us have/ had the same problem,
Oct 23, 2012, 01:36 PM
billpa's Avatar
Hi - sorry you're having an issue. Unfortunately, it sounds like either your OSD Pro or eLogger have failed. Is there a chance that high voltage (12V) was allowed to contact one of the OSD Pro or eLogger's I/O pins?

Regardless, if you could open a ticket with us at http://ticket.eagletreesystems.com, and reference this thread, we'll work with you to get this resolved.
Oct 24, 2012, 03:40 PM
Fly Seaplanes
Fviking's Avatar


I have a 4 year old elogger V3, a GPS and a video OSD, worked fine.
I moved it to a new plane and up dated the software and firmware. now only the logger works my computer doesn't see the OSD and GPS.

I also have a new elogger V3 with a OSD Pro, GPS and stabilization. Same thing.
I updated the software and firmware and now my computer sees only the logger.

Are there known issues with Windows 7 Pro 64bit OS??

I have tried swoping the logger between the Video OSD and the OSD Pro without the other stuff and my PC doesn't see the OSD either of them.
I am really tired of the "there is no OSD board connected bla bla bla. When there is.

Any help would be appreciated;
Oct 29, 2012, 07:25 PM
billpa's Avatar
Hi FViking, sorry to hear about your issues.

To confirm, when you connect the OSD pro or the video OSD to either of your eLoggers, and run "Firmware Control," "Not Connected" appears under the OSD listing?

Is it possible you have the OSDs connected to the wrong port of the eLogger? Please refer to page 6 in the manual here if needed.
Oct 31, 2012, 05:55 PM
Fly Seaplanes
Fviking's Avatar
No. The GPS goes in the top, theled blinks, USB to computer in the middle and OSD in the xcd/tx on the bottom, The Elogger is blinking 3 times, I adjusted the sample rate to 10 a second. I saved the .set file and sent it to support as per their instructions.

Beats me.
Nov 02, 2012, 08:02 PM
billpa's Avatar
Hi, yes, that's the correct hookup. We'll work with you through the ticket system to get it sorted.
Nov 13, 2012, 02:05 PM
Fly Seaplanes
Fviking's Avatar
No one is working with me on this problem. I have waited over a week for some kind or reply.
I emailed support again early this morning and no response as of 2PM. today Tuesday
Last edited by Fviking; Nov 13, 2012 at 03:04 PM.
Nov 13, 2012, 02:46 PM
billpa's Avatar
Hi, sorry you have not heard back from us. Could you give me your web ticket #?

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Eagle tree V4 Elogger and Osd pro everything working except throttle monitoring? whosthebaddest Eagle Tree Systems 5 Mar 19, 2014 05:50 PM
Question OSD Pro, eLogger V3, GPS V4 problems updating firmware in OSD Pro jbfoamy Eagle Tree Systems 23 Jun 02, 2012 03:59 PM
Sold Eagle Tree Systems OSD Pro, GPS V4, eLogger V4, and Guardian constantmotion FPV Equipment (FS/W) 8 Apr 15, 2012 11:26 AM
Found Eagle Tree OSD Pro V4 dustydonnay FPV Equipment (FS/W) 4 Feb 28, 2012 03:44 PM
Question Elogger V4 Throttle connections with osd pro whosthebaddest Eagle Tree Systems 1 Feb 23, 2012 09:36 PM