Shop our Airplanes Products Drone Products Sales
Thread Tools
Mar 06, 2013, 03:10 AM
Registered User
Quote:
Originally Posted by e_lm_70
LiPo + USB can be risky.

In a quadcopter, with no servo connected, it is way better to use only USB for power the board ... USB has enough power for allow board and RX to work fine. On top ... the propeller will never ever spin ... so no risk at all

If you plug USB and Battery (this will use the BEC of one or more ESC), if the voltage has a difference .. like 6v BEC ... you may damage either the board or your computer ....

Thanks guys! That information would also be useful at the OP.
Sign up now
to remove ads between posts
Mar 06, 2013, 05:46 AM
Registered User
Quote:
Originally Posted by Sir Alex
@e_lm_70,
Your propellers destroyed by your hand. Because you used totally untested development sources!
ups - does not make sense.
totally untested stuff should NEVER appear in a repo.

will cause a drop of the level of trust
Mar 06, 2013, 06:10 AM
Aleksey Kharlanov
Quote:
Originally Posted by robert b
ups - does not make sense.
totally untested stuff should NEVER appear in a repo.

will cause a drop of the level of trust
It's not totally untested. All versions tested at least by me. But there is lot of boards/ESC/receivers or other stuff. I cannot physically test all things.
Mar 06, 2013, 06:13 AM
Registered User
Quote:
Originally Posted by robert b
ups - does not make sense.
totally untested stuff should NEVER appear in a repo.

will cause a drop of the level of trust
Saying untested is 100% bulls

2.9.1 MegaPirate, for APN 2.5 is out since a while

Multiple people report to have no problem using MegaPirateNG 2.9.x ... so ... it is tested ... and the base, is mega tested ... NG is just porting the base from APN board to other one.

Make it sense now ?



ps: Enough virtual ink lost on this topic ... but ... I don't accept to pass like a dummy that I'm not ...
Mar 06, 2013, 09:14 AM
Registered User
Donjuanzx9's Avatar
My quad looks right in flight planner and everything works correct in testing but pitch is reversed?
Should I just reverse my pitch on my Tx or am I missing something?
I'm using megapirate 2.7 R4 on a new hobbyking multiwii pro /GPS.
Last edited by Donjuanzx9; Mar 06, 2013 at 09:40 AM.
Mar 06, 2013, 11:25 AM
eak
eak
Registered User
If you are runing stable 2.8r3
put your quad level. then yaw to the left for 15 sek (untill the lights start to flash so maby count to onethousand twenty )
wait untill it stops flashing you are done.

Quote:
Originally Posted by squiggy2
Sorry if this has already been answered, it seems to be a common problem, but I haven't found a solution anywhere yet.

When I try to calibrate accelerometers in Mission Planner it doesn't give me any commands, it just hangs on "command received".

I went to CLI mode and typed
setup
level
And it gave me the accel and gyro offsets, but what do I do with them?
Mar 06, 2013, 11:27 AM
eak
eak
Registered User
Quote:
Originally Posted by Donjuanzx9
My quad looks right in flight planner and everything works correct in testing but pitch is reversed?
Should I just reverse my pitch on my Tx or am I missing something?
I'm using megapirate 2.7 R4 on a new hobbyking multiwii pro /GPS.
yes. pitch is reversed in APM for soe odd reason for everyone. just reverse tx.
Mar 06, 2013, 11:30 AM
eak
eak
Registered User
You know there is alot of stuff they need rewrite and alot is changed every time. it can't be done over night. And porting introduces new bugs because maby orignal version takes asumptions in their code and such things.

Quote:
Originally Posted by e_lm_70
Saying untested is 100% bulls

2.9.1 MegaPirate, for APN 2.5 is out since a while

Multiple people report to have no problem using MegaPirateNG 2.9.x ... so ... it is tested ... and the base, is mega tested ... NG is just porting the base from APN board to other one.

Make it sense now ?



ps: Enough virtual ink lost on this topic ... but ... I don't accept to pass like a dummy that I'm not ...
Mar 06, 2013, 12:31 PM
Registered User
Quote:
Originally Posted by e_lm_70
Saying untested is 100% bulls

2.9.1 MegaPirate, for APN 2.5 is out since a while

Multiple people report to have no problem using MegaPirateNG 2.9.x ... so ... it is tested ... and the base, is mega tested ... NG is just porting the base from APN board to other one.

Make it sense now ?



ps: Enough virtual ink lost on this topic ... but ... I don't accept to pass like a dummy that I'm not ...
ups, quite a few stuff inside does not make to much sense.
to me it is not well tested
haven't tested/flown since more than a year because of fly-aways ...
Mar 06, 2013, 01:18 PM
Registered User
Donjuanzx9's Avatar
Quote:
Originally Posted by eak
yes. pitch is reversed in APM for soe odd reason for everyone. just reverse tx.

Thanks,
I wanted to try a test flight but that was the only thing holding me back.
When I try to calibrate the Acc in planner it sometimes hangs but shows level in planner so I think its fine.
Mar 06, 2013, 03:11 PM
Registered User
Quote:
Originally Posted by robert b
ups - does not make sense.
totally untested stuff should NEVER appear in a repo.

will cause a drop of the level of trust
Only by people that cannot understand that it is unreleased software, in beta, and not for general use.

If you chose to use unreleased software, you do so at your own risk. It isn't difficult to understand. If you don't know how to properly test the behaviour of this software with your gear, before flying, you shouldn't use it.

I am using MPNG 2.9 and have had no problems but I did test it carefully before flying and for each mode that I use.
Mar 07, 2013, 06:54 AM
Registered User

Help please :)


Well just built my first quad, the hquad from flite test. Calibrated esc's individually as suggested but now all connected up all my dt750's just judder/stutter and don't move. I tried disconnecting a motor and tried a cheap suppo 2012 which worked fine.
Any ideas?
Cheers,
Nick
Mar 07, 2013, 07:40 AM
eak
eak
Registered User
Quote:
Originally Posted by Shorty
Well just built my first quad, the hquad from flite test. Calibrated esc's individually as suggested but now all connected up all my dt750's just judder/stutter and don't move. I tried disconnecting a motor and tried a cheap suppo 2012 which worked fine.
Any ideas?
Cheers,
Nick
Sorry I dont understand your post.
Mar 07, 2013, 07:48 AM
eak
eak
Registered User
Did you hawe the motors connected to the escs when calibrating? They work as speakers for ESC. Did they work before calibrating? Hawe you tried to reset all ESC to factory settings. Did they work? Did you try to recallibrate escs. When I program my escs I put y servo leads in a tree to all ESC. Plug battery in so they power up and programming them all. I use opto ESC cheaper and no need to cut middle servo lead wire off.
Last edited by eak; Mar 07, 2013 at 08:00 AM.
Mar 07, 2013, 08:12 AM
Registered User
I bought everything new from HK. I did try before calibration but all just stuttered. Calibrated each esc individually with the spare suppo motor I had and each esc worked with that the suppo motor.Put the dt750 back on and still stutters???
MMMMMM, what to do?
Cheers,
Nick.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion [UNOFFICIAL] New HobbyKing MultiWii PRO Flight Controller w/MTK GPS Module benybee UAV - Unmanned Aerial Vehicles 418 Nov 20, 2015 07:32 PM
Help! PROBLEM on Crius AIO Pro Y6 With MegaPirate NG 2.7 R4. RQuad Multirotor Drone Electronics 3 Jan 22, 2013 12:13 AM
Found MultiWii PRO Flight Controller w/MTK GPS Module Koo Aircraft - Electric - Multirotor (FS/W) 4 Oct 10, 2012 11:47 PM
Yippee! New AirStudio universal Flight Controller for Mega Pirate NG and MultiWii AirCopter Multirotor Drone Electronics 44 Sep 10, 2012 04:56 AM