Thread Tools
Oct 14, 2012, 05:15 PM
Registered User
Discussion

Brown out! Loss of a new model.


Hey there kids. Well here we are again. I'm afraid it has happened again. Although this time it was not pilot error this time it was a bona fide brown out.

Today I put my lovely Kyosho ME109 in the air and she was flying beautifuly albeit a little underpowered. She was running 6 servos so I used a fully charged life battery to power the Spektrum AR6200 receiver. It was great until I took her high, rolled her onto her back and dove whilst levelling out. It was all going so well and she was almost level when I noticed no response from any of the controls. I thought she was level enough to maybe hopefuly skid across the runnway but alas she was in many peices. It certainly didn' t look like a plane any more.

As I walked the walk of shame I tried moving the sticks and low and behold life returned. Earlier the range check went well so I was not worried. My Spektrum DX8 is like new. I learned how to bind ages ago. I've been so cautious lately that I'm beside myself. How did it go wrong?????

I truely feel this is not my fault but that of the manufacturers. Has anyone ever won a dispute on a faulty product? Kind of bummed out.

On a brighter note though. I went on to have 3 more flights with my starmax f18 which were fun, exciting stress free flights. It uses an Orange receiver and I gotta tell you... I trust it more than I trust the name brand at the moment.

Thanks for listening guys.
Sign up now
to remove ads between posts
Oct 15, 2012, 05:13 AM
Registered User
HELModels's Avatar
I've read that more than 3 servos on 3s without a seperate BEC will cause the brownout, but I'm not speaking from first hand experience. Crashing aint no fun and that I do know first hand.
Oct 15, 2012, 09:50 AM
Redacted per NSA "suggestion"
dedStik's Avatar
OP mentioned using a seperate LIFE battery for the RX so I doubt the BEC or too many servos were the issue.

Would help to know if there was RX flashing going on when the plane was recovered.
Oct 15, 2012, 11:57 AM
Registered User
hey guys.

The receiver wasn't flashing that I had noticed. As I recall it was on. It certainly wasn't flashing when I started out. I've had that happen before.
Oct 15, 2012, 01:24 PM
3D? I only got two thumbs!
Have you tested that life battery under load (the same load that 6 servos plus receiver would draw) to see if it maintains it's voltage under load?
Oct 15, 2012, 07:10 PM
I think I'm inverted. Maybe.
acetech09's Avatar
A 6.6fv LiFe shouldn't EVER sag below brownout voltage even on Spektrum recievers. Even if the LiFe flat dead, it should've sagged to maybe 4.5v... I think a less-than-perfect battery's at fault.
Oct 16, 2012, 09:29 AM
Registered User
HELModels's Avatar
Quote:
Originally Posted by dedStik
OP mentioned using a seperate LIFE battery for the RX so I doubt the BEC or too many servos were the issue.

Would help to know if there was RX flashing going on when the plane was recovered.
Right you are, I read it as "life" as in a fresh battery.

Just this morning I gained personal experience with a BEC that decides it needs to shutdown and stop supplying power to Rx and servos - Smash.
Oct 17, 2012, 11:40 AM
Registered User
These are some things to think of for sure but. The battery is still full of charge and I haven't done anything new since the crash. It's a 1700 mah life battery too. So I dunno. I'm sending the receiver back to Horizon as we speak. At the moment I just don't know.

Thanks for the help guys.
Oct 18, 2012, 07:59 AM
An itch?. Scratch build.
eflightray's Avatar
Just a guess, but was the elevator horn on the underside ?

If so when/if she is repaired, try holding full up elevator and gently press down on the elevators trailing edge.

Sometimes manufacturers do not brace a push rod or snake enough to stop it flexing and allowing the elevator to move down under higher speeds.

A 'pull' is always better than a 'push' with a control, they just look prettier if stuck out the way on the underside, but they must not flex, or .........
Last edited by eflightray; Oct 18, 2012 at 08:02 AM. Reason: Additional comment.
Dec 03, 2012, 11:12 AM
Registered User

Crash Post Mortem! BEC


I had a AcroMaster that suddenly insisted on pulling straight up when I hit the throttle! It also started hating right hand turns and stalled at a good rate of speed from a good height into the ground!
I replaced it with a FunCub It also Pulled Up with throttle and on the first flight spiraled into the ground in a Right Turn!!!!!

I was Unable to duplicate the issue on the ground, and it was Not a Range Issue.

The Castle Creations 50 Amp ESC was old tired and became faulty!
When I replaced it.... I now have complete control!
Dec 24, 2012, 05:13 PM
Depron Daz
Daz393's Avatar
Is your AR6200 a true Spektrum Rx? I bought a couple and have had brown outs. Fortunately the one in my EF 58" Extra was intermittent and kept coming back quick enough to recover from a high wide turn. They are now in the bin. Don't believe that they were original kit and the internet and some shops I hear are full of fake 6200s. I now pay the full price from an authorised Spektrum dealer.
Dec 26, 2012, 01:11 AM
Registered User
Detroit Dave's Avatar
I moved my DX-7 to my park flying planes. I put 3 planes in that I couldn't explain why. All were glow planes with 6 volt, high MaH ratind receiver packs. They also had been recently cycled. Lost a Great Lakes Bipe, a Mud Duck Sport, and a Fokker DR-I triplane. The Fokker will get replaced, but it won't see 2.4 gigahertz.
The Mud Duck went free flight seconds after take off. I had just given it a touch of rudder or it would have flown straight away. It made a circle that must have been close to half a mile in diameter. The wind finally lifted one wing and it went in on a knife edge. It was in the air close to three minutes and I never got any control back at all. Couldn't even shut down the throttle.
I have flown 2.4 with orange receivers and Lazer Toyz, 6 channel receivers and haven't had any problems with them, but those are mostly small planes and park flyers.
Bought a bunch of 72 Megahertz receivers and I'll be flying them with the planes that I value. Hard to give something up when it works.

Dave
Jan 01, 2013, 06:44 PM
Registered User
Will the Castle Creations CapPack prevent Brown-Outs?????
Jan 01, 2013, 06:52 PM
Registered User
pda4you's Avatar
I don't think this was a brownout - with a LiFe pack of that size you should have had gobs of power. I worry about your "underpowered" comment and wonder if that was not helping. An inverted maneuver to boot.

Having a hard time with your brownout analysis. I think something else is amiss here.

Mike
Jan 02, 2013, 09:49 AM
I think I'm inverted. Maybe.
acetech09's Avatar
Quote:
Originally Posted by andrew26842
Will the Castle Creations CapPack prevent Brown-Outs?????
No, the capPack reduces voltage spikes between the battery and the ESC.

What you want is this: http://www.hobbyking.com/hobbyking/s...Protector.html


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Brown out, Hold, Loose wire or Something Else? wayfaringdreamer Electric Plane Talk 4 Aug 17, 2012 12:30 PM
Question Do Analog Servos brown out when used with a Digital Radio? Cathay Stray Radios 89 Aug 09, 2012 02:46 AM
Help! AR600 AND AR8000 browning out/rebooting, but not blinking? -= GYRO =- Radios 19 Jun 16, 2012 12:45 PM
Discussion Brand New HK OrangeRX brown out/signal fade geekrawker Radios 11 Apr 09, 2012 04:20 PM
Discussion Plane crash after Spektrum 2.4 signal loss! Was it brown out? Stuart Warne Crash Discussion 11 Oct 02, 2009 08:46 PM