Thread Tools
Oct 08, 2012, 01:27 PM
Registered User
tbonebrown's Avatar
Thread OP
Discussion

After crash my F-27Q Stryker won't go full power


Hello guys,

I wanted to see what some of you thought about this issue. I crashed my Stryker awhile back and now after piecing it back together, it appears to have lost a lot of power. The motor, ESC, new prop, and RX seem to be fine, no physical damage to them. When I go to fly the plane (even at take-off) it barely has enough power to fly at full throttle. Any ideas on what could be the issue?

Maybe the ESC needs to be fully reset or something happened to it? If so, how would I do that? Maybe the motor has been damaged and I just can't tell? I'm not sure and looking for ideas.

FYI - The plane is 100% stock.

Your thoughts and/or troubleshooting tips are greatly appreciated!

Thank you,

t.bone
Sign up now
to remove ads between posts
Oct 08, 2012, 01:32 PM
Registered User
xrx1113's Avatar
did you mess up the battery? test all 3 cells individually.
try taking the motor apart there may be dirt or somthing else mucking it up.
you may have pluged in the esc with the raido on and throttle at full and messed up the programming.
Oct 08, 2012, 01:39 PM
Registered User
tbonebrown's Avatar
Thread OP
No, I've tried multiple batteries and I have all of them balanced and charged correctly. I'm thinking the ESC needs to be reset. Do you know how I would go about resetting the ESC programming?
Oct 08, 2012, 01:40 PM
Registered User
tbonebrown's Avatar
Thread OP
I'll go take apart the motor though, right now. I'll bring back the exact model number of the ESC as well. I thought I googled how to reset the ESC and but had no luck. I may have to look again.
Oct 08, 2012, 03:03 PM
Redacted per NSA "suggestion"
dedStik's Avatar
If it's stock this should be your ESC.

http://www.horizonhobby.com/products...sc-EFLA1040#t6

Manual for that esc http://www.horizonhobby.com/pdf/EFL4...CInstSheet.pdf
Oct 08, 2012, 03:07 PM
Registered User
tbonebrown's Avatar
Thread OP
Yup, that's it! I've been working on resetting it but it still does not appear to have as much thrust as it used to. I'll have to fly it tonight or sometime soon to find out if it works or not. I'll report back on whether the ESC timing change worked or not.

If anyone else has ideas, please feel free to let me know what you're thinking.

Thanks!
Oct 08, 2012, 03:23 PM
Registered User
do you have meter to test volts or amps? a tach to test rpms? a scale to measure thrust?

with those, you wouldn;t have to risk your plane to see if it was working. without those, we are left to guess at things like the prop being on backwards.
Oct 08, 2012, 03:25 PM
Balsa is for doll houses
Skrogg's Avatar
Quote:
Originally Posted by RedLine19k
do you have meter to test volts or amps? a tach to test rpms? a scale to measure thrust?

with those, you wouldn;t have to risk your plane to see if it was working. without those, we are left to guess at things like the prop being on backwards.


I know its a dumb question but are you sure you have the prop on the right way?
Last edited by Skrogg; Oct 08, 2012 at 03:27 PM. Reason: redline beat me to it
Oct 08, 2012, 03:35 PM
Wake up, feel pulse, be happy!
Piece's Avatar
... Prop on backwards was my first thought, too.
Latest blog entry: Jeti ESC resto-mod
Oct 08, 2012, 03:59 PM
Registered User
tbonebrown's Avatar
Thread OP
Wow..that's something I didn't even think about to be honest! I'll look at that. Boy would I feel like a dumb @$$ if that was it. :-)

I have a tach but that's it. I will order up a volt meter. I have one but I don't have one for RC stuff. I assume there is something that sits between the ESC and the motor, correct?
Oct 08, 2012, 04:04 PM
Registered User
yep. often called wattmeter. inline ones for bench testing, logging ones for inflight readings. really a must-have for troubleshooting, protecting and optimizing power systems.

this one does it all and ships US, but i've never used it. quality ?

These guys are forum spnsors (i think) and might be driving distance
Last edited by RedLine19k; Oct 08, 2012 at 04:12 PM.
Oct 08, 2012, 04:10 PM
Registered User
tbonebrown's Avatar
Thread OP
I'll order that one when I order some more batteries for this week! Thanks! That one review seemed pretty positive.

Yup, the prop is on correctly. The flat edge is the to the back of the plane. The lettering "6x6" is facing the front the plane, the motor, in this case. Glad is wasn't that...or hold on...maybe I should be hoping that was the issue! hehehe

I'll fly it tonight and or tomorrow and see how she goes.
Oct 08, 2012, 04:25 PM
Registered User
lol, all HK reviews up for more than a few days are positive.

it looks like mile high RC sells "the same one" (see link above) and might be close.. i couldnt; find an actual address on the website

in the mean time...
a bent shaft or jammed bearing could rob power (high amps, low rpm,vibration)
slipping collet adapter (no high power, squeals, eventually falls off)
*ESC throttle range not set correctly (normal, just no "top end")

all the other reasons (loose battery connection, damaged ESC) would have more obvious, intermittent symptoms you;d have found by now.

i'm out of ideas. good luck.
Oct 08, 2012, 04:36 PM
Redacted per NSA "suggestion"
dedStik's Avatar
Are you sure the prop is on correctly? The lettering usually isn't direction specific.

Concave side should be toward the read of the craft. Note not facing the rear, but pointing away from plane.
Nov 03, 2014, 01:25 AM
Registered User
tbonebrown's Avatar
Thread OP

Need help..again


Hey folks,

I'm not sure this Stryker is pulling enough thrust so I thought I would revisit this thread and see if anyone can give me some help?

Do these number look correct on the WattMeter? Also, does the prop appear to be in the right direction? I tried it both ways and this seems to push the plane a little more. Any input would greatly be appreciated.

I'm running a 3S battery on this plane.

Thanks,

Thomas


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion flaps on my Stryker F-27Q mcg526 Parkflyers 4 Jun 06, 2012 03:05 AM
Discussion V400D02 won't go full throttle WickedWolf Electric Heli Talk 6 May 19, 2012 07:19 PM
For Sale Parkzone Stryker F-27Q Forsale - LPU - Going to Joe Nall shadow102 Aircraft - Electric - Airplanes (FS/W) 4 Apr 26, 2012 08:59 AM
Discussion PowerLab 8 won't auto discharge after charge (won't cycle) martinwinlow Revolectrix 6 Apr 08, 2012 05:26 AM
My Axi 2212/34 won't go full speed!!! joffacn Power Systems 5 Jun 15, 2004 09:53 PM