DJI F450 failsafe problem - RC Groups
Thread Tools
Sep 28, 2012, 01:20 PM
Registered User
hartrockets's Avatar

DJI F450 failsafe problem

HI Guys,

I have brought a DJI F450 quad from a friend who did not like it and only flew it a few times.

It flies lovely, but the failsafe is not working now,

The failsafe was set so on hitting failsafe it would just land immediately, and this worked for the first few weeks.

But then when I went to land last week on failsafe it landed but did not shut off the motors as normal.
I took it off failsafe and the motors still just kept running at idle speed.

As soon as I hit the fail safe again the motors went to full throttle.

I have loaded the DJI assistant and everything seems to be set correctly and I have re calibrated the Radio (DX8)

It still flies fine in all modes but as soon as I touch fail safe it just goes full throttle.

Also after 3-4 minutes of flight I get a flashing red light with the occasional long flash.

Any ideas?

Currently flying stock setup with 10 inch props on 3s 2200 lipo.


Sign up now
to remove ads between posts
Sep 29, 2012, 02:58 AM
Registered User
try to rebind the receiver in the fail safe position of the stick.
You should bind the receiver when the throttle stick is down.
Sep 29, 2012, 05:54 AM
Registered User
hartrockets's Avatar
The throtle was fully down when binded, but have rebinded to check and still the same.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! DJI f450 with Naza Problem mmnnxx101 Multirotor Drone Electronics 6 Sep 14, 2012 04:26 PM
Discussion DJI Naza - DJI F450 or XAircraft X650? totality Multirotor Drone Talk 14 Jun 25, 2012 02:59 AM
Sold DJI Flame Wheel F450 White/Black frame x2 timecop Aircraft - Electric - Multirotor (FS/W) 5 Dec 13, 2011 10:50 PM
Found Wanted: DJI F450 'Flaming Wheel' Frame daign Aircraft - Electric - Multirotor (FS/W) 4 Dec 07, 2011 12:52 PM
Sold DJI F450 frame tc3wins Aircraft - Electric - Multirotor (FS/W) 4 Nov 19, 2011 04:19 PM