Hobbyking KK2.0 Multi-rotor LCD Flight Control Board will not arm. - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Sep 26, 2012, 07:44 AM
Registered User
Discussion

Hobbyking KK2.0 Multi-rotor LCD Flight Control Board will not arm.


Yesterday I fitted a Hobbyking KK2.0 Multi-rotor LCD Flight Control Board (V1.2) to my newly constructed Quad.

I have been through the complete setting-up procedure but cannot get the FC to Arm.

The Hobbyking 30A Blue Series ESCs were first programmed with the appropriate programming card before connecting to the FC.
Receiver checks are all OK- direction and travel. FC correctly set-up for Quad X and motor rotation.

ESC calibration was then performed as per instructions. Tx ON, Throttle to Max, hold down buttons 1 & 4 apply power. 4 sets of double beeps followed by a musical tone (to the best of my recollection). The throttle was then put to minimum resulting in a single tone. Power to the FC was then disconnected and transmitter switched off.

Now, when I apply power to the FC the LCD shows Self Level Off, OK, and battery 0.0 (no battery connected). However when I switch on the transmitter and apply minimum throttle and right rudder (as instructions), the board will not arm and remains at Safe and OK. Arm and Self Level set to 'Sticks'.
All menus seem to be OK but, and I do not know if this is an anomaly, when I apply minimum throttle and LEFT rudder I hear constant beeps.
Anyone any ideas please?

Thanks
Sign up now
to remove ads between posts
Sep 26, 2012, 08:27 AM
AVR Dude
Beeping on LEFT rudder is expected.
Have you checked your subtrims and that you are only set to 100% ATR on your transmitter yaw?
Sep 26, 2012, 09:51 AM
Registered User
Sounds like what my 2 boards did....

It'll boot up, but go into rx test, does it say no signal? If so, it's the same as mine. I found that the board will turn on with just about any ol' ESC, but for some reason, it would only turn on and read a receiver input on some of my ESC's. I had to keep trying different ESC's to find one that worked, even though they're ALL HK 20 amp models, the exact same.

Then just run power to M1, leave the red wire off the rest of the esc's.

The one that gets my board to boot has different arming beeps. Not sure whats up with that. Also adding a cap to the power side of the board had no effect

ORRRRRR.....

This one tricked me the other day too... Went to arm, get nothing. Go to receiver test, and it's reading ok, just the numbers seem low.

Oh right, I had dual rates on low.... flip of a switch on the radio and I'm in the air.
Sep 26, 2012, 08:10 PM
Registered User
I had the same problem.
Try connecting the battery and in less then 1 second, move the throttle stick to the right.
It works for me.
If you disarm it, then it can not be rearmed again until you disconnect the battery.
Hope this works for you.

Lloyd
Last edited by lquick; Sep 26, 2012 at 08:47 PM.
Sep 27, 2012, 08:42 AM
Registered User
lougedo's Avatar
hello
I had the same problem too, it does not want to ARM.

it worked if i quick conect the battery a move the rudder to the the left (itīs reverse the way to arm it, how can ia change it?), but it canīt not disarm...
Sep 27, 2012, 08:49 AM
Registered User
lougedo's Avatar
Playing with servo jittering and it worked sometimes, but a few times only. I donīt know what happens, if is the servo or what, but if i choose arm On it work just fine

sowftware problems of this new update 1.2 iīm thinking
Sep 27, 2012, 09:37 AM
AVR Dude
^
When you check Receiver Test in the KK2 menu, is throttle between 0 and 100 and yaw between -100 and +100. It won't arm/disarm if throttle is not 0 and yaw throw is too low or too high (for yaw, too low may be when you have low rates and too high may be when you have ATR way above 100%)
Sep 27, 2012, 09:54 AM
Registered User
lougedo's Avatar
yes, my throttle is on 0 idle, and the same for all the channels, 0
Sep 27, 2012, 10:17 AM
AVR Dude
Quote:
Originally Posted by lougedo
yes, my throttle is on 0 idle, and the same for all the channels, 0
What is your max and min yaw values?
Sep 27, 2012, 05:08 PM
we dont NEED roads!
AcroFPV's Avatar
Perform a Sensor Calibration and then try.

Check the sensor test & see if any of them report "NOT OK"

If a sensor is not okay, the board will not arm.
Sep 27, 2012, 05:16 PM
Registered User
lougedo's Avatar
When arrive at home will check the limits of the yaw.

Yes, i did various sensors check, and always they were fine, all ok

Thanks for the reply's
Sep 27, 2012, 11:50 PM
Registered User
To determine if it's a hardware issue, I'd try setting the KK2 to arm automatically, and check if it works then. Make sure the sensors are CALIBRATED, if they aren't it won't arm. Now, go to reciever test, and make sure you get values of +/- 100 (and correct reversal) for yaw.
Sep 28, 2012, 12:18 AM
Registered User
reset your rudder trim. from one side to the other, until it arms. Do the same to make sure it will disarm.
Sep 28, 2012, 02:44 AM
AVR Dude
I have performed a test to check the operation with extended travel on my yaw.

On my DX8, I set the yaw servo travel to 150% (maximum). In KK2 receiver test, I checked the values it recorded for rudder. Right went up to -143 at full right yaw. However Left went up to 146 and then went to 0 at full left yaw. This resulted in being able to arm the kk2 but unable to disarm it.

Equally, if receiver test left and right yaw max readings do not go above +/-50 on full yaw stick deflection, you remain in the "safe area" so won't be able to arm / disarm.

And, of course, to be able to arm / disarm, throttle should be 0 idle in receiver test.
Last edited by Steveis; Sep 28, 2012 at 02:56 AM.
Sep 28, 2012, 07:23 AM
Registered User
lougedo's Avatar
I works now!!

I did a new model, resetting all data on my DX7 and the same on the kk2, check the EPA on the KK2 to get full -100 to 100 in all channels... but it didnīt want to arm either.

So i replace the Rx with a Orange spektrum compatible 6ch and it WORKS perfect everytime now.

Thank you all


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Where to mount Hobbyking KK2.0 Multi-rotor LCD FCB josephr Multirotor Drone Electronics 8 Apr 26, 2014 10:36 AM
Discussion Hobbyking KK2.0 Multi-rotor LCD Flight Control Board MoRaLeSD Multirotor Drone Talk 5 Apr 09, 2014 12:05 PM
Discussion Schematic of "Hobbyking KK2.0 Multi-rotor LCD Flight Control Board" MHefny Multirotor Drone Electronics 60 Jun 29, 2013 01:45 AM
Question V-Tail Quad copter with HK KK2.0 Multi-Rotor Control Board horst1903 Multirotor Drone Electronics 3 Dec 16, 2012 12:14 PM
Sold Hobbyking KK2.0 Multi-rotor LCD Flight Control Board Cobra68 Aircraft - Electric - Multirotor (FS/W) 4 Sep 14, 2012 01:40 PM