Fms brushless motor isn't working - RC Groups
Thread Tools
This thread is privately moderated by Caturiaj, who may elect to delete unwanted replies.
Sep 11, 2012, 09:20 PM
Registered User

Fms brushless motor isn't working

I just recieved my giant yellow p 51 today
Upon completion of building I turned on the remote hooked up the battery
And everything worked except the motor I check all the plugs to make sure
I didn't miss something multiple times. Even pulled the motor to check the wires
from there but no luck is there something else I can do or am I the proud owner of a lemon? Excuse the gramer and spelling.
Thanks Jim
Sign up now
to remove ads between posts
Sep 11, 2012, 11:03 PM
I live my life 12oz at a time
arnav's Avatar
What sort of beeps is the ESC making? I will be surprised if it is the motor. For example, is the ESC making a continuous beep-beep-beep-beep non-stop?
Sep 12, 2012, 05:43 AM
Registered User
Yes it is a continuous beep. Then if I give it throttle it stops but the motor does nothing. I tried inserting the throttle plug in the opposite direction into the transmitter but that resulted in no power at all to the plane. The motor is a kv500 with a speed Controller 65A Brushless ESC w/ 5A SBEC Controller System 2.4GHz Multifunctional Transmitter and Receiver I'm not sure what version this plane is, but from what I've been reading the electronics are no good in these planes. Is this a matter of just replacing the ESC?
Sep 12, 2012, 08:09 AM
I live my life 12oz at a time
arnav's Avatar
I still bet ya everything is ok. You just need to set it up correctly.

A continuous beep could mean:
- The Rx is not bound to the Tx. Are the control surfaces moving? If not, forget the motor and first make sure your control surfaces are moving by making sure the Rx is bound correctly.

- If your control surfaces are moving, it could be the Throttle is not at the lowest most position so the ESC's fail safe kicks in. Make sure the throttle and the throttle trim is all the way down.

- Did you try another battery? If the battery cells are not balanced, the ESC may not arm.

- Does the motor spins freely by hand?
Sep 12, 2012, 09:18 AM
Registered User
It was the throttle trim!
I wish I could buy you a beer right now, thank you very much!!!
Sep 12, 2012, 11:20 AM
I live my life 12oz at a time
arnav's Avatar
haha, my pleasure... Enjoy!

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion My Tamiya Hornet isn't working!!! MarcazzarSmish Off-road Cars 10 Apr 27, 2012 07:24 PM
Help! My motor isn't working but my servos are! Please help! Ecibob Beginner Training Area (Aircraft-Electric) 6 May 21, 2011 03:15 AM
Discussion HZ Cub isn't the easiest plane to fly on FMS... gyrokiteguy Beginner Training Area (Aircraft-Electric) 9 Jun 21, 2009 12:36 PM
Discussion Isn't it about time submariners used brushless motors ? jaguar75 Castle Creations 2 May 11, 2009 04:16 PM
Discussion Motor isn't working, everything else is. problem? 7ender Power Systems 7 Dec 28, 2008 04:48 PM