Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
Old Sep 11, 2012, 06:07 AM
doc.maunz is offline
Find More Posts by doc.maunz
Registered User
Help!

Guardian defective?? Leveling AHI needs seconds


Hi Guys,

I have problems with my Guardian. It needs about 5 seconds to level the AHI correctly after just moving the plane at the bench. I tested it in two different planes. It has nothing todo with vibrations (occurs also with motor off).

First it was placed directly side by side to all the other RC stuff in my small Easyglider... so I thought the problem has to do with some interference.
But now it`s mounted with lots of space and different rc parts in my new X8 an the problem still exists.

Please see this short video:



guardian (1 min 16 sec)



I am running the latest beta 1.43 software and reflashed the guardian firmware.

Is there anything else I can do? Could it be a defective sensor within the guardian?


cheers
Sebastian
Last edited by doc.maunz; Sep 11, 2012 at 03:38 PM.
Sign up now
to remove ads between posts
Old Sep 11, 2012, 08:25 AM
doc.maunz is offline
Find More Posts by doc.maunz
Registered User
here some additional informations:

ET connection scheme:
eLogger V4 -> GPS
eLogger V4 -> OSD -> Altimeter -> Guardian

Firmware:

elogger 1.21
OSD 2.66
Guardian 1.19
Altimeter 1.06
Old Sep 11, 2012, 08:40 AM
Crist Rigotti is offline
Find More Posts by Crist Rigotti
First to go over 106K feet
Crist Rigotti's Avatar
Try turning up the overall gain from 0 to 8. I noticed that when you displayed your menu at 27 seconds.
Old Sep 11, 2012, 09:26 AM
doc.maunz is offline
Find More Posts by doc.maunz
Registered User
Quote:
Originally Posted by Crist Rigotti View Post
Try turning up the overall gain from 0 to 8. I noticed that when you displayed your menu at 27 seconds.
Hi,

Thanks for your reply Crist!

I tried this out but the problem still exists. It needs 5-6 seconds to go back to level after just a few movements.

The "overall gain" setting was set to 0 by me because I need "elevon mixing / stabilization" set to on (Skywalker X8 plane) but without stabilization. Unfortunately I would like to use stabilization and RTH but with this (perhaps defective ??) guardian it will crash the plane...

I donīt know what to do anymore... should I send it to Eagletree for inspection? Itīs just 4 month old and it never worked.

cheers
Sebastian
Old Sep 11, 2012, 03:01 PM
billpa is online now
Find More Posts by billpa
billpa's Avatar
Hi Sebastian,

Sorry to hear about the problem. If it is not too much trouble, could you rock the plane's wings at moderate/fast speed, and make a short video showing how the Guardian responds to that?
Site Sponsor
Old Sep 11, 2012, 03:37 PM
doc.maunz is offline
Find More Posts by doc.maunz
Registered User
Quote:
Originally Posted by billpa View Post
Hi Sebastian,

Sorry to hear about the problem. If it is not too much trouble, could you rock the plane's wings at moderate/fast speed, and make a short video showing how the Guardian responds to that?
Hi Bill,

here it is:

guardian test xx (1 min 9 sec)
Old Sep 13, 2012, 01:41 PM
billpa is online now
Find More Posts by billpa
billpa's Avatar
Hi Sebastian,

Thanks for posting the video. We would like to get your Guardian in-house for further examination, and for replacement. Could you please open a ticket with us at http://ticket.eagletreesystems.com, and reference this thread? Sorry again for the trouble!
Site Sponsor
Old Sep 17, 2012, 03:58 PM
GregSilver is offline
Find More Posts by GregSilver
Registered User
GregSilver's Avatar
Bill, there are a bunch of people getting this issue now.

Was there a batch of bad guardians or is this software related?
Old Sep 17, 2012, 08:02 PM
billpa is online now
Find More Posts by billpa
billpa's Avatar
Hi Greg,

We are tracking 3 reports of issues that appears to be similar. Note that one key symptom of the issue is that when rocking the wings (or just the guardian) rapidly, the AHI will only sluggishly follow the movement, and the AHI may rotate slowly forever when the model is sitting perfectly still (it's normal for the AHI to take some time to recenter after movement).

One has arrived here, and two are inbound. The one that arrived is failing our test procedure now, but passed that test procedure when it was shipped. The nature of the failure in this one suggests it's something we can address with a firmware update and customer procedure, if we do start seeing more, and the issues turn out to be related and not related to physical damage. We'll know a lot more when we have all 3 units in-house.
Site Sponsor
Last edited by billpa; Sep 17, 2012 at 08:59 PM.
Old Sep 18, 2012, 01:19 PM
doc.maunz is offline
Find More Posts by doc.maunz
Registered User
Quote:
Originally Posted by billpa View Post
Hi Greg,

We are tracking 3 reports of issues that appears to be similar. Note that one key symptom of the issue is that when rocking the wings (or just the guardian) rapidly, the AHI will only sluggishly follow the movement, and the AHI may rotate slowly forever when the model is sitting perfectly still (it's normal for the AHI to take some time to recenter after movement).

One has arrived here, and two are inbound. The one that arrived is failing our test procedure now, but passed that test procedure when it was shipped. The nature of the failure in this one suggests it's something we can address with a firmware update and customer procedure, if we do start seeing more, and the issues turn out to be related and not related to physical damage. We'll know a lot more when we have all 3 units in-house.
Hi Bill. I have sent you my Guardian today via airmail from Europe. I hope it will arrive soon and you can fix this issue...

Cheers
Sebastian
Last edited by doc.maunz; Sep 18, 2012 at 01:26 PM.
Old Sep 30, 2012, 04:35 PM
doc.maunz is offline
Find More Posts by doc.maunz
Registered User
Hi Bill,

any news here? My support ticket was set to "closed"...

Cheers,
Sebastian
Old Oct 01, 2012, 01:50 PM
billpa is online now
Find More Posts by billpa
billpa's Avatar
Hi Sebastian,

I checked on this. The ticket will be reopened (which will send you a notification) when we receive your Guardian. Airmail can sometimes take a while (but is pretty reliable).
Site Sponsor
Old Oct 05, 2012, 11:29 AM
aaronredbaron is offline
Find More Posts by aaronredbaron
Spektrum Dev Team
aaronredbaron's Avatar
mine is wacked out too, I've almost given up on it, but I would love it if there is a fix... I don't have this setup in the same airframe anymore, but it still acts the same way.
Eagle Tree OSD Guardian Stabilizer acting weird (1 min 19 sec)
Old Oct 05, 2012, 11:46 AM
doc.maunz is offline
Find More Posts by doc.maunz
Registered User
My Guardian arrived at ET last monday (some hours after Bills last post here) so I think we will get some information soon...



cheers
Sebastian
Old Oct 05, 2012, 03:50 PM
billpa is online now
Find More Posts by billpa
billpa's Avatar
Hi aaronredbaron, that is definitely not correct behavior!

Could you let me know a few things:
a) Did this suddenly start happening, or is it something that's always been this way?
b) When did you purchase the unit, and from where?
c) When the model is sitting on the ground, does the AHI stay level? If so, when you rev the motor, does the AHI then move around? If so, the issue could be either RFI or (less likely) too much vibration.
Site Sponsor


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Need help choosing a second heli! james0742 Beginner Training Area (Heli-Electric) 6 Jul 10, 2012 01:02 PM
Discussion Need advice on my second glider sahil80 Beginner Training Area (Aircraft-Electric) 4 May 14, 2012 02:42 PM
Whoops! A few seconds in the air, need good props. nabiul Multirotor Talk 3 Apr 15, 2012 12:28 AM
Help! AHI Cal Wizard with Guardian!!! alexvan Eagle Tree Systems 0 Sep 29, 2011 04:37 PM
Question Which model to get for a second level? rafcab Foamies (Kits) 7 Sep 27, 2008 07:00 PM