Shop our Airplanes Products Drone Products Sales
Thread Tools
Feb 17, 2013, 02:29 PM
2 seconds from crashing
indoorheli's Avatar
Quote:
Originally Posted by aesmith
Cheers. It could still be blade balance, the feathering shaft looks straight using the "take one blade off and rotate the shaft" test. I'll try loosening it. What's the best way to check blade balance? I was getting nowhere trying to think up a way.
To get the correct tightness tighten all the way then back off while rotating the blade grip until the notchy feeling goes away.

On balancing if you have an ultra precise scale i would start there. If they weigh the same you could then check CG per blade on a pencil or something similar and see if they match.
If both are correct then you could add a small piece of tape to one blade and see if it gets better or worse.. Start out with a very small piece and if you dont notice a difference add another piece until you see it get better or worse. if it gets worse you know you have to correct the other blade.
Sign up now
to remove ads between posts
Feb 17, 2013, 03:14 PM
I'd rather be flying!
turboparker's Avatar
Quote:
Originally Posted by indoorheli
To get the correct tightness tighten all the way then back off while rotating the blade grip until the notchy feeling goes away.

On balancing if you have an ultra precise scale i would start there. If they weigh the same you could then check CG per blade on a pencil or something similar and see if they match.
If both are correct then you could add a small piece of tape to one blade and see if it gets better or worse.. Start out with a very small piece and if you dont notice a difference add another piece until you see it get better or worse. if it gets worse you know you have to correct the other blade.
+1!

That's the method I use on these micros. Works quite well.

Joel
Feb 17, 2013, 03:34 PM
when down=up, up=expensive
whichwaysup's Avatar
Quote:
Originally Posted by aesmith
Cheers. It could still be blade balance, the feathering shaft looks straight using the "take one blade off and rotate the shaft" test. I'll try loosening it. What's the best way to check blade balance? I was getting nowhere trying to think up a way.
Have you crashed it a lot? If so and if you eliminated all the other possibilities, then you may have a sprung main shaft. If you have very significant vibration at low rpm take the blades off and spool it up very slowly. If you still have any vibration your shaft is bad.

I recently replaced my main shaft and can't believe the difference. And then I went out with 20 mile an hour winds, flying upside down. All went well until the wind caught it and it ended up smashing into my truck. Now my board is bad again. 2 steps forward 3 steps back. But I just bought a used mCPX bl so I think I'll be okay
Feb 17, 2013, 03:53 PM
Registered User
seeingeyegod's Avatar
Quote:
Originally Posted by whichwaysup
Have you crashed it a lot? If so and if you eliminated all the other possibilities, then you may have a sprung main shaft. If you have very significant vibration at low rpm take the blades off and spool it up very slowly. If you still have any vibration your shaft is bad.

I recently replaced my main shaft and can't believe the difference. And then I went out with 20 mile an hour winds, flying upside down. All went well until the wind caught it and it ended up smashing into my truck. Now my board is bad again. 2 steps forward 3 steps back. But I just bought a used mCPX bl so I think I'll be okay
Interested in hearing how you do with the mCPX though
Feb 17, 2013, 03:55 PM
when down=up, up=expensive
whichwaysup's Avatar
Quote:
Originally Posted by seeingeyegod
Interested in hearing how you do with the mCPX though

I'm a lost cause!
Feb 17, 2013, 04:17 PM
Registered User
i812's Avatar
Quote:
Originally Posted by whichwaysup
I'm a lost cause!
Join the club

Quote:

I might have been a biker if I hadn't spent all my money on drugs.
Feb 17, 2013, 05:33 PM
Registered User
After much tinkering and reading, I have managed only to get my MSRX setup and working with my modded 9x and DSM2 module. My Nano CPX is a horse of a different color, to borrow a phrase from my mother. The template provided some pages ago did not work and I deleted it from the radio. I tried to create a model from scratch for it, but find myself staring at it like someone in the fifties would stare at a cell phone. Perhaps I'm in too deep as far as this hobby goes. Does anyone have this setup actually working? Where did you find out how to set everything? A combination of sources? Help! Everything that I have tried has ended in failure. I abhor failure.
Feb 17, 2013, 07:24 PM
Safety : practice & promote!
RoboHeli's Avatar
Quote:
Originally Posted by elkabong80
After much tinkering and reading, I have managed only to get my MSRX setup and working with my modded 9x and DSM2 module. My Nano CPX is a horse of a different color, to borrow a phrase from my mother. The template provided some pages ago did not work and I deleted it from the radio. I tried to create a model from scratch for it, but find myself staring at it like someone in the fifties would stare at a cell phone. Perhaps I'm in too deep as far as this hobby goes. Does anyone have this setup actually working? Where did you find out how to set everything? A combination of sources? Help! Everything that I have tried has ended in failure. I abhor failure.
Mine is working fine. I assume you have er9x if you're using a dsm2 module? I just translated my dx6i settings over after using my blade 4ch model as the template. I could send you my eepe model if you want.
Feb 17, 2013, 08:04 PM
Registered User
Alex4R's Avatar
I ordered a set of airtime landing gear not too long ago, and it came in the mail yesterday. Opened her up and found that he sent me two sets! they look sick. I love the lo profile look. assembly/install was easy enough. Hardest part for me was snapping the hangers onto the skid. It's tight, you have to wiggle it a lot and stretch the hanger then use quite a bit of force to snap them in. They pressed into the frame no problem. Lighter than my KBDD's also.
Feb 17, 2013, 08:09 PM
Billy
+1 on the airtime skids. Already taken a beating on my nano...

These damn swash plate's on the other hand are made out of butter. How do the alloy one's hold up? Which brand should I buy? I was just going to get the MH kit, but they don't seem that highly regarded on the 130X forums.
Last edited by Billz_01; Feb 18, 2013 at 01:45 AM.
Feb 18, 2013, 02:20 AM
RC Aircraft Junkie
jlk69's Avatar
Quote:
Originally Posted by Billz_01
+1 on the airtime skids. Already taken a beating on my nano...

These damn swash plate's on the other hand are made out of butter. How do the alloy one's hold up? Which brand should I buy? I was just going to get the MH kit, but they don't seem that highly regarded on the 130X forums.
I bought a Microheli swash and have had no problems with it. Plus you can convert to a rear anti-rotation bracket because swash has a pin coming off rear swash arm.
Feb 18, 2013, 07:04 AM
Registered User
Quote:
Originally Posted by whichwaysup
Have you crashed it a lot? If so and if you eliminated all the other possibilities, then you may have a sprung main shaft. If you have very significant vibration at low rpm take the blades off and spool it up very slowly. If you still have any vibration your shaft is bad.
It's smooth with the blades removed.
Feb 18, 2013, 07:43 AM
Registered User
Quote:
Originally Posted by RoboHeli
Mine is working fine. I assume you have er9x if you're using a dsm2 module? I just translated my dx6i settings over after using my blade 4ch model as the template. I could send you my eepe model if you want.
That would be great! I tried using a combination of the settings in the manual for the dx6i and the er9x manual, but couldn't make the two mesh together and found myself clueless when it same to setting throttle and pitch curves and the throttle hold. I just couldn't figure it out. I appreciate your help! I seem to be experiencing a heli related mental block.
Feb 18, 2013, 12:42 PM
Registered User
Quote:
Originally Posted by elkabong80
After much tinkering and reading, I have managed only to get my MSRX setup and working with my modded 9x and DSM2 module. My Nano CPX is a horse of a different color, to borrow a phrase from my mother. The template provided some pages ago did not work and I deleted it from the radio. I tried to create a model from scratch for it, but find myself staring at it like someone in the fifties would stare at a cell phone. Perhaps I'm in too deep as far as this hobby goes. Does anyone have this setup actually working? Where did you find out how to set everything? A combination of sources? Help! Everything that I have tried has ended in failure. I abhor failure.
I'm flying the Nano with a 9x, OrangeRX DSM module, and Open9x software. Happy to share my settings if that helps. I don't suppose the difference between ER9X and Open9x is significant. Here's a print out attached if I can get it to work, but be aware that this a beginner's settings and I don't use the idle up mode (so I only use Curve 1 and 4 for throttle and pitch).
Feb 18, 2013, 02:12 PM
Registered User
seeingeyegod's Avatar
Does anyone else have this issue where occasionally using the DX4e, throttle hold won't work? It is always when I crash into something and the blades are making contact, usually spinning the heli on the ground like a headless chicken, scuffing up the blades. I will sit there banging on throttle hold and it won't shut the damn thing down! It is like when the ESC is heavily loaded it (or the RX part) can't hear the signal you are trying to send. Is this an issue with the DX4e or the nano?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Cool Walkera MiNi CP - Smallest 100 sized 3D helicopter zadaw Micro Helis 6166 Nov 19, 2016 11:57 PM
Discussion is there anything better than mcpx v2 at same or smaller size? Legendary_Agent 3D Electric Heli Flying 33 Feb 24, 2012 08:46 PM
Question Whatís Better than a Blade CP and Smaller than a Trex? HavingFun2002 Micro Helis 74 Mar 05, 2006 05:07 PM