Thread Tools
Oct 10, 2012, 09:39 AM
Registered User
Quote:
Originally Posted by Nosepo
Excellent job Yangˇˇˇˇ

Please remember your old costumers with nova osd.
We will be very pleased if you can add the rssi with % value and the gps raw data in the screen like you make it in the Storm osd.
soon
Sign up now
to remove ads between posts
Oct 10, 2012, 03:42 PM
mucho FPV
RocketMouse's Avatar
extraline
Any chance that we will see throttle control + air speed version one day? It would be a dream! )
And two ailerons support....
Oct 10, 2012, 10:49 PM
mmerry2 on Youtube
mike_m2's Avatar

what is the USB device for Firmware update?


If you download the v.1.02 firmware from http://www.bevrc.com/download/STORM%...%20upgrade.zip it describes how to install the firmware. It has a driver for what looks like a special USB device that connects to 4 pin holes on the main OSD board. See the attached pic. Does anyone know where to get this board? I have one of these USBasp devices from HobbyKing. I wonder if it could be wired to work with this. Anyone know?
Oct 10, 2012, 11:00 PM
mmerry2 on Youtube
mike_m2's Avatar
Quote:
Originally Posted by mike_m2
If you download the v.1.02 firmware from http://www.bevrc.com/download/STORM%...%20upgrade.zip it describes how to install the firmware. It has a driver for what looks like a special USB device that connects to 4 pin holes on the main OSD board. See the attached pic. Does anyone know where to get this board? I have one of these USBasp devices from HobbyKing. I wonder if it could be wired to work with this. Anyone know?
I think I found the answer to my own question. Bevrc sells the USB firmware flashing tool here: http://www.bevrc.com/flash-tool-for-...eosd_p305.html There is a comment that says it works for flashing the Storm OSD.

Here is a pic:


I still want to know if the USBasp device from HobbyKing can be used to flash it. Anyone know?


The HK device has 10 pins, with a 6-pin adapter. The Storm OSD only has 4 pin holes shown for upgrade. Perhaps there is a way to connect these?
Last edited by mike_m2; Oct 10, 2012 at 11:11 PM.
Oct 11, 2012, 05:31 AM
Registered User
Quote:
Originally Posted by iskess
Lee8sec,
Did you get your Storm?
We are eagerly awaiting your report. Is your DOA too?

There must be a bunch out there flying, why is this thread so quiet? Is it just that good?
We need more reports on the best valued OSD ever sold.

Away working at the moment. Wont be able to test now until next month.
Oct 11, 2012, 05:37 AM
Fatshark Repairs AU/NZ
hpcoolahan's Avatar
mine should bet tested this weekend or the next , weather depending
Oct 11, 2012, 07:49 AM
RTFM
octane81's Avatar
I'm going out testing 1.02 firmware later today.
Oct 11, 2012, 01:30 PM
RTFM
octane81's Avatar
Here guys , test of the new v1.02 ... awesome!

Review of Cyclops Storm v1.02 OSD (13 min 43 sec)
Oct 11, 2012, 02:48 PM
FPV in Hawaii
iskess's Avatar
Quote:
Originally Posted by octane81
Here guys , test of the new v1.02 ... awesome!

http://www.youtube.com/watch?v=w2YdcJ7P6pI
Great video!
Everything seems to be working well.
Nice job Yang.

If I may nitpick a little, I have some suggestions.
I find the altitude and speed ladders useless and a waste of space. They should work like the compass does, where the compass headings move along with the scale. All heads up displays show the numbers moving along the ladder so the scale has some meaning. Seeing little white hash marks move alone doesn't really tell me anything. See the attached examples so that you no what I mean. Name: ImageUploadedByTapatalk1349984085.509440.jpg
Views: 228
Size: 36.8 KB
Description: Name: ImageUploadedByTapatalk1349984094.778761.jpg
Views: 200
Size: 52.3 KB
Description:

My issue with the simple display screen is that flashing H for home. I find the flashing very distracting, and should be used only for warnings like low battery or low RSSI. Is there another way to indicate that Home is behind other than flashing? Maybe a different symbol? I think you should just have a home arrow on the simple display, no compass needed.
I hope you will continue to take suggestions and make this great OSD even better.
Thank you.
Oct 13, 2012, 10:37 AM
RTFM
octane81's Avatar
I did some tests today , can someone explain these test results?
Why does osd and watt meter show that a 2200mAh battery is empty at only about 1527mAh?
I stopped the test at 1527mAh , because the voltage dropped very fast under 10v, and I didnt want to destroy it.

OSD and watt meter show same result ..

Im
Oct 13, 2012, 11:51 AM
Registered User
Quote:
Originally Posted by octane81
I did some tests today , can someone explain these test results?
Why does osd and watt meter show that a 2200mAh battery is empty at only about 1527mAh?
I stopped the test at 1527mAh , because the voltage dropped very fast under 10v, and I didnt want to destroy it.

OSD and watt meter show same result ..

Im
I was always had the understanding that this happens because you have a TOTAL energy of 2200 mAh. You used 1547 of them to get down to around 10 volts, the rest of the mAh lie in the remaining volts. Basically you can only use about 1100-1400mAh of a 2200 mAh battery, to stay within safe lipo/cell voltage parameters. Perhaps I'm wrong but that was my assumption...

You put in more than you discharged because the balancer over feeds and wastes off mAh to acheive a full charge. I never have, but perhaps you could discharge around 1500 mAh again and then do a straight no balance charge and see what you get (seems pretty hard on your batts though/borderline dangerous). maybe it will be closer to the amt discharged if you dont balance it... Again I have never tried it....
Last edited by mrracer98; Oct 13, 2012 at 11:57 AM.
Oct 13, 2012, 12:16 PM
RTFM
octane81's Avatar
I didnt balance charge it ... this was a "fast charge" (you can see this by FST on charger)
Oct 13, 2012, 12:22 PM
Registered User
Quote:
Originally Posted by octane81
I didnt balance charge it ... this was a "fast charge" (you can see this by FST on charger)
sry i see that now... i have no idea... i got theorys but i am sure electrical engineer knows something on here we dont. Id venture to guess it has something to do with the way the charger reads vs what the put into the battery's gotta be different...
Oct 13, 2012, 01:33 PM
Registered User
hi octane81, how did you conect the rssi cable? did you use a resistence between the osd and rx dragonlink?
Oct 13, 2012, 01:39 PM
FPV in Hawaii
iskess's Avatar
Octane, have you tried different batteries. Try a newer one from a different manufacturer.
I would expect that you should be able to get about 1800 out of a 2200 or 80%. After this, the voltage drops very quickly for little mA output.
Last edited by iskess; Oct 13, 2012 at 01:48 PM.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! CYCLOPS OSD 1.5 GPS problem. grassiew FPV Equipment 2 Apr 26, 2013 08:30 PM
Discussion Use the CYCLOPS NOVA OSD System Auto-return function Rc Heli Halle Multirotor Drone Talk 14 Dec 22, 2012 07:08 PM
For Sale For sale Cyclops OSD NOVA Schmoopiebunny FPV Equipment (FS/W) 26 Mar 26, 2012 10:18 PM
For Sale Cyclops Easy OSD V1.6 New In Package stewtheman FPV Equipment (FS/W) 4 Mar 22, 2012 11:08 PM
For Sale burned mainboard Cyclops nova osd parts for sale or trade rellik demanon FPV Equipment (FS/W) 11 Mar 09, 2012 08:13 PM