Strange KK 2.0 Problem - RC Groups
Thread Tools
Aug 19, 2012, 06:03 AM
Registered User
gitit20's Avatar
Discussion

Strange KK 2.0 Problem


Hey guys I think my KK 2.0 had died here is an attached video maybe you can tell me whats going on? it does this in all throttle ranges i installed another controller and everything works fine so had to be something to do with the 2.0.

I have already reflashed it and so on but no go here is a link to the video

KK 2.0 Quadcopter Controller Problem (0 min 33 sec)
Sign up now
to remove ads between posts
Aug 19, 2012, 12:21 PM
Registered User
I have had similar problems. Mine always boiled down to motor and or esc problems. You should see the pile of defective motors and esc I have.
Aug 19, 2012, 03:34 PM
DART
have it ever worked before?
have you preformed throttle calibration?
connect ESC directly to the receiver (of that works the reason is in KK)
try to connect some other receiver channel instead of throttle to see if your transmitter is configured properly and works.

PS: don't forget to remove props by the time everything work fine.
Aug 19, 2012, 07:44 PM
Registered User
gitit20's Avatar
Quote:
Originally Posted by dart50
have it ever worked before?
have you preformed throttle calibration?
connect ESC directly to the receiver (of that works the reason is in KK)
try to connect some other receiver channel instead of throttle to see if your transmitter is configured properly and works.

PS: don't forget to remove props by the time everything work fine.
Yes i did all this and it works fine with my older kk 5.5 black every motor ESC is ok it was flying fine landed and went to take back off and this happened...

Contacted the people i bought the KK from and they are sending me a new one but i still would like to know what happened to this one.

Never had anything like this happen before lol
Aug 19, 2012, 07:46 PM
Registered User
gitit20's Avatar
Quote:
Originally Posted by dart50
have it ever worked before?
have you preformed throttle calibration?
connect ESC directly to the receiver (of that works the reason is in KK)
try to connect some other receiver channel instead of throttle to see if your transmitter is configured properly and works.

PS: don't forget to remove props by the time everything work fine.
Ya i have tried that its defiantly a problem with the KK board too bad too this one handled very well
Aug 20, 2012, 03:10 AM
DART
Quote:
Originally Posted by gitit20
Ya i have tried that its defiantly a problem with the KK board too bad too this one handled very well
Try to clear all settings if you haven't already.
Aug 20, 2012, 03:40 AM
Registered User
gitit20's Avatar
Quote:
Originally Posted by dart50
Try to clear all settings if you haven't already.
I did thanks for the help but its DOA I'm afraid
Aug 20, 2012, 04:55 AM
DART
You can ask KapiteinKUK (or someone else who writes firmware for KK2.0) to write some self-testing algorithm (it will be usable not only for you).
When you figure out what on the board is failing then you can find out how to repair the board.
Aug 21, 2012, 12:13 AM
Registered User
gitit20's Avatar
I did find out if i press down on the center of the board it works fine but as soon as i let off does it again i will try removing the LCD and baking the thing for a few sec see if it re-solders it
Aug 21, 2012, 12:43 AM
Registered User
Google "easy bake oven lap top repair" to get time and temp to bake your board. I did this to fix a lap top and it actually worked!
Aug 21, 2012, 02:54 AM
Registered User
gitit20's Avatar
Quote:
Originally Posted by topforce
Google "easy bake oven lap top repair" to get time and temp to bake your board. I did this to fix a lap top and it actually worked!
Ya i have a small computer shop here in town and i have done that a number of times with great success


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product KK 2.0 Delrin Protection Case Chris Moon Multirotor Drone Talk 327 Feb 12, 2015 12:59 PM
Help! KK 2.0 Set Up For Flying Wing HughesBrothers FPV Talk 4 Aug 31, 2012 04:14 AM
Sold KK 2.0 board, new and unflown Blucross Aircraft - Electric - Multirotor (FS/W) 2 Aug 03, 2012 09:57 PM
Question New KK 2.0 based quad, uncontrollable, what's wrong? mrenouf Multirotor Drone Electronics 5 Aug 01, 2012 03:52 AM
Discussion New on 2.4Ghz; strange problems...help? sammy Radios 3 Mar 11, 2012 11:11 PM