Thread Tools
Old Aug 13, 2012, 04:40 PM
snelan is offline
Find More Posts by snelan
Registered User
snelan's Avatar
Discussion

KK2 Board Throttle On Plug In


So I have this KK2 board that just brings to motors to, i'm guessing 60% throttle when I plug the LiPo in. I have checked my trims on my TX and set the minimum throttle to 0 on the KK2. I have also confirmed that 0 throttle does register as 0 in the settings. The manual doesn't seem to say anything about it. ESC calibration seems to allow a max throttle of 70% and a minimum of 50%. Bad board?

Further, it looks like it killed one of my ESCs...
Sign up now
to remove ads between posts
Old Aug 13, 2012, 05:37 PM
snelan is offline
Find More Posts by snelan
Registered User
snelan's Avatar
Now the screen is completely blank, bad board.
Old Aug 13, 2012, 05:40 PM
Daemon is online now
Find More Posts by Daemon
Registered User
Daemon's Avatar
Sounds like a question for the multi-rotor forum.
Old Aug 13, 2012, 05:48 PM
snelan is offline
Find More Posts by snelan
Registered User
snelan's Avatar
Quote:
Originally Posted by Daemon View Post
Sounds like a question for the multi-rotor forum.
That it does! Gonna post there in a second.

Does anyone know how hobbyking is with returns?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted Mpi on-board electronic glow plug driver HAWKEYE44444 Aircraft - Fuel - Engines and Accessories (FS/W) 2 May 17, 2012 10:33 PM
Help! Anybody work with a Sullivan On-Board Glow Plug Driver? jodini Engines 1 Mar 26, 2008 06:50 PM
Question Motor doesn't run til half throttle on tx and what's this plug? expo Power Systems 14 Jan 04, 2008 11:57 PM
On board glow plug switch? Fishmasterdan DIY Electronics 15 Jun 30, 2005 11:39 PM
any advice on how to keep your esc reiceiver plug soldered up good to the p.c. board? airborn express Power Systems 5 Oct 08, 2003 05:59 PM