Thread Tools
Aug 05, 2012, 03:28 PM
Registered User
SUPERSPORT's Avatar
Thread OP
Question

Any ideas on why my T-28 controls turned to mush?


I've had the PZ T-28 since the beginning. 2007 or 2008. Still using the PZ controller. Every time I would order a receiver for my Futaba 6EX 2.4GHz I'd end up getting a new plane or heli to put it in.

I decided to try the FrSKY receivers from HK. I bought 3.

So I put one in the T-28 and pull out the manual. Been so long I didn't remember but there are no suggested throws in there. I looked around on-line and couldn't find anything. Called HH and was told they don't know. This is the only plane I own that has no throws in the manual. I left high at 100% and put low at 80%. Thought I'd fly it and adjust.

I about couldn't fly the thing. The controls feel like mush. I don't know if it's the throws or the receiver. Did PZ ever put out any suggested throws? Everything looks fine on the ground, could the receiver be slow/unresponsive in the air?
Sign up now
to remove ads between posts
Aug 06, 2012, 06:20 AM
Registered User
Sorry, but I have to call BS on this one. I found the throws in the manual online in less than 30 seconds. I don't even have a T-28 :-)

http://www.parkzone.com/ProdInfo/Fil...480_manual.pdf
Aug 06, 2012, 06:22 AM
Registered User
High rate Low rate
Aileron 13mm up/down 9.5mm up/down
Elevator 16mm up/down 13mm up/down
Rudder 22mm left/right 16mm left/right
Aug 06, 2012, 09:32 AM
Registered User
SUPERSPORT's Avatar
Thread OP
Thanks.

I didn't look up the BNF manual. I was searching forums and such. I even called Horizon and the guy told me they don't suggest throws for the T-28.

Mine is one of the originals. What I call a RTF. Parkzone called it a Charge and Fly. Came with everything. Controller and all. This was before the BNF option.

My manual has no throws. As a matter of fact, and I do remember this, it doesn't even list a CG. That's now listed on HH under important product bulletin.

Anyway, thanks. I'll set the throws and give it another try.
Aug 06, 2012, 01:16 PM
Registered User
Are you sure it is the dual rates and not the expo settings? Expo settings set too low will make the TX stick controls feel mushy.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Forgot to turn off transmitter - any ideas? micka80ella Electric Plane Talk 28 Jul 22, 2012 01:45 AM
Help! Servo suddenly died - any idea why? ravisurdhar Radios 8 May 13, 2012 04:28 PM
My Aiptek SD won't turn on - any thoughts? Peter Young Aerial Photography 5 Feb 05, 2005 01:12 AM
Question Filip 400......any ideas on T tail elevator control? farnboro flyer Electric Sailplanes 7 Jan 22, 2005 09:06 AM