Zero UAV YS-X6 [Owners Thread] *Autopilot system for multirotors* - Page 53 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Nov 04, 2012, 02:25 PM
Registered User
Quote:
Originally Posted by Mr_westie

-Done differently
Do not launch from a confined space, balcony?
Once RTH was enabled, do not touch mode switch.
Agree. While it is flying in Back Landing Mode, do not push throttle to max and then down to 20 as it does nothing. The switch to Manual mode when the throttle was low (20) probably did it. At 4.50 the real time throttle was down to 4 and that is not where the crash took place.

I and a few others I know, have switched over to manual mode while Back Landing, without a problem, but the throttle was still at about 50%.

The problem is in Auto Hover mode, to make it move up or down, it needs such extreme movements.

I know they say in the Manual that if the throttle is low and you switch to manual, the motors will cut off. Now I am not sure how low is low. Maybe it looks like 20 percent is low.

I would like to ask 2 questions, just so we get a clearer picture..

1. Can you tell us what the battery voltage was when this switch over to manual took place (4.46).
2. Can you tell us what the ESC's settings were. Lipo/Nixx and Soft Cut off/no cut off or hard cut off.

Rob
Last edited by robone; Nov 04, 2012 at 02:35 PM.
Sign up now
to remove ads between posts
Nov 04, 2012, 03:16 PM
Down under under
1. 11.64v
Idle start of flight , 12.57v
10s after power up hover, 12.00v

2. Owner will have to answer that.
Nov 04, 2012, 06:05 PM
Registered User
fajar's Avatar
Quote:
Originally Posted by Mr_westie
magetpr's maiden crash

Flight video
http://www.youtube.com/watch?v=2ZGYKJkNuRQ

GCS
http://youtu.be/4CV-4tYHCYc
Note video may not be realtime.

System setup
https://www.rcgroups.com/forums/show...0#post23059155


Good number of sats.
Low shake.

0:41 off axis gps drop
1:15 lift off
4:01 radio loss?
4:15 Back landing (RTH) engaged
4:22 "xekf Velx" peaks at -458
4:32 radio control restablished? .DTB 26m
4:34 "xekf Veld" starts to rise, peaking at -141
4:37 full throttle for 1.5s does not result in alt change
4:44 Low throttle for 1s does not result in alt change
4:46 Switch to manual at low throttle = crash
4:50 impact, throttle off

-Analysis
Depends what you trust more, the AR8000 or YS-X6.
I am going with the AR as failsafe is throttle low and range was less than 70m.
During normal flight minor corrections are seen in "Manual servo position"
At 4:01 MSP input is stalled.
When input is working again throttle does not result in Alt change.
I can not see any reason why the YS would ignore MSP.
The sat signal does appear to go bad at points but not at the same time as stalled input.

Not responding to throttle is a problem.

The bad data the YS was getting may have caused it to ignore MSP


-Warning signs
High "xekf Velx" blip while on ground
High "xekf Velx" blip while on in air


-Done differently
Do not launch from a confined space, balcony?
Once RTH was enabled, do not touch mode switch.
Personally I wont even launch the copter if I found that the xekf velx number was that high. When I crashed mine upon lift off about a month ago I thought it was the system's fault. But I realized that I'd changed my setup the night before so I had inadvertently introduced interferences to the IMU. So I did a couple of ground test and the result was conclusive, source of interferences were affecting the IMU. The fix was really easy, I just repositioned those sources as further away as possible from the IMU and it's all good now.

It is important to note that magetpr's setup included 800mw 1.2ghz vtx. From my point of view, the vtx and possibly other sources might have caused harmful interference to the IMU. Just try that by powering up the copter and move the source of interference close to the imu and read the values of xecf velx in the GCS.

Since the values were not accurate the system didnt perform what it was supposed to do so that may explain the crash.

So perhaps a new protocol could be introduced in which the system would deny throttling up upon take off if the xecf velx value reaches a certain high number just before take off.
Nov 04, 2012, 09:44 PM
Registered User
I have a question for someone.... if I am always seeing a white light when trying to take off, afterreading everything here it seems my vibrations are to high, so the actual question.... Can I extend the LED wires? If I use 4 conductor sheilded wire, another 6 inches or so should be ok? This will take it totally away from everything for the RF noise as I read a few pages ago??
Thanks in advance....

Oh, I am getting rid of the F550 plastic arms unit for aluminum arms, or a new frame altogether
Last edited by hobiej; Nov 04, 2012 at 09:46 PM. Reason: Forgot to add frame details
Nov 05, 2012, 01:13 AM
Registered User
If it were me I would address the vibrations before flying as the possiblity of a crash could be very costly
Nov 05, 2012, 02:19 AM
Registered User
Quote:
Originally Posted by richkphoto
If it were me I would address the vibrations before flying as the possiblity of a crash could be very costly
Well, to be honest, I went through all the setup steps, and I got to the test flight in manual mode, flew perfect, then I saw my vib was around 10 or so, then started to see a white light, landed. Read. Flew again, and when I tried gps mode, it started to shoot straight up, and fast, rechecked vibs, way up in the 20's, and a white light again.... So I landed and started reading some more, And then good old winter showed up and it snowed, so I'm ordering parts, then will try again in the spring, or sooner if we get a nice long chinook
Nov 05, 2012, 07:50 AM
Registered User
I have been battling over the last while (could be a month or two) to load saved waypoints on my Android HTC Flyer Tablet and also on my Samsung S3. Could save but not reload them. Everytime I tried to load it would shut down the app.

It turns out that in South Africa we use the comma as a delimiter instead of a decimal point. So every time it saved the file it saved with a comma as the decimal point and when it came to load, it did not know what it was reading. We finally resolved it today with ZeroUAV and they have revised their App, which is busy being tested. But, for those of you in Europe, South America and South Africa and a few other countries, you must also have been having this problem.

These are the Countries affected (Green) and Blue uses the point (full stop)



I would think that the revised App will be sent out in a few days.

I like the the way the new App has been laid out. It is so much easier to use.

Well done ZeroUAV.
Nov 05, 2012, 03:42 PM
Registered User
hello,
i have a problem of not enough channels. i'm using a 9x with frsky modules with a max of 8 channels.
What i really want to do is have my quad set up to run with 2 controllers. A pilot flying fpv style and a photographer controlling the camera.
So my question is this, can i run 2 2.4ghz systems of one quad, or will the signals interfere with each other, and or shorten my range.
I want to order another 9x and frsky combo for the photographer.
I was thinking of perhaps using a second system on 72mhz, or 30mhz, but it would be easier to just duplicate the stuff i'm already familiar with.
Any help much appreciated !
Nov 05, 2012, 11:07 PM
MULTIROTOR FREAK
hI GUYS

Any one noticed at what time Zero UAV support will be online on SKYPE, I have many clarifications Please let me know
Nov 06, 2012, 02:53 AM
Vulcan skyhook multirotor
Andre6553's Avatar
I know a guy in south africa he is using 2 controllers one for video and one for controlling the drone

http://www.steadidrone.com/

Quote:
Originally Posted by whizz101
hello,
i have a problem of not enough channels. i'm using a 9x with frsky modules with a max of 8 channels.
What i really want to do is have my quad set up to run with 2 controllers. A pilot flying fpv style and a photographer controlling the camera.
So my question is this, can i run 2 2.4ghz systems of one quad, or will the signals interfere with each other, and or shorten my range.
I want to order another 9x and frsky combo for the photographer.
I was thinking of perhaps using a second system on 72mhz, or 30mhz, but it would be easier to just duplicate the stuff i'm already familiar with.
Any help much appreciated !
Nov 06, 2012, 02:13 PM
Vulcan skyhook multirotor
Andre6553's Avatar
How can itbe so quiet here?
Nov 06, 2012, 02:41 PM
saabguyspg's Avatar
well personally I am afraid to fly my WKM lately... and am considering sending it back for checking.

I get white flahes and very poor performance from my one machine, the other is fine.

It's also getting cold so I am staying inside building things

Steve
Nov 06, 2012, 02:44 PM
Registered User
Quote:
Originally Posted by saabguyspg
well personally I am afraid to fly my WKM lately... and am considering sending it back for checking.

I get white flahes and very poor performance from my one machine, the other is fine.

It's also getting cold so I am staying inside building things

Steve
But this is YS thread right? Sold my wkm in lack of trust for latest firmwares. I think YS:s are just playing nice, that's why quiet here.
Nov 06, 2012, 08:11 PM
Registered User
Quote:
Originally Posted by hemanthtguru
hI GUYS

Any one noticed at what time Zero UAV support will be online on SKYPE, I have many clarifications Please let me know
They are based in Beijing so time there is GMT+8 They are open 9am to 5pm but I usually don't see them on Skype until around midday. You can call them on +86-10-57250711 during office hours as well.
Nov 06, 2012, 10:28 PM
Down under under
My one went in for repair.
Waiting for it to come back.
At least another 2 weeks away as no replacement stock
Grounded since 29th Sep

In the meantime I am playing with Autoquad.
Getting close to YS performance.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product DJI WooKong-M Autopilot System for multirotors **Owners Thread** DJI INNOVATIONS Multirotor Drone Electronics 20305 Nov 18, 2017 12:48 AM
Discussion Zero UAV YS-X6 Owners Thread and Discussion fajar Multirotor Drone Electronics 2428 Mar 23, 2016 03:52 AM
New Product Test video of YS-X6 Autopilot system pzhang Multirotor Drone Talk 141 Jun 07, 2012 07:50 AM
Discussion Groupbuy for YS-X6 system fajar Australia 14 May 15, 2012 05:35 AM