Shop our Airplanes Products Drone Products Sales
Thread Tools
Jul 22, 2012, 12:27 AM
eYebox US servicing
E.N.'s Avatar
Help!

Aurora 9 doesn't recognize 2.4 module as AFHSS


Hi,
I have been trying to solve this problem for hours. I am pretty sure the way it started was when I turned the transmitter on and accidentally selected transmit when there was no module plugged into the back of the A9. It switched from AFHSS to ppm. Now, when I plug the 2.4 module back in and turn the radio on, it won't detect it as AFHSS resulting in no telemetry. I have upgraded the module, receivers, and the A9 to the latest firmware and have done a factory reset on the A9 and still no luck. When I go through the initialization screens after a factory reset, the AFHSS shows up but then it asks me what modulation I want to use and wont finish the initialization until I select something else than the AFHSS.

Thanks in advance,
Ian
Sign up now
to remove ads between posts
Jul 22, 2012, 01:01 AM
Registered User
[QUOTE=E.N.;22230122] Hi,
I have been trying to solve this problem for hours. I am pretty sure the way it started was when I turned the transmitter on
and accidentally selected transmit when there was no module plugged into the back of the A9. It switched from AFHSS
to ppm. Now, when I plug the 2.4 module back in and turn the radio on, it won't detect it as AFHSS resulting in no telemetry.
I have upgraded the module, receivers, and the A9 to the latest firmware and have done a factory reset on the A9
and still no luck. When I go through the initialization screens after a factory reset, the AFHSS shows up but then it asks me
what modulation I want to use and wont finish the initialization until I select something else than
the AFHSS. Thanks in advance, Ian [/
QUOTE]

No Spectra Pro module handy today.
Suggest check out manual pages 27, 57 & 58 regarding frequency changes.
May need to finish the 72MHz PPM sequence before it will allow change back to 2.4GHz.
i.e. select PPM and then any frequency, cycle power on/off.
. Insert 2.4Ghz module and A9 should then recognise the change.
if no joy, then email/phone:
Hitec Warranty & Service
Note: Hitec USA only services North/South America and Canada. (- Closed Weekends)
• If you are from a country that is outside North and South America, please contact the
Hitec distributor in your country for service.


Alan T.
Alan's Hobby, Model & RC FAQ Web Links
Jul 22, 2012, 01:18 AM
eYebox US servicing
E.N.'s Avatar
Thanks, but I have already tried that. It seems to me that the 2.4 module is not talking to the A9 or that the A9 can't hear it. Is there a way to hard reset the module?

Thanks,
Ian
Dec 11, 2012, 02:36 PM
Registered User

similar issue.


Hi i have the same problem with my A9. did you manage to sort it? how did you reset the TX? cheers


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale BRAND NEW HITEC AURORA 9 IN 2.4 and 72 3Deee Aircraft - General - Radio Equipment (FS/W) 1 Jul 08, 2012 02:24 AM
Sold Hitec Aurora 9 2.4 Transmitter W/2600 mah 7.4 Lipo Great shape! HD Hucker Aircraft - General - Radio Equipment (FS/W) 3 May 12, 2012 11:45 AM
Discussion XPS Module doesn't fit 10CHP kelnet88 Xtreme Power Systems 3 May 06, 2012 01:08 AM
Sold Hitec Aurora 9 2.4 TX & Optima 9 chn 2.4 RX-$359 Howard L Aircraft - General - Radio Equipment (FS/W) 0 Apr 20, 2010 09:19 AM
What!? Laser 4 suddenly doesn't work at all after wal-wart charge but works as mstr jay flay tway Radios 7 May 16, 2005 04:49 AM