Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Jul 20, 2012, 01:29 AM
hallstudio is offline
Find More Posts by hallstudio
Pilot not Drone Operator
hallstudio's Avatar
KK will work it out. I have 10 plus hours of flight time on my analog and my digital tail servo tri's and no burnt out servos yet. I did burn out a HS 81 when it was set to high setting. Could be vibration or maybe a little slop in the linkage but a little code will probably fix us up. I donít know what is more anticipated, the new iphone or the firmware release for this board.
Sign up now
to remove ads between posts
Old Jul 20, 2012, 04:07 AM
Tim Harbour is online now
Find More Posts by Tim Harbour
DLG Bug Bit Me
Tim Harbour's Avatar
Yeh, no.
Tested board off the frame in my hand and the jitter is still there.
We will just have to wait for the update.
Old Jul 20, 2012, 11:08 AM
SleekStryker is offline
Find More Posts by SleekStryker
Registered User
Quote:
Originally Posted by TLHover View Post
Yeh, no.
Tested board off the frame in my hand and the jitter is still there.
We will just have to wait for the update.
That won't work if the board is in your hand.
Old Jul 20, 2012, 11:25 AM
hallstudio is offline
Find More Posts by hallstudio
Pilot not Drone Operator
hallstudio's Avatar
played withthe gains a bit. i have been flying with p60 and i30. droped douwn to p 50 and i 27 and its better. still has some twitch but not as bad. might try dropping your p's and i's till the tail feels mushy and not snappy enough. let me know if that helps. Also not that what i do is right or wrong but as far as mounting the board i use velcro. the board just floats on loops and fur. i also mount my gopro that way and my battery. i zip tie the motors to the stick with a layer of 2 face tape under the mount.
Old Jul 20, 2012, 07:14 PM
shelterock is offline
Find More Posts by shelterock
Fly, crash, rebuild.
So I installed a solar digital servo for $12 from hobbypartz. D657. 25g with 3.0kg 0.1 seconds to 60'. No wobble. Set servo on high. Sweet. $12 fix and tri is good!! H
Old Jul 20, 2012, 07:31 PM
Banjo5 is offline
Find More Posts by Banjo5
Registered User

Awesome


Quote:
Originally Posted by shelterock View Post
So I installed a solar digital servo for $12 from hobbypartz. D657. 25g with 3.0kg 0.1 seconds to 60'. No wobble. Set servo on high. Sweet. $12 fix and tri is good!! H
That's the data point I was waiting for. Thanks. Andrew.
Old Jul 21, 2012, 04:37 PM
Okisub is offline
Find More Posts by Okisub
Just noticed I can change this
Okisub's Avatar
Quote:
Originally Posted by shelterock View Post
So I installed a solar digital servo for $12 from hobbypartz. D657. 25g with 3.0kg 0.1 seconds to 60'. No wobble. Set servo on high. Sweet. $12 fix and tri is good!! H
That is good news
Is it stable in fast forward flight as well? And what PI setting are you using on the rudder channel?
Old Jul 22, 2012, 11:56 AM
shelterock is offline
Find More Posts by shelterock
Fly, crash, rebuild.
Quote:
Originally Posted by Okisub View Post
That is good news
Is it stable in fast forward flight as well? And what PI setting are you using on the rudder channel?
Well, new observation, the digital servo is so high strung that right at the initial yaw input moment it moves so quick that it induces vibes in the camera mount.
My yaw P gains are at 75 and I gains at 70. Limits 20 p and 10 I. I think there is some tweaking left to do.
Roll/pitch at 65p and 60I.
My tri is a 50cm arm rcexplorer 2.5. I think the size of the craft comes into play. Bigger can handle higher gains. She's pretty solid other than the quick vibes at initial servo movement.
H
Old Jul 24, 2012, 05:03 PM
ADI Man is offline
Find More Posts by ADI Man
Registered User

Jitter Fixed


Good Evening All. I was interested in this thread because I too, upon using the KK2 board for the first time, became very aware of the tail jitter. I managed to get it down to reasonable effect by lowering the gain right down but it was still there. I was using a Digi Tower Pro MG16R servo. Today I replaced it with a Tower Pro MG946R Digi, a veritable beast of a servo.....but.....tail now rock steady. Gain now back up to 100....still rock steady. It seems you have to have a servo that's man enough for the job. By the way, I now love this KK2 board.....Neil
Old Jul 24, 2012, 05:22 PM
eitan is offline
Find More Posts by eitan
Registered User
What could be the reason that the servo does not respond at all?
I use this servo: http://www.hobbyking.com/hobbyking/s...idProduct=8761.
The servo worked fine with the HobbyKing Multi-Rotor Control Board V2.1.
Thank you
Old Jul 24, 2012, 10:04 PM
Phalanx-0 is offline
Find More Posts by Phalanx-0
Hulk likes flying things
Phalanx-0's Avatar
@eitan
does the servo work straight from the receiver? If so then, make sure the conector is oriented properly.
Old Jul 25, 2012, 05:50 AM
eitan is offline
Find More Posts by eitan
Registered User
Quote:
Originally Posted by Phalanx-0 View Post
@eitan
does the servo work straight from the receiver? If so then, make sure the conector is oriented properly.

Yes, the servo works correctly when connected directly to the receiver.
The Connector is connected correctly.
Old Jul 25, 2012, 05:52 AM
Okisub is offline
Find More Posts by Okisub
Just noticed I can change this
Okisub's Avatar
Quote:
Originally Posted by eitan View Post
Yes, the servo works correctly when connected directly to the receiver.
The Connector is connected correctly.
What PI setting are you trying on the rudder channel?
Old Jul 25, 2012, 06:10 AM
eitan is offline
Find More Posts by eitan
Registered User
Quote:
Originally Posted by Okisub View Post
What PI setting are you trying on the rudder channel?
P gain : 150
P Limit :20
I Gain : 50
I Limit : 10
Old Jul 25, 2012, 09:43 AM
healthyfatboy is offline
Find More Posts by healthyfatboy
Registered User
Do you have voltage on the 5V rail for M2-M8 on the board? If you disabled the BEC on the 2nd and 3rd motor, then your servo won't get any voltage as the BEC from the 1st motor is separate from the rest of the connections.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hobbyking KK2.0 Multi-rotor LCD Flight Control Board MoRaLeSD Multirotor Talk 5 Apr 09, 2014 12:05 PM
Discussion Tricopter tail servo parts TS00 Multirotor Talk 5 Jun 23, 2012 02:40 PM
Discussion Problem Flashing Hk Board for Tricopter timmerflyer Multirotor Talk 0 Jun 20, 2012 01:10 PM
Help! TriCopter with HK Board V2 Savage27 Multirotor Talk 0 Jun 12, 2012 04:44 PM
Discussion .hex firmware for hk board tricopter emberjelly Multirotor Talk 1 Sep 25, 2011 06:33 AM