Yet another NAZA arming thread - Page 2 - RC Groups
Thread Tools
Jul 14, 2012, 05:45 AM
Registered User
This is now fixed. Had to set a fake aileron endpoint mix to a switch to get it to arm. After motors turns its just to flip the switch back and fly.
Sign up now
to remove ads between posts
Jul 14, 2012, 07:05 AM
Registered User
I finally got the motors running except for one after upgrading the firmware in the Naza Assistant.
They are all running in the right direction based on Y6 configuration.
I have one motor M2( based on Y6 configuraion) not running as it should be and twitching a lot.
Anyone know what could be the problem?Could it be an ESC issue or motor issue.They are all brand new out of the box.
Jul 14, 2012, 07:12 AM
Registered User
Originally Posted by huntermanmt
Im using the same TX/RX setup.

I flew yesterday, couldnt figure it out why I was arming but had no control of my throttle, I simply overlooked the throttle hold switch being on.

Another problem I had in the beginning were the dual rates and expo. I had made adjustments and there wasnt enough stick travel detected to arm the naza. I changed them back to original settings.

Also, in the very beginning, I initially made the mistake of plugging in the motors (positive, negative, ground) the opposite way into the naza, i just flipped and plugged them in the right way.

Maybe this will help.
Hi Hunterman,
Thank you for your advice.
I got everything set up right from the start so I do not have to unplug any ESCs for adjustment.
The LED is flashing as it should be. It is so nice when everything works so well right from the first set up.
I now have a single motor not working well. (Motor 2 on Y6 configuration is twitching a little bit).
Hope someone will beable to help me out on this.
Jul 14, 2012, 07:24 AM
FPV Desert Beta Test Center
Originally Posted by seojeff
It sounds to me like you either need to calibrate the throttle throw on each ESC OR try trimming back your throttle. I had this same issue with some really cheesy ESCs I used and then ended up getting something better later.

In order to calibrate the throttle throw connect the ESC directly to your ESC, do one at a time. Power up with your throttle at 100%, when the ESC beeps back it down to zero. Do this with no prop installed just to be safe.
Do you mean connect the ESC directly to your RX?

Since my DJI ESC's came with no manual and the factory is apparently too busy to answer user requests I had not done a calibration as the manual outlines. I therefore tried this procedure with high hopes but once again no joy.
Last edited by Gary Evans; Jul 14, 2012 at 10:27 AM.
Jul 14, 2012, 11:39 AM
Registered User
huntermanmt's Avatar
Those escs dont need to be calibrated they are already set. I wonder if the calibration that had been done messed with what was set up originally?
Jul 14, 2012, 12:46 PM
FPV Desert Beta Test Center

From everything I've tried to date it was apparent that either my MC was defective or something in the firmware was blocking the motor start. I then remembered the following statement (highlighted in RED) on this point in page 17 of the manual.

1. All slides should become green when all the sticks are in the middle positions. If slides cannot go back
to center points (become green), just click FINISH, then slides will be at center automatically. If still not, please reboot MC, and do not apply Tx command during the reboot.
2. CSC may not start motors If trims and sub-trims of sticks are not 0

During the initial set up the R, E and A sliders had gone to green after calibration. Then I went back and recalibrated again. This time they also went to green but if I watched it for a while I could see the E and A slider jump from side to side very slightly and I could see a micro second of black on the pointers.
This time after calibration I followed the instruction shown in blue and BINGO I have motor starts.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Yet another Fox conversion Sherlock Slope 3 Jul 08, 2012 06:45 PM
Discussion Lights go dim on yet another Obama energy project P-51C Life, The Universe, and Politics 31 Jul 06, 2012 02:52 PM
Discussion yet another reason to drop google logan5 Life, The Universe, and Politics 43 Jul 03, 2012 11:13 AM
Yet Another Brushless Switchback Thread 02ViperTwin Parkflyers 89 Oct 22, 2002 03:07 PM
Yet another Bandit thread! tim hooper Electric Sailplanes 31 Nov 05, 2001 01:36 PM