New Products Flash Sale
Thread Tools
Old Jul 04, 2012, 04:31 PM
3D4life is offline
Find More Posts by 3D4life
Registered User
Discussion

Blade 130X Problem Thread


I don't know if there is one yet, so I figured this would be a good start.

Picked up my 130X yesterday. GREAT heli, very quick, makes the MCPX look like a toy. On the second flight I got a weird tail wag, so I set it down only to discover I had no tail control. The servo was unsoldered. Resoldered it, but to no avail. Now I have a dead heli on one of the few days Horizon takes holiday. Crud.
Sign up now
to remove ads between posts
Old Jul 04, 2012, 04:48 PM
J_skaggs is offline
Find More Posts by J_skaggs
Registered User
Seven flights on mine and no problems. Knock on wood.



Update:

Crashed it onto grass from 10 feet. Canopy came off but, no damage.
Last edited by J_skaggs; Jul 05, 2012 at 05:14 PM.
Old Jul 04, 2012, 08:46 PM
3D4life is offline
Find More Posts by 3D4life
Registered User
Just resoldered the tail servo. Got to try out some harder 3d and it seems like the tail is a tad weak for a few things, but an excellent flyer all around. Still calling horizon to let them know though.
Old Jul 04, 2012, 11:06 PM
marctrudeau is offline
Find More Posts by marctrudeau
Registered User
5 low-intensity (new to CP) flights. Couple hard impacts with hard objects. No vibes. No issues. (knock wood.)
Old Jul 04, 2012, 11:26 PM
Mizchief is offline
Find More Posts by Mizchief
Registered User
I've had a few flights on mine mostly FFF. Had one crash in grass and one of the links slipped out of the rod. was able to screw it back on, but haven't tried it since, had fireworks to prepare
Old Jul 04, 2012, 11:31 PM
sirzeppu is online now
Find More Posts by sirzeppu
Registered User
sirzeppu's Avatar
Just flew mine in FFF a couple of times. I am new as well...but this thing feels as locked in as my 450x. I am very happy.
Old Jul 05, 2012, 12:01 AM
J_skaggs is offline
Find More Posts by J_skaggs
Registered User
Quote:
Originally Posted by 3D4life View Post
Just resoldered the tail servo. Got to try out some harder 3d and it seems like the tail is a tad weak for a few things, but an excellent flyer all around. Still calling horizon to let them know though.
I would ask HH for a new servo. Even if you don't need it now you would have it for a spare.
Old Jul 05, 2012, 02:02 PM
3D4life is offline
Find More Posts by 3D4life
Registered User
Waiting on a call back. Flew it again today, just simple hovering inverted hovering, and towards the end of the flight it started making quick pirouettes. Brought it back down(not a hard landing) and discovered that the tail servo had once again become unsoldered. So the waiting begins. Anybody else having trouble with theirs?
Old Jul 05, 2012, 03:26 PM
3D4life is offline
Find More Posts by 3D4life
Registered User
HH is sending a new servo.
Old Jul 05, 2012, 05:46 PM
bradharvy is offline
Find More Posts by bradharvy
Registered User
bradharvy's Avatar

Mine was a problem


popcorn
Last edited by bradharvy; Jul 15, 2012 at 11:31 PM.
Old Jul 05, 2012, 08:57 PM
J_skaggs is offline
Find More Posts by J_skaggs
Registered User
I understand the safety issue with the tail blade breaking and flying off but, we're not hearing wide spread complaints of this. Could this be an isolated incident like the report of tail servo shaft nuts backing off? Take your shots. I have my bullet proof vest on.
Old Jul 05, 2012, 09:14 PM
mrski154 is offline
Find More Posts by mrski154
Registered User
Flew the heli twice, no problems. Got a new battery so fired it up and found I had no tail control. With the throttle off, the tail servo works normally giving the correct inputs when the rudder stick is moved. Push the throttle to 50% and no rudder. Bring the throttle to idle, and a second or two after the blades stop, the tail servo kicks in. The whole thing is repeatable.
Old Jul 05, 2012, 09:42 PM
Mizchief is offline
Find More Posts by Mizchief
Registered User
Hmm sounds like a bad board. Assuming you have your Tx settings correct.
Old Jul 06, 2012, 02:00 AM
3D4life is offline
Find More Posts by 3D4life
Registered User
It may be similar to what I encountered with the MCPX when it came out. The board loses a channel or goes out of bind when it gets a good amount of power running through it.
Old Jul 06, 2012, 10:07 AM
everydayflyer is offline
Find More Posts by everydayflyer
Southern Pride
everydayflyer's Avatar
That sounds like a bad power connection perhaps. Could be bad solder joint at the main power leads at battery end or the main board end. I know I have found this on the mCPX and also the mCPX leads are only secured to the main board with a bit of silicon rubber toserve as a strain relief which is not really all that secure IMO. The leads tend to be a bit short and it is difficult to connect and disconnect the battery without pulling on them. I put a longer length of heat shrink on the battery end of the leads while I am resoldering them and also use hot glue to secure the leads to the main board.

Charles


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Blade 130x tail servo flaw Howeroll Micro Helis 5 Jul 03, 2012 07:15 PM
Discussion Any hobby shop in ct, ma or ri stocking blade 130x yet? HeliStyle Micro Helis 4 Jul 03, 2012 10:46 AM
Discussion So, the Blade 130X and it's battery...charging/balancing? sertav Batteries and Chargers 16 Apr 23, 2012 06:56 AM
Discussion How's the Blade 130x? sertav Electric Heli Talk 1 Apr 18, 2012 01:22 PM