Thread Tools
Dec 26, 2012, 06:03 AM
Aleksey Kharlanov
Quote:
Originally Posted by lnquang
If you know the structure of code,you can make a script to do automatic port, since it is same programming language, just different hardware platform.
Really? Do it.
Sign up now
to remove ads between posts
Dec 26, 2012, 06:11 AM
Registered User
Yes, sir... I wish I know the Code structure
Dec 26, 2012, 07:22 AM
Registered User
Quote:
Originally Posted by Sir Alex
Really? Do it.


I will wait for yours 2.9. But for now 2.8 is working. Have a break!
Thanx for your good work!!
Dec 26, 2012, 07:35 AM
Aleksey Kharlanov
Quote:
Originally Posted by lnquang
Yes, sir... I wish I know the Code structure
Maybe with 2.9+ the porting process will be simpler since ArduCopter team writing HAL. So we will just make our HAL driver for our boards.

But currently it's not possible to do porting automatically, IMHO.
Dec 26, 2012, 08:03 AM
Registered User
Quote:
Originally Posted by Boykintom
Guys, I can really use some help here. Can someone tell me exactly how I can connect my Crius u-Blox CN-06 GPS Receiver V2.0 to u-center? I have the gps on the Crius AIOP, and its performance is erratic, sometimes good but often not so good. I am hoping that configuring the unit in u-center will help. If anyone has other advice on improving the gps reliability, I'd love to hear it.
You need a FDTI cable like this one to connect to u-Center:
http://viewitem.eim.ebay.se/FTDI-FT2...023514603/item
Dec 26, 2012, 09:15 AM
Registered User
Quote:
Originally Posted by Kaptenklister
You need a FDTI cable like this one to connect to u-Center:
http://viewitem.eim.ebay.se/FTDI-FT2...023514603/item
Thank you!
Dec 26, 2012, 02:09 PM
Registered User

Altitude drop in alt hold mode after roll


Hi, my quad has a strange behaviour. In alt hold hovers quite good while at the end of "strong" rolling maneuvers (I mean, when I release the stick) it loses 0,5 - 1 mt and then regain altitude. Strangely enough, in stab mode this doesn't happen, my quad just stop rolling and doesn't lose altitude at all (of course I'm not touching the throttle).

Any suggestion to fix that?
Hope I made myself clear enough
Thanks in advance!
Dec 26, 2012, 02:19 PM
Youtube: TomRi25
Dr.Tom's Avatar
AIO pro v1
my hexa in gps hold + alt hold mode, 26 minutes endurance.

MWC 1284 GPS + baro alt hold test - 26 minutes endurance (24 min 48 sec)


MWC code 1284, works pretty good for AP
boring test, I took a nap during it in my car,
but photographers like their models to be stationary while they control gimbal and camera...

I prefer long range FPV
http://tinyurl.com/longrangezg01
http://tinyurl.com/longrangezg02
Dec 26, 2012, 02:46 PM
Registered User

MPNG 2.8 gimbal problem


Just loaded MPNG 2.8 and now the gimbal servos don't work like they did. Can't find CAM_PITCH FUNCTION or CAM_ROLL FUNCTION. What do I set in their place to get the gimbal to automatically compensate for pitch and roll?
Dec 26, 2012, 04:17 PM
Registered User
Quote:
Originally Posted by Boykintom
Just loaded MPNG 2.8 and now the gimbal servos don't work like they did. Can't find CAM_PITCH FUNCTION or CAM_ROLL FUNCTION. What do I set in their place to get the gimbal to automatically compensate for pitch and roll?

Donīt apply any changes to config.h (like in 2.7 R4)

Install (or update) to newest MissionPlanner.
Tilt is now RC5 ! If you want to override it with your Headtracker or RC, use channel 7 on your receiver and enter it in the "RC-input checkbox".

Reverse and all other Gimbal settings are now working via MissionPlanner. No need to change config.h
Dec 26, 2012, 05:03 PM
ShopCzar
Endlesslag's Avatar
For a hex on MPNG, which ports do the motors get plugged into, and what are the rotation settings?
Dec 26, 2012, 09:06 PM
ShopCzar
Endlesslag's Avatar
Anybody? Sorry if I'm a bit impatient, but I've looked all over and can't seem to find a diagram or make it work. Just need the correct motor numbers and rotation directions for a hex on MPNG, and I think I'm good to go.
Dec 26, 2012, 09:43 PM
Too Many Thread Subscriptions
TheFernMan's Avatar
Quote:
Originally Posted by Endlesslag
Anybody? Sorry if I'm a bit impatient, but I've looked all over and can't seem to find a diagram or make it work. Just need the correct motor numbers and rotation directions for a hex on MPNG, and I think I'm good to go.
https://www.rcgroups.com/forums/showthread.php?t=1769026
Jumpy07 manual
Dec 26, 2012, 10:09 PM
ShopCzar
Endlesslag's Avatar
Thanks! I think its working right now
Dec 27, 2012, 12:29 AM
Registered User
Hello All,
I was hoping someone would be able to help me here. Im using the crius AIO pro board and built my own two axis camera gimbal. Although the gimbal works quite well my roll is not quite centered and when I login to Mission planner and goto ADV Parameter List. I change the CAM_R_TRIM and then Write Params button but it does not do anything. I have even tried the CAM_P_TRIM and still nothing. Can someone please help with this.
Thanks and Merry Christmas and Happy New Yr


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-HowTo Arduino and HobbyKing Multi-Rotor Control Board V3.0 or KKmulticontroller v5.5 pprioverde Multirotor Drone Talk 33 May 28, 2017 11:40 AM
Discussion New updated Crius Multiwii SE flight controller SGsoar Multirotor Drone Electronics 72 May 15, 2013 08:36 PM
Discussion Jim, any plans for more multi rotor flight controller? chris24g Xtreme Power Systems 12 Jun 25, 2012 08:11 PM
Sold One New, one used ArduPilot 2560 APM1.0 Flight Controlls/autopilots wingspinner FPV Equipment (FS/W) 3 May 28, 2012 12:55 AM
Question Quad Build Using HobbyKing Multi-Rotor Control Board V3.0 (Atmega328 PA) SJackson Multirotor Drone Talk 27 Apr 30, 2012 08:51 PM