The new KK2 FC, info and Q&A in first post. Read it before asking a question. - Page 663 - RC Groups
Thread Tools
Feb 02, 2013, 08:37 AM
Registered User
Quote:
Originally Posted by R.Grimm
Maidened my first tricopter today and it was a big succsess
It flies perfectly stable and also able to do some 3D moves!!
I Thank you KK for bringing so much joy to my life!!

Video of build setup and maiden flight.
http://www.youtube.com/watch?v=8KcB3oOvijk
That is one classy looking, and smooth flying machine. Great video too, pretty much covers off everything. Can tell why you're so pumped.

Cheers,
Andrew
Sign up now
to remove ads between posts
Feb 02, 2013, 10:31 AM
It only cost 50 honest!
David Parry's Avatar
Think my board may be broke. Getting a buzzing sound from it and tri spins rather than take off. Tried recalibrating same thing. Sometimes if I tap the board the buzzing stops, but comes back fairly quickly. Will have to take it out and check for breaks etc, but not sure if it will be ok. Anybody else had a similar problem? was working fine yesterday, and not been crashed or knocked. Also just noticed that one of the ESC's is getting warm.
Feb 02, 2013, 11:02 AM
efx
efx
Rookie in training, heads up
efx's Avatar
Yes I've been working on the throttle. I have increased the minimun throttle but I may keep going a bit. My stick scaling is the default and I said sudden move, not full moves to either side...Also, where did you get 11 inch props from? I use 8x4 which is what was recommended for this motor under the specs. I know there's more to that, but this size seems to be working fine for so far. I saw the dji naza 330 and 450 with the same size props, they worked the same as mine. All three are very stable and level with these size props. In any case, mine seems to drop, so it's so it's not a matter of how far I move the sticks. It appears something is making it stop. I'll keep checking it. I need some parts now so until then will see how it goes.

Quote:
Originally Posted by Del-Dredd
You need to sort out your throttle range, so that zero throttle is off and motors start just above zero.
Maybe you need to adjust the Min throttle setting in the KK2 menu.

Moving Aileron stick full one way will make it roll over if you have a decent Stick scaling value and Self Level off , how else do you think you can do rolls and flips.

Are you sure your motors are capable of spinning an 11 inch prop, did you use a smaller pitch on the 11 inch to compensate for extra load on the motor.
Feb 02, 2013, 11:05 AM
efx
efx
Rookie in training, heads up
efx's Avatar
What firmware do you have? I'm just wondering as mine sometimes seems totally fine, and other times I think it kind of acts up so now I'm wondering if it's the board too.


Quote:
Originally Posted by David Parry
Think my board may be broke. Getting a buzzing sound from it and tri spins rather than take off. Tried recalibrating same thing. Sometimes if I tap the board the buzzing stops, but comes back fairly quickly. Will have to take it out and check for breaks etc, but not sure if it will be ok. Anybody else had a similar problem? was working fine yesterday, and not been crashed or knocked. Also just noticed that one of the ESC's is getting warm.
Feb 02, 2013, 11:07 AM
It only cost 50 honest!
David Parry's Avatar
Running v1.5 so as to use the cam stab. May try reflashing it. Have checked the back of it for breaks, cant see any, also cleaned the back with Iso propyl but still the same.
Feb 02, 2013, 11:17 AM
Registered User
muck76's Avatar
is there a reason the manual says to set up a TX in airplane mode instead of Heli? I'm planning on using this board on a quad and need to set up my DX7
Feb 02, 2013, 11:23 AM
efx
efx
Rookie in training, heads up
efx's Avatar
Thanks. I have firmware 1.4 so I was thinking of upgrading it to see if anything would change.

Quote:
Originally Posted by David Parry
Running v1.5 so as to use the cam stab. May try reflashing it. Have checked the back of it for breaks, cant see any, also cleaned the back with Iso propyl but still the same.
Feb 02, 2013, 11:30 AM
It only cost 50 honest!
David Parry's Avatar
The only reason to use brontides v1.5 is for the cam stab. everything else is the same, except you loose the debug option.
Feb 02, 2013, 11:43 AM
efx
efx
Rookie in training, heads up
efx's Avatar
I don't have a cam pan/tilt on mine so this is why I didn't go up to the 1.5. i guess I just need to keep testing a bit more. Now my quad seems to be getting the chicken dance. I know one prop shaft got bent a bit from the crash but I can still get it to hover, then all of the sudden it starts going crazy so I have to put it down.

Quote:
Originally Posted by David Parry
The only reason to use brontides v1.5 is for the cam stab. everything else is the same, except you loose the debug option.
Feb 02, 2013, 11:46 AM
Registered User
Quote:
Originally Posted by Brombo
PI Editor Pitch & Roll
P Gain 40
P Limit 30
P Limit should be 100.

Quote:
Originally Posted by muck76
is there a reason the manual says to set up a TX in airplane mode instead of Heli? I'm planning on using this board on a quad and need to set up my DX7
No fancy mixing is needed. It's all done in the KK2. Airplane mode is therefore ideal.

Fred
Feb 02, 2013, 11:49 AM
Registered User
R.Grimm's Avatar
Quote:
Originally Posted by georgehine
I just got my tricopter going. Can you do complete flips with the 1.5 firmware or do you have to use a acro version of firmware?
Flipping a tri or quad with 1.5 is easy......
Hobbyking Y-3 Tricopter build and first flight (5 min 34 sec)

HobbyKing Q450, KK2 1.5 . simonk firmware flashed to Ty-P1 ESC:s (1 min 54 sec)


Accidently tried to do a backflip with my quad in autolevel mode but the flip was so slow that i hit the ground before completing the flip. actually done this twice..some never learn... Broke 2 arms on my quad last time and now im only using autolevel when loosing orientation.

So my experience is always fly KK2 with autolevel OFF to do flips and other "3D" manouvres.
Last edited by R.Grimm; Feb 02, 2013 at 12:14 PM.
Feb 02, 2013, 01:18 PM
Registered User
Del-Dredd's Avatar
Quote:
Originally Posted by efx
Yes I've been working on the throttle. I have increased the minimun throttle but I may keep going a bit. My stick scaling is the default and I said sudden move, not full moves to either side...Also, where did you get 11 inch props from? I use 8x4 which is what was recommended for this motor under the specs. I know there's more to that, but this size seems to be working fine for so far. I saw the dji naza 330 and 450 with the same size props, they worked the same as mine. All three are very stable and level with these size props. In any case, mine seems to drop, so it's so it's not a matter of how far I move the sticks. It appears something is making it stop. I'll keep checking it. I need some parts now so until then will see how it goes.
In the post I quoted there was this statement

" I also changed the prop spin to 11 instead of the default 10." never seen a setting for prop spin so thought you meant prop size.

I now see you you meant Min Throttle setting as i mentioned in my reply.
as per the manual

"Misc. Settings":
-"Minimum Throttle" item: Adjust just high enough to keep all the motors running when the throttle
is above zero.

I use 8X4.5's on my Quad and Tri, 1200 and 1300Kv respectively.
Feb 02, 2013, 01:45 PM
Master of Flash
LazyZero's Avatar
Looks like you start it from the wrong directory. You must start it from the folder where the flash tool is stored. Please go to the console and type java -version and post it here or send it as PM to me.

Best Christian

Quote:
Originally Posted by SDSURFnGLIDE
do you think i cant run this cause i cant access the jar file??

Ok here is what i get when i open the non serial flash tool:
Feb 02, 2013, 02:20 PM
Multi rotors=No Paycheck left
SDSURFnGLIDE's Avatar
Quote:
Originally Posted by LazyZero
Looks like you start it from the wrong directory. You must start it from the folder where the flash tool is stored. Please go to the console and type java -version and post it here or send it as PM to me.

Best Christian
Thanks...cause this is driving me nuts....fwiw...i have the tool in a folder on my desktop...open up the file and then double click the tool....
But i will send you a pm with the info you requested.
Feb 02, 2013, 02:27 PM
Addicted
I'm sorry for the ignorance, but what exactly do the limits do? And if the gain is above the limit then what does that do?