Thread Tools
Jan 22, 2013, 06:43 PM
efx
efx
Rookie in training, heads up
efx's Avatar
Hahaha...well that's why we are here...we may things work. I just finished swapping the load side so I can plug motors, escs on that side so it worked out fine. I just hate soldering to this large wires. I just went ahead and cut the plug and installed a new one. I just couldn't get the plugs off. I also just maded my own parallel adapter so I can use two batteries and just tested it and it works! It's pretty cool. I'm uploading the short video showing two batteries plugged in. So now I think I'm down to just testing and tuning to hopefully get it flying smoothly but I tend to like going fast on these things unfortunately.
Sign up now
to remove ads between posts
Jan 22, 2013, 06:44 PM
Registered User

App


Quote:
Originally Posted by JBPiantanida
From my experience there is a standard, a very strong one that all manufacturers adhere to:

"Whatever connector I am currently using will not be available on the product I am ordering. To do this effectively, every three months introduce a new one that has no clear advantage over the ones they have supplied in the past, just something new I have to buy or cut off and replace."

That has been my experience...
This is why for years I have used Anderson Power Pole connectors.Used to be Sermos connnectors.
Partzee
Jan 22, 2013, 06:47 PM
efx
efx
Rookie in training, heads up
efx's Avatar
I standardized to the red banana plugs just because you can't plug them backwards and you can actually hold them. So although a tad bigger they have worked great for me. I've seen a cheaper version where the plastic is thin though and those bend too easily. I believe HK now carries the red in the shorter version if you like that. I just like them because there's no way to short things while trying to plug them like other plugs where you really have to watch that as you could just touch them and make some sparks.
Jan 22, 2013, 06:56 PM
Registered User
JBPiantanida's Avatar
Quote:
Originally Posted by efx
I standardized to the red banana plugs just because you can't plug them backwards and you can actually hold them. So although a tad bigger they have worked great for me. I've seen a cheaper version where the plastic is thin though and those bend too easily. I believe HK now carries the red in the shorter version if you like that. I just like them because there's no way to short things while trying to plug them like other plugs where you really have to watch that as you could just touch them and make some sparks.
I agree about the banana plugs. I was using Deans Ultra for size and current handling ability. But despite the size, and possibly because of it (old eyes and sloppy fingers), I am switching everything over to the red banana plugs. Easy to solder, easy to plug and unplug. Except for the smallest things which will stay JST, I am sold on the banana plugs.
Jan 22, 2013, 10:43 PM
Team WarpSquad
Quote:
Originally Posted by JBPiantanida
From my experience there is a standard, a very strong one that all manufacturers adhere to:

"Whatever connector I am currently using will not be available on the product I am ordering. To do this effectively, every three months introduce a new one that has no clear advantage over the ones they have supplied in the past, just something new I have to buy or cut off and replace."

That has been my experience...
Totally agree... now where did those side cutters get to?

<SNIP> solder <SNIP> solder


I went to Traxxas type on 3S since I managed to plug battery to battery once with bananas. The current didn't flow longer than needed to vaporise the connection points!!
EC3 or XT60 also prevent that sort of stupidity and additionally there are no easily shorted terminals.
I have XTs on my 2S stuff.
Last edited by thwaitm; Jan 22, 2013 at 10:53 PM.
Jan 23, 2013, 12:51 AM
Registered User
Quote:
Originally Posted by efx
I standardized to the red banana plugs just because you can't plug them backwards and you can actually hold them. So although a tad bigger they have worked great for me. I've seen a cheaper version where the plastic is thin though and those bend too easily. I believe HK now carries the red in the shorter version if you like that. I just like them because there's no way to short things while trying to plug them like other plugs where you really have to watch that as you could just touch them and make some sparks.
There are no standard for these. Some have the male battery connector on the positive wire, some on the negative. Then there are two ways to arrange them inside the plastic, female in narrow or wide plastic sleeve. Plastic housings from different manufactures may not fit together.
Yes, they are pretty safe until the day you connect one battery into the other battery by accident. What I do, is splitting male and female on everything except batteries (ESC, charge leads etc.). Then I get used to connecting one wire at a time (which sometimes is easier anyway), and hopefully will realize that something is wrong if I ever have a double one in each hand.
Here is an easy way to get them out of the plastic: http://www.hobbyking.com/hobbyking/f....asp?TID=35963

Fred
Jan 23, 2013, 02:47 AM
efx
efx
Rookie in training, heads up
efx's Avatar
Thanks Fred. I had an incident tonight, two fingers got bitten. Not sure what the hell happened but here's the description. I'll update more once I heal and get a chance to look at the quad again.
https://www.rcgroups.com/forums/show...2#post23901337
Jan 23, 2013, 02:50 AM
8 bit is more fun
RC911's Avatar
Quote:
Originally Posted by Steveis
Nice work! A lot of people have been asking for this kind of gimbal tilt feature.
Jan 23, 2013, 03:15 AM
Registered User
Quote:
Originally Posted by Steveis
thank you Steveis, controlling the CamStab offsets from the transmitter is a nice feature i was waiting for but not time yet to test it.
Jan 23, 2013, 05:31 AM
Registered User
Quote:
Originally Posted by efx
Thanks Fred. I had an incident tonight, two fingers got bitten. Not sure what the hell happened but here's the description. I'll update more once I heal and get a chance to look at the quad again.
https://www.rcgroups.com/forums/show...2#post23901337
Sorry to hear that. Hope you recover soon.
What happened was probably that your three other ESCs were fully initialised when you connected M1 with full throttle! When button 1 & 4 is pressed while the KK2 is power up, it will send that throttle signal to all ESCs.
The calibration process starts only when ESC is powered up (from the battery side) with 100% throttle signal.
The power meter is just like two pieces of wire connected between battery and quad, and is not the cause for this.

You are not the first, BTW: https://www.rcgroups.com/forums/show...postcount=6708

Fred
Last edited by flarssen; Jan 23, 2013 at 05:45 AM.
Jan 23, 2013, 06:10 AM
Registered User
Donnyv's Avatar
kk 2.0 quadcopter in below zero degree weather!! (4 min 26 sec)

My first flight with the kk2! I love it!
Jan 23, 2013, 08:16 AM
Stop me before I build again!
Why do I even bother with MWC? It's a mess of code and I'm suprised it's not more broken. Wasted at least a day on this build already trying to get a MWC board working because I bused my spare KK2, but damn I'm about to order another KK2 just so I can stop mucking with this broken FW. I have 10 output pins on my MWC board but, for some ungodly reason, I can't actually use 10; Best I can figure is that I can use 8 in total.
Jan 23, 2013, 08:55 AM
iMultirotors
Senator315's Avatar
Powered up one of my quads today and noticed the text is gone but the backlight is still working. Thought it was strange as the last time I flew it, it was all fine and I didn't crash at all. So I did the normal tests, still nothing. I then tried to arm it and it armed fine and flew normal.
I have a spare broken KK2 (gyro doesn't work), so I thought I'll take the LCD out of it to see if that would fix it. First off I went to remove the non functioning LCD, it all looked fine while in the quad and even after removing it from the quad it still looked fine, but as I went to remove the LCD, the ribbon cable came away from the glass along with some glass (pic below).
Well, no wonder it didn't work, so how did it happen!! this quad has never been crashed, well not hard enough to break anything, and the KK2 sits inside between the plates, so it's well protected.
Anyway, I put the new LCD in and it works just fine.
Thought I'd share incase others have a non working LCD and it's yet another possible cause.
Jan 23, 2013, 09:16 AM
Registered User
Quote:
Originally Posted by efx
Thanks Fred. I had an incident tonight, two fingers got bitten. Not sure what the hell happened but here's the description. I'll update more once I heal and get a chance to look at the quad again.
Here is one way to have a safe power connection. Install one of these on the frame where you can reach it without exposing your fingers to the props.

http://www.sharprc.com/catalog/index.php?cPath=43
Jan 23, 2013, 10:49 AM
Registered User
Quote:
Originally Posted by efx
Okay I just made myself a parallel battery adapter. Would just the one battery voltage plug work or would I need one for each? I know this seems basic, but since I have never actually flow with a set of batteries I don't know what others have experienced with something similar. I'm guessing just the one balance lead I have will be fine if I'm using the same size batteries unless I can get voltage on each individual battery from the controller, but my guess is this is not necessary. I still haven't tested this on the quad but adapter is all done and I just tested it individually on the one battery and all seems good to go. In any case, I just want to make sure I don't make any fires.

Darn, it looks like one of my wattmeter plugs is soldered wrong...ahhh
Quote:
Originally Posted by efx
Here's what I had done. I can plug a battery from either side which works, but now I need a nother adapter to plug it to the quad side, the connectors don't match if I want to plug the wattmeter between them...that manual has two in and two out which these plugs don't have. They are one in and one out...I just used the batteries to make sure I could plug them in on either side. I guess this is what happens when there's no standard. I guess I can always redo the load side. I just found another battery plug I had cut that I can use to reverse this side. I'll just soldered the correct side on the other end...I'll have to reverse the load end. The one I found is too big 12awg which is more of a pain to solder.
Stop! Don't plug anything in until you understand!

I just want to make sure that what you have is good and that you don't damage stuff by plugging it in wrong. The type of connector that you have can be dangerous because it can be plugged in backwards which is very bad to do.

I am writing instructions, but before I get them written, always make sure that black wires plug into black wires and red wires plug into red wires for store bought cables.