The new KK2 FC, info and Q&A in first post. Read it before asking a question. - Page 152 - RC Groups
Thread Tools
Aug 09, 2012, 06:25 PM
Quad Whisperer
Originally Posted by Erknie
How about KK 4.7 ported to the i86
That one will have to wait as well.
Sign up now
to remove ads between posts
Aug 09, 2012, 06:35 PM
Quad Whisperer
Originally Posted by HappySundays
Another thing for those who think they have "bricked" KK2s...
Probably the only person who has reflashed a KK2 board more times than me is Kapteinkuk himself.
Yep, done it very many times, and not a single problem. Uses AVRStudio 4 an an original AVRISPII programmer.
My development KK2 has been flashed at least 1000 times and still works fine, but it won't always flash. There are a number of scenarios that I found screw up the flash process.

While Lazy's flashtool works perfectly for me, it was much quicker for me during development to make a batch file that ran avrdude from the command line. No verify - double-click on the icon and burn.

Sometimes avrdude would just abort and exit as it tried to start the process, sometimes it would do this five times in a row, but I would just keep trying until it gave in.

On rare occasions it, or the driver would get all mixed up and removing and reconnecting my USBasp would solve the problem.

But one thing that would *really* piss off the programmer and/or avrdude was having a ground loop formed by externally power devices. For instance, while testing the battery monitor, I had a mains-powered power supply hooked up. I don't remember the specifics but that would lock up the programming in certain circumstances.

Similarly, having the ground clip of an oscilloscope lead attached would also bugger up the programming process on occasion.

In both the above cases, removing the external connection fixed the problem.
USB is quite sensitive to ground noise.
I don't think it is possible to "brick" a KK2 otherwise either I or Kapteinkuk would be sure to have done it by now.

For those with blank LCD screens - can you try flashing OpenAero2 on it to see if that works? You can always flash it back.

Early reports are that when the eeprom is corrupted on the KK2, you can get a blank screen.
Only if the address containing the contrast value is hit.
The first 4 bytes of the EEPROM is a signature, unique for the two FW versions that exists. If it does not find the correct one, it does a factory reset. This is noticeable by rapid beeps and it goes direct to the sensor test screen.
If you cannot properly do a factory reset, try flashing OpenAero2 first, to confirm that all is working. I'm fairly sure it's immune to a corrupted eeprom.
Aug 09, 2012, 06:57 PM
Registered User
I got my KK2 two days ago, powered it up the first time yesterday before reading the latest in this thread. While skipping through the Menus (in the Misc Settings menu) all of a sudden the screen went totally blank.

I most definitely didn't change the contrast setting manually while in the menus.

After a few power cycles, I followed the contrast reset process from post #1 exactly and the screen came back. (Phew!)

Its now flashed with 1.01, and I haven't seen it happen since.... but any ideas why the contrast setting would suddenly get zero'd?
Aug 09, 2012, 07:15 PM
Aug 09, 2012, 07:45 PM
Hulk likes flying things
Phalanx-0's Avatar
have you tried flashing your speedies with Simonk's firmware?
It might fix your problem.
Aug 09, 2012, 07:58 PM
Originally Posted by kapteinkuk
New FW for the KK2.


1: Removed: LCD contrast adjustment: Not necessary.

2: Removed: "I of PI" on/off mode: No practical use found.

3: Removed: I part of self-level: Does not work with slow reacting ACC.

4: Changed: default gains to 50/50/50 (roll/pitch/yaw) P-term, and 25, 25, 50 I-term.

5: Added: beep (short beep, 2 sec delay) when armed and throttle closed, for extra safety. Makes the KK2 a bit more noisy when armed so the user does not forget it is armed.

6: Added: longer arm/disarm beep.

7: Added: ACC trim. Use it to adjust self-level attitude, no need to recalibrate sensors. Adjust in "Self-level Settings" menu.

8: Added: factory reset.

9: Added: status messages on the "SAFE" screen. The KK2 will not arm unless it says "OK.". Error messages can only be reset by cycling the power, except for the "sensors not calibrated" message, which is reset after a successful sensor calibration. Error messages include lost RX connection.

10: Bug fix: wrong offset in flying wing mix table.

11: Changed: doubled self-level stick response. Let you have more control in self-level mode.

12: Added: CPPM (sum PPM) mode. Turned on/off in "Mode Settings" menu. Also the assignments of the CPPM channels can be changed in "CPPM Settings".

13: Added: Y4 and V-tail layout.

14: Added: shows battery voltage on the "SAFE" screen.

15: Added: lost aircraft alarm. Starts to beep (1 sec on and 4 sec off) after 30min of no activity (arm/disarm).

16: Added: LP filter on servo outputs. Adjust in "Misc. Settings". A good start value is 50.

17: Added: auto-disarm. The KK2 will disarm itself after 20 sec if throttle is at idle. For extra safety. Can be turned on/off in "Mode Settings" menu.

Download it below. You only need the "kk2.hex" file. The source is also included, with a license.


(At least throw a blanket over the propellers if you are to lazy. )

Also check for correct operation before mounting the propellers.

Note that all settings is returned to default.

Have fun!
I flashed the KK2 board and everything looks good except that the Bat. voltage on the main page shows 0.0. All other changes seem to have taken effect. Any suggestions?
Aug 09, 2012, 08:05 PM
Registered User
jsmith285's Avatar
Its Flys really well. Still need to adjust but default settings sure seem close.

My LCD appears to want to tip up. side towards the buttons.
Does it snap in, or should I glue it down?
Aug 09, 2012, 08:05 PM
Registered User
Originally Posted by johnargrc
I flashed the KK2 board and everything looks good except that the Bat. voltage on the main page shows 0.0. All other changes seem to have taken effect. Any suggestions?
Set the battery alarm voltage to something other than zero and it should work, that's assuming you have a wire hooked up to the battery.
Aug 09, 2012, 08:11 PM
Changed the alarm voltage to 1 then 3 still no voltage reading on the main page. I have a 2200 3S hooked up to the quad as normal.
Aug 09, 2012, 08:15 PM
Registered User
pbmax's Avatar
Originally Posted by johnargrc
Changed the alarm voltage to 1 then 3 still no voltage reading on the main page. I have a 2200 3S hooked up to the quad as normal.
You need to solder a wire from the battery connection to the appropriate location on the board:

KK2 Voltage Alarm Setup (7 min 21 sec)
Aug 09, 2012, 08:21 PM
Thanks, I was not trying to set up the alarm. I do not have the alarm set up, almost deaf and the alarm is of no use to me. I was trying to use the new firmware update to show the battery voltage on the main page. I assume you are saying that I will need to set up the alarm to utilize this new function.
Thanks, John
Aug 09, 2012, 08:28 PM
Registered User
Originally Posted by kapteinkuk
This file is empty, and only a fraction of the 32kb memory.
The board just decided to go blank when it did. It was not a result of flashing since at the time there was no code to flash. The board is now on a slow boat to HK and with any luck at all I may see it again in the long term future. Again, thanks for the help and I plan to flash my new board when it arrives providing I can see the display first.
Aug 09, 2012, 08:32 PM
Blowtorch and a pair of pliers
evildean's Avatar
Originally Posted by kapteinkuk
I removed the calibration text. ESC calibration is still there. (button 1 + 4 on power up)
The Calibration process does not seem to occur for me... even though the menu displays "Calibrating ESCs" nothing seems to change. I can arm the FC but my ESCs continue to beep as if the throttle is not at idle, and nothing happens. In an attempt to troubleshoot, I have individually calibrated ESCs with success per the Turnigy 10a Plush instructions, yet I still only get the constant beep-beep-beep-beep-beep when powering up the FC. Am I missing something??
Aug 09, 2012, 08:32 PM
Multi rotors=No Paycheck left


I got all the files for lazy zeros flash tool and when i go to open up the jar file...the widow flashes and it goes away...i loaded the latest java to...running win 7...what an i doing wrong?
Aug 09, 2012, 08:35 PM
Blowtorch and a pair of pliers
evildean's Avatar
Can I flash back to the original firmware for the purpose of troubleshooting my issue? What Firmwares are recommended for the kk2.0 LCD?