Opensource Videomodem - Page 4 - RC Groups
Thread Tools
Jul 03, 2012, 08:06 AM
Registered User
jalves's Avatar
You are correct, I forgot I don't have the pin8 of arduino connected.

Pics replaced.
Last edited by jalves; Jul 03, 2012 at 08:24 AM.
Sign up now
to remove ads between posts
Jul 03, 2012, 01:35 PM
Registered User
Jalves.

Tried today a bit, and got the same picture like your snapshots.

BUT, look what picture i have with the diyosd. I have the same issue...
I'll ask dennis what could be the problem
Jul 03, 2012, 02:02 PM
Registered User
Some dimming is seen on your (on jalves's pictures no dimming is seen)...I guess you have to adjust the potentiometer value to get more dimming (or use a pot with a different value)..Do you require more dimming? Does it have to be completly black?
I know that the telemetry part of osd won't be seen, but will the other part of the osd (which we can see) have to be completely dimmed to black? I'm asking this because I don't like very much the completely dimmed look
Jul 03, 2012, 02:19 PM
Registered User
Quote:
Some dimming is seen on your (on jalves's pictures no dimming is seen)...I guess you have to adjust the potentiometer value to get more dimming (or use a pot with a different value)
i have a 150Ohm resistor on PIN8 which is responsible for dimming.

Quote:
Do you require more dimming? Does it have to be completly black?
for debugging: YES. For the finalversion: NO

Quote:
but will the other part of the osd (which we can see) have to be completely dimmed to black
Of course NOT. That whould be bad.

Quote:
I'm asking this because I don't like very much the completely dimmed look
Me too.

msev: can you imagine why the chars of the diyosd, and the "bars" of my code are so ugly and not stable?

Jalves: can you please post a picture of a diyosd screenshot? Would be nice to compare.
Jul 03, 2012, 02:50 PM
Registered User
Maybe its because of innapropriate resistor values..When using the pots there is a sweet spot that gets the most stable letters.
Jul 03, 2012, 06:11 PM
Registered User
jalves's Avatar
Quote:
Originally Posted by muerzi
Jalves: can you please post a picture of a diyosd screenshot? Would be nice to compare.
My diyosd (V017):
Jul 04, 2012, 01:52 AM
Registered User
Thanks. Looks better than mine...
Will try to adjust the poti.

Today i will try to build the OSD like the SimpleOSD by Flytron.
Maybe with the LM1881 the detection of the newline sync is better than with the diyosd osd method with the analog comparator, and i hope the letters will be more stable.
Jul 04, 2012, 02:43 AM
Registered User
jalves's Avatar
Nope,

I bought the SimpleOSD from flytron (with the video telemetry on mind...) and try the diyosd code with it.

Surprise, surprise, the characters on screen are much more unstable (almost unreadable) than with the analogue comparator of the atmel.
Jul 04, 2012, 03:01 AM
Registered User
Well I diy-ed the version with lm1881 and in my case they are not unstable. Can you make a video of how unstable yours are?
Jul 04, 2012, 04:25 AM
Registered User
Jalves:

Have you edited the settings in the code correctly for the diyosd?
What voltagesource are you using?
A lipo, a BEC or a stable voltagesource?

Are you sure there are no other misstakes you made?

You can also try to replace the 680k resistor with a 710k resistor on the rst pin of the lm1881
Last edited by muerzi; Jul 04, 2012 at 10:51 AM.
Jul 05, 2012, 10:35 AM
Registered User
Quote:
Originally Posted by muerzi
Jalves,
About the circuit you are trying.
Do you think the LM393 is fast enough to do that?
At 500kHz it should be no problem, but with e.g. 4MHz?
With a typical response time of 1.3us I think it is too slow even for 500KHz.


The the last image looks as dimming does not work (not connected or disabled by software).
Jul 05, 2012, 11:53 AM
Registered User
1.3 uS are 769230.769230769Hz, so 769kHz.
But than there will will be a problem with the timing.
Maybe we should go to 250 kHz and use more lines...
Jul 05, 2012, 07:51 PM
Registered User
Quote:
Originally Posted by muerzi
Maybe we should go to 250 kHz and use more lines...
Or find a faster comparator. On a quick search I found LT1011 which should be good to about 2MHz.
Jul 06, 2012, 12:52 AM
Registered User
Hey guys.

From now on, i'll be 1 week on holiday (in croatia).
I will be take my ipad with me, but can only read the post on eveninng.

Cheers
Jul 12, 2012, 12:06 PM
Registered User
Any progress so far from anybody?

My video experimenter arrived, but i'm in croatia till saturday


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Opensource frames design files! DexterIt Multirotor Drone Talk 5 Apr 26, 2012 09:42 AM