Thread Tools
Old Jun 12, 2012, 05:29 PM
jasper7821 is offline
Find More Posts by jasper7821
Registered User
Discussion

Crashed my new dji s800, 100%totally not my fault. I'm so friggn pissed off right now


I'm totally shaking right now, I can't even believe this happened.

This is totally 100% a malfunction somewhere.
I brought the S800 to work and was hovering during lunch and I was only about 5ft up in GPS mode and it all of a sudden flipped right and hit the ground just about upside down.
Everything was going perfect for just over 10 minutes so I don't understand what happened. It was either the WKM malfunctioning or the S800.

This SUCKS big time. And I had my Sony Nex5n attached. I'm praying that's ok.
I wish I had the video going to prove that it was just hovering and took a dive to the right and went into the ground. It happened so fast that I wasn't able to try and give it left aileron to try and correct it.

I'm sending it back to Robert for an estimate for repair and if I can afford to fix it then I will and post it here CHEAP for sale.
If I cannot afford to repair it, then whoever owns a S800 and wants some DIRT CHEAP replacement parts then let me know.
I'm just praying that it's not going to be a ton of money to repair.

I wish there was someone from DJI standing next to me when it crashed, maybe I'd get some assistance in having it repaired then
Sign up now
to remove ads between posts
Old Jun 12, 2012, 05:32 PM
Z06 Tony is offline
Find More Posts by Z06 Tony
Z06 Tony's Avatar
What size batts did you use?
How much was left when you charged them?
Site Sponsor
Old Jun 12, 2012, 05:42 PM
jasper7821 is offline
Find More Posts by jasper7821
Registered User
This will probably be the last aerial photo I ever take unless I force myself to get a CHEAP quad and a GoPro
It crashed about 2 minutes after this photo.

Man, I'm so bummed out right now.
I be really pissed at myself if it was my fault, but this was totally a malfunction with a DJI product.

I have mixed feelings right now about them.
I really liked what I bought from them and they gave me a new NAZA when it broke from a crash from the faulty prop breaking in mid air.
Robert was great when the first WKM I bought had issues and now this WKM's blue LED doesn't work and he's sending me another one.
So Robert's customer service has been stellar but I don't think I'm going to get much help from DJI this time. I wish I could
Last edited by jasper7821; Jun 12, 2012 at 05:59 PM.
Old Jun 12, 2012, 05:45 PM
jasper7821 is offline
Find More Posts by jasper7821
Registered User
Quote:
Originally Posted by Z06 Tony View Post
What size batts did you use?
How much was left when you charged them?
I have 2 near brand new (only 3 charges on each) 5000mah and I can go 17.5 minutes of hovering and I was only into just over 10 minutes.

Both batteries are totally fine and now reading 22.7

I charged them last night and they took 3990 and 3983 so I ran them to just about 80% and that was a 17.5 minute flight.
Old Jun 12, 2012, 05:46 PM
blade strike is online now
Find More Posts by blade strike
DJI Testing / US Support
blade strike's Avatar
where is your sat? The shadow on that ar8000 must be pretty bad imho.

I am also very sorry for your crash man!
Site Sponsor
Old Jun 12, 2012, 05:49 PM
SDSURFnGLIDE is offline
Find More Posts by SDSURFnGLIDE
Multi rotors=No Paycheck left
SDSURFnGLIDE's Avatar
Dang that sux man...do you think there may have been some faulty wiring somewhere? if it was hovering for that long and then all of a sudden crapped out...that doesnt sound right...good luck and hopefully you get it fixed....
Old Jun 12, 2012, 05:49 PM
cryhavoc38 is offline
Find More Posts by cryhavoc38
Why didn't they run? A pass???
cryhavoc38's Avatar
wait wait..I'm with Blade strike here.

you have BOTH the ar9000 and its satellite INSIDE the fuse?
In the pictures, you have put both the main rec and the sat rec inside.

thats a big no no with 2.4ghz when there is alot of carbon fiber around it.
Old Jun 12, 2012, 05:53 PM
Z06 Tony is offline
Find More Posts by Z06 Tony
Z06 Tony's Avatar
Did you setup FS according to the Spektrum manual and make sure it went into FS on your computer screen when you shut off the TX ?
Site Sponsor
Old Jun 12, 2012, 05:56 PM
jasper7821 is offline
Find More Posts by jasper7821
Registered User
Quote:
Originally Posted by Z06 Tony View Post
Did you setup FS according to the Spektrum manual and make sure it went into FS on your computer screen when you shut off the TX ?
Yes, my fail safe has been set up for weeks. it worked fine on the F550 and S800.
There was no signal loss. I was only standing about 8ft away from it.
The AR8000 had a steady orange so there was no loss of signal.
Old Jun 12, 2012, 06:02 PM
killy is offline
Find More Posts by killy
Registered User
killy's Avatar
this realy sucks, that is a lot of damage for a 5 feet crash man,
Old Jun 12, 2012, 06:04 PM
jasper7821 is offline
Find More Posts by jasper7821
Registered User
Quote:
Originally Posted by SDSURFnGLIDE View Post
Dang that sux man...do you think there may have been some faulty wiring somewhere? if it was hovering for that long and then all of a sudden crapped out...that doesnt sound right...good luck and hopefully you get it fixed....
All wiring is great. I made 100% sure of that.
I was hovering in the same spot for almost 5 minutes just in awe at how great the GPS holds it in position and then all of a sudden it just banked right.

It's totally weird, and I cannot understand why it happened but I swear to god on my life it was not my fault and it was something in the WKM or S800 that freaked out.
My AR8000 had a solid orange light so it wasn't that. My batteries still have plenty of juice so I don't get it.
Old Jun 12, 2012, 06:05 PM
peoples is offline
Find More Posts by peoples
I think you should look for burned tracks....
Site Sponsor
Old Jun 12, 2012, 06:06 PM
cryhavoc38 is offline
Find More Posts by cryhavoc38
Why didn't they run? A pass???
cryhavoc38's Avatar
Quote:
Originally Posted by jasper7821 View Post
Yes, my fail safe has been set up for weeks. it worked fine on the F550 and S800.
There was no signal loss. I was only standing about 8ft away from it.
The AR8000 had a steady orange so there was no loss of signal.
I feel for your loss. That has to be a you know what feeling.

but correct me if I am wrong..the receivers won't show a loss of signal via the LED..they only show a loss of power via a blinking led no?

Its been a long time since I've used spektrum, but thats what I remember about LOS, versus loss of power.

regardless, the next time you build one up, keep the receivers outside of the fuse, one on top and one on the bottom, or out on a boom.

sorry again for your loss. I read your original thread and how excited you were to receive the S800
Last edited by cryhavoc38; Jun 12, 2012 at 06:11 PM.
Old Jun 12, 2012, 06:09 PM
jasper7821 is offline
Find More Posts by jasper7821
Registered User
Quote:
Originally Posted by killy View Post
this realy sucks, that is a lot of damage for a 5 feet crash man,
Ya, this thing is WAY more fragile and delicate than my F550. I smashed that thing up good (DJI Prop breaking) and I only broke one arm and 2 or 3 blades.

I think these motors are very delicate also, only 2 are spinning freely. 4 of them are grinding pretty bad when turning them.
Old Jun 12, 2012, 06:09 PM
Adidas4275 is offline
Find More Posts by Adidas4275
manual flying apologist
Adidas4275's Avatar
yeah that is a TON of dammage for a 5' crash.

jasper i feel for you man.... this sucks


it is laughable that we are talking about a radio hit here even with the sat and rx inside... he was like 20 feet from himself and even if it got a hit it would go into failsafe...

total bummer and i think what we can all take away from this is...A) spare parts MUST be available to users of ANY frame and B) this thing is super fragile in comparison to the CineStar, SkyJib, Flexicopter and the like......

i do agree, jasper..... go back to something cheaper and have fun.... dont worry about making $$ at this or selling photos... just have some fun man


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion My DJI Spreading Wings S800 just came in the mail and I think I'm in trouble jasper7821 Multirotor Talk 219 Oct 16, 2012 06:11 PM
Discussion DJI S800 aircraft crash incidents in Inner Mongolia **DJI Multirotor Talk 188 Jul 02, 2012 11:45 AM
Discussion I Crashed, My Fault -- BUT??? everynameistaken Electric Plane Talk 21 Oct 13, 2011 10:45 PM
Discussion Now with data: Hobbyking SS 25A esc works great it was my fault for not testing first handyfella Power Systems 40 Mar 26, 2011 10:29 AM
J-3 Cub Crash (not my fault!) JustFly Beginner Training Area (Aircraft-Electric) 8 Nov 02, 2004 05:22 PM