Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
Old Dec 28, 2012, 10:48 AM
jazzjohn is offline
Find More Posts by jazzjohn
Registered User
Quote:
Originally Posted by pmerritt View Post
i've posted this elsewhere but i love these.

http://www.hobbyking.com/hobbyking/s...dProduct=25526
I have those too, but they can slide forward and damage the canopy because they're thinner than stock. I wrapped a few turns of 1/2 inch electrical tape around the wire end of the lipo and covered the tape with large shrink tubing. That solved the problem.
Sign up now
to remove ads between posts
Old Dec 28, 2012, 10:57 AM
mcmoyer is offline
Find More Posts by mcmoyer
450x, 180CFX
Quote:
Originally Posted by oldsneakers View Post
The drawback is they come with XT60 connectors, so you either change the battery or the heli. I just put a XT60 on the heli. Here's the battery.

http://www.hobbyking.com/hobbyking/s...dProduct=27171
I guess it does make more sense to change the connector on the heli instead of the batteries. Is the XT60 connector the defacto standard nowadays? Is there any advantage to the banana connectors?
Old Dec 28, 2012, 11:53 AM
BThirsk is offline
Find More Posts by BThirsk
Brent 黑雁
BThirsk's Avatar
Quote:
Originally Posted by mcmoyer View Post
I guess it does make more sense to change the connector on the heli instead of the batteries. Is the XT60 connector the defacto standard nowadays? Is there any advantage to the banana connectors?
Most batteries under 3000mah seem to have the XT60. And yes, it is easier to change the ESC connector once than change all your batteries.
Old Dec 28, 2012, 12:52 PM
pmerritt is offline
Find More Posts by pmerritt
Registered User
Quote:
Originally Posted by jazzjohn View Post
I have those too, but they can slide forward and damage the canopy because they're thinner than stock. I wrapped a few turns of 1/2 inch electrical tape around the wire end of the lipo and covered the tape with large shrink tubing. That solved the problem.
take two zip ties and lay then in the battery cage just like the battery lays and then wrap them around and zip them as tight as you can. this leaves a portion of the tie strap bowed in the cage and when you pop a battery in there it provides a nice spring like action and they fit nice and snug. no tape needed.
Old Dec 28, 2012, 06:06 PM
jazzjohn is offline
Find More Posts by jazzjohn
Registered User
Quote:
Originally Posted by pmerritt View Post
take two zip ties and lay then in the battery cage just like the battery lays and then wrap them around and zip them as tight as you can. this leaves a portion of the tie strap bowed in the cage and when you pop a battery in there it provides a nice spring like action and they fit nice and snug. no tape needed.
My problem is one of my lipos is the stock one so I was forced to mod the batteries instead of the cage.

But if you're only using the one type of lipo this makes sense.
Old Dec 29, 2012, 12:31 PM
RamboSmurf is offline
Find More Posts by RamboSmurf
Bring back the Huey!
RamboSmurf's Avatar
Couple of questions if anyone can give me a hand. My CP has seemed to have lost its power or motor spools down quickly. Starts good, runs for 1-2 minutes then slowly dies. Land it, throttle off, wait 1 minute, starts up and repeats. With other battery it lacks top end power or bogs out with any big pitch increase. I think its the motor crapping out. I am putting out 12.50V from ESC.
Its been so long since I have had a brushed motor, I forgot if this is how they act when they are getting bad.
Second question, with my ball links disconnected and testing gyro recovery or servo recovery, they do not move smooth, they kind of twitch back to center.
If I move the sticks then let go of the sticks, the servos slowly tick back to center. They don't move smoothly or very fast back to center. Of course I'm comparing this to my 450 so it could be perfectly normal and I just don't know it.
As a side note, my Ball links were so tight they were causing major binding. I don't know if they are all like this but if they are that has to be a big factor in the servo stripping issues.
Thanks for your help.
Old Dec 29, 2012, 01:38 PM
addifromgermany is offline
Find More Posts by addifromgermany
Registered User
The behaviour of your motor is normal for brushed motors when they get older.
Buy a new one or better: Convert to brushless
Old Dec 29, 2012, 04:51 PM
54885488 is offline
Find More Posts by 54885488
Registered User
Does anybody know how many teeth on main and pinion gear ? Im trying to set up brushless with a castle phoenix 25 speed control .
Old Dec 29, 2012, 07:18 PM
pmerritt is offline
Find More Posts by pmerritt
Registered User
Quote:
Originally Posted by 54885488 View Post
Does anybody know how many teeth on main and pinion gear ? Im trying to set up brushless with a castle phoenix 25 speed control .
it's 114t or 115t on the maingear and stock pinion is 13t
Old Dec 30, 2012, 03:50 PM
54885488 is offline
Find More Posts by 54885488
Registered User
Thank you pmerritt . I have my head speed set at 3800 and 4000 rpm and like it alot . It sure wakes this heli up .
Old Dec 30, 2012, 07:48 PM
SaigonFPV is offline
Find More Posts by SaigonFPV
Registered User
hello my family.
I just got master CP on Today. but with two flies, i got somethings bad. hic. maybe seller do not know how to setup Master CP . Please help me. my master cp never stable. always fly to left too much, and backward when throttle about 70%
My setup on TX is:
Throttle 0%(L) 13% 25% 40%(M) 55% 65% 76%(H)
Pitch 35^(L) 37% 40% 45%(M) 50% 55% 60%(H)
D/R-Expo: Aileron 45% - Expo 35% / Elevator 50% - Expo 40%
- Can i setup like that? Please help me
------------------------------------------------------------------------------------
And this is Video i got badthing. i try to turn ball link of Elevator servo 2 turn, and my bird have a little bit stable, but always turn left when fly. And hear sound on my video, you will see..(my English voice too bad ^^)
00255 (2 min 14 sec)

And this is the second fly after
00256 (0 min 41 sec)

Is this broken servo on Pitch Servo? huhuhuhu..
Thank you so much...
Old Dec 30, 2012, 08:26 PM
Rain4LA is offline
Find More Posts by Rain4LA
Registered User
Rain4LA's Avatar

What is wrong with my Master CP???


I don't understand. This thing is like flying a sack of stones. It barely gets off the ground, and when it does, the response is so slow and sluggish that there is no way anyone could ever do even the mildest 3D. Not that I would, because I can't - but it would be nice to just fly it without spending the next few days repairing it or waiting for parts. I don't know how to explain it. I'm used to the fast responses of the smaller helicopters, but I also fly the big helicopters in Phoenix (SIM) snd know how they should behave. My Master CP literally flies like it has rocks tied to the skids. Does anyone have any idea what this could be? Any help would be appreciated.
Old Dec 30, 2012, 08:47 PM
scornflake is offline
Find More Posts by scornflake
Registered User
Quote:
Originally Posted by kid_boy View Post
I just got master CP on Today. but with two flies, i got somethings bad. hic.

Hello!
Sounds like a servo is stripped. MasterCP servos are known to be ... bad (I'd use another word, but that'd be rude)...

Take the servos apart and check that the gears are good. Search this forum, there are a number of replacement recommendations (Hitec, futaba to name two).
Old Dec 30, 2012, 08:49 PM
scornflake is offline
Find More Posts by scornflake
Registered User
Quote:
Originally Posted by Rain4LA View Post
I don't understand. This thing is like flying a sack of stones. .
Got any setup details, videos, pics?
Mine certainly lifts off at a rate of knots, I've seen other people doing mild 3d just fine. Seems like a setup issue.

What's the pitch? If it's too low, it won't get much lift.
What expo/dr's in tx? If you have too much travel reduction (on pitch) or too much expo in the d/r setup, it'll be REAL slow.

Sounds like not enough pitch tho.
Old Dec 30, 2012, 09:03 PM
Rain4LA is offline
Find More Posts by Rain4LA
Registered User
Rain4LA's Avatar
Quote:
Originally Posted by scornflake View Post
Got any setup details, videos, pics?
Mine certainly lifts off at a rate of knots, I've seen other people doing mild 3d just fine. Seems like a setup issue.

What's the pitch? If it's too low, it won't get much lift.
What expo/dr's in tx? If you have too much travel reduction (on pitch) or too much expo in the d/r setup, it'll be REAL slow.

Sounds like not enough pitch tho.
Cool, I appreciate that. Let me look at this stuff. I'm using someone else's setup file for a Master CP. I run Deviation on my Devo 8s and it's an .ini file. Although I messed around with it because I didn't like the negative pitch on the first page setting. I probably messed it up, because I don't understand it enough yet to...well....understand it. But I'm trying! I really am. Thank you.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Blade Mcpx v1 v2 vs Walkera Mini Cp vs Genius Cp vs solo pro 100 3d f.a.r.m.e.r Micro Helis 134 Mar 30, 2016 11:51 AM
Sold Walkera Genius CP with Devo 6 King.7200 Aircraft - Electric - Helis (FS/W) 2 Feb 02, 2012 11:52 AM
Sold Walkera Genius CP Brushless version 3D with 6-axis gyro Devo stretch1100 Aircraft - Electric - Helis (FS/W) 3 Jan 25, 2012 09:37 AM
For Sale Walkera Genius CP with DEVO 6 bymannan Aircraft - Electric - Helis (FS/W) 0 Nov 07, 2011 08:57 AM
New Product Walkera 6-Axis gyro UFO5# (new version with Camera~) DLY Micro Helis 6 Oct 29, 2011 02:48 PM