Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
Old Jun 01, 2012, 06:27 PM
DutchAirVideo is offline
Find More Posts by DutchAirVideo
Registered User
Discussion

X650v4 can't get A.K.E HighSPEED PWM 12A ESC to work properly


Hi there, i replaced stock esc's on my x650v4 with A.K.E HighSPEED PWM 12A ESC, got the, from xaircraft.co.uk. Accordig to them these are the perfect plug and play replacements for better esc's no soldering etc etc But i can't start them to work properly. Tried the whole shebang with the stick up and down all the beeps etc etc, nothing will make the respons to my tx correct.. Anyone?
Sign up now
to remove ads between posts
Old Jun 01, 2012, 06:32 PM
DutchAirVideo is offline
Find More Posts by DutchAirVideo
Registered User
Additional info; i have (wgile trying to solve the problem) removed the red wires of three of the esc's, changed the battery and linked it to xaircraft centre but nothing seems to help. I have installed gps(v2) compass(v1) fc1212-s v2, gimball go pro and pilotlamp..maybe too much interference?
Old Apr 02, 2013, 12:23 PM
Fotophanatic is offline
Find More Posts by Fotophanatic
Build, Fly, Crash, Repeat
Fotophanatic's Avatar
Did you ever get this resolved?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Please help, Can't get it to work hello bro Beginner Training Area (Aircraft-Electric) 28 Nov 24, 2011 12:10 PM
Discussion can't get E-flite Blade MX s300 to work with spektrum module on Futaba 10C Capy-Norway Micro Helis 1 Jun 26, 2009 10:32 AM
Help! I can't get my eflite 40 amp brushless esc to work with my futaba 6EX!!! SwissBoy Power Systems 1 Jun 08, 2007 09:17 PM
Help! can't get esc to work, Help? furnaceman Beginner Training Area (Aircraft-Electric) 3 Mar 27, 2004 09:19 AM