Thread Tools
Old Apr 13, 2012, 08:58 PM
cryhavoc38 is offline
Find More Posts by cryhavoc38
Why didn't they run? A pass???
cryhavoc38's Avatar
Discussion

Is it me, or do the new Immersion 5.8ghz 600mw Tx's suck


I've got an Immersion Uno 5.8ghz receiver coupled with an ibcrazy 5.8ghz blue beam whips on both the tx and rx

It seems like I can get maybe a few hundred feet and lose signal.
Tried both the standard ant's and the bluebeams.

I've got the three lobe to the tx and the 4 lobe on the rx

Anyone running the latest version 600mw Immersion 5.8ghz TX and experiencing less than stellar performance?
Last edited by cryhavoc38; Apr 13, 2012 at 09:05 PM.
Sign up now
to remove ads between posts
Old Apr 13, 2012, 09:35 PM
malcr001 is offline
Find More Posts by malcr001
Registered User
malcr001's Avatar
Have you tried out other 5.8ghz gear from other companies? because I'm thinking the frequency in general sucks not the gear. I spent a crap load of money on iftron 5.8ghz and although theres a slight better picture it doesnt compare in terms of range with frequencies such as 1.3ghz. This is because of the frequency and no matter what expensive gear you have this wont change. Ofcourse I only realised this after I learnt anything about RF

I'm sure some people will swear by 5.8ghz, where you fly might make a difference I guess.
Old Apr 13, 2012, 10:00 PM
Shadrack is offline
Find More Posts by Shadrack
Mini Obsessed
Shadrack's Avatar
You shouldn't lose signal at a few hundred feet. I have been out 600 meters easy using the original dipole antenna and the fat sharks recevier.
Old Apr 13, 2012, 10:53 PM
Teamsherman is offline
Find More Posts by Teamsherman
Member #1
Teamsherman's Avatar
Try a different channel.
Old Apr 13, 2012, 11:34 PM
renatoa is offline
Find More Posts by renatoa
Registered User
Check if you have a left/right hand antennas mismatch.
The expected range without antenna change should be more than 1km.
The crimping of central pin of SMA plugs can also be an issue.
Old Apr 14, 2012, 12:30 AM
cryhavoc38 is offline
Find More Posts by cryhavoc38
Why didn't they run? A pass???
cryhavoc38's Avatar
Quote:
Originally Posted by RENATOA View Post
Check if you have a left/right hand antennas mismatch.
The expected range without antenna change should be more than 1km.
The crimping of central pin of SMA plugs can also be an issue.
I bought the ant set from readymaderc
the bluebeam rhcp whip set so they better be matched up


I'm going to see if I mistakenly isolated the ground somewhere from the 12v cam, ezosd, or transmitter.

it could also be something as simple as a weak/faulty tx or rx.

By the way, where/what is a good 9 to 10" monitor that doesn't blue screen.
I tried a Pyle 10.4" widescreen, but it doesn't allow for blue screen disabling.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question ImmersionRC 5.8ghz 600Mw Tx gets warm omer921 FPV Talk 11 Jun 21, 2013 06:32 AM
Alert Immersion 5.8ghz 600mw Tx nautique FPV Talk 17 Apr 08, 2012 08:40 PM
Sold Immersion RC 5.8ghz 600mw VTX NEW (FatShark Compatible) crd FPV Equipment (FS/W) 4 Feb 17, 2012 01:17 AM
Sold 5.8ghz 600mw TX, RX and patch antenna package RaptorAP FPV Equipment (FS/W) 1 Nov 13, 2011 03:51 PM
Found 5.8ghz fpv 200-600mw tx and receiver setup tahoelight FPV Equipment (FS/W) 1 Aug 13, 2011 08:16 PM