My GWS ESC 25A not arming - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Apr 12, 2012, 01:51 PM
Registered User
Discussion

My GWS ESC 25A not arming


I connected my GWS ESCs (25A) to my Hobby King board and tried increase the throttle but the ESCs just beep every 3 secs. I tried it with a Ardupilot System and it doesn't get armed also.
What might be the problem?
Sign up now
to remove ads between posts
Apr 12, 2012, 08:50 PM
Registered User
Probably some of the connectors and leads were not soldered well, might have been from your Hobby King board. But I have no idea about what Hobby King board you mentioned. Normally an ESC is desgined to connect with motor, receiver and battery.
Chen
Apr 14, 2012, 10:38 AM
Registered User
I use 'HobbyKing Multi-Rotor Control Board V2.1 (Atmega168PA)'. Its a stabilization board. I want to use this setup for my Quad board.
Lijoy
Apr 14, 2012, 08:06 PM
Registered User
Suggest plugging this ESC with one motor, battery and receiver, forget the control board at this moment, to see if it works correctly for you. If so, probably the board itself was in trouble, or you have to refer to the board's manual again.
Chen


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! ESCs will not arm using DX7 or my 9C TM8 simages Power Systems 16 Mar 04, 2012 07:03 PM
Discussion ESCs connecting but not arming motor tezact Power Systems 4 Feb 11, 2012 12:48 PM
Discussion Esc not arming? motor won't start. dudly Electric Plane Talk 5 Jan 15, 2012 11:47 AM
Discussion GWS 2205/15T Brushless Motor Plus 25A ESC kieranb Power Systems 2 Dec 05, 2011 04:51 PM
Discussion Now with data: Hobbyking SS 25A esc works great it was my fault for not testing first handyfella Power Systems 40 Mar 26, 2011 10:29 AM