GPS and AH functions not working with Firmware 4.0 - RC Groups
Thread Tools
Apr 07, 2012, 05:35 PM
SuperX Hex and X8 Flyer
ross_badger's Avatar

GPS and AH functions not working with Firmware 4.0

I updated to the latest 4.0 firmware on both my V1 HFPro green board and GPS board and everything seemed fine. I used the setup utility to set the config to Y-6, and confirmed that all the functions/flight modes from my transmitter were being received by the HFPro. AL, AH, PH, and RTH flight modes had checked boxes when I switched them on. In addition, the board passed all tests, and I confirmed that the GPS was connected and receiving a fix (cool feature in the setup by the way).

So I went out to fly and normal flight was absolutely perfect! Very solid and smooth.

However, when I switched on GPS......nothing happened. RTH function.....nothing. Is anyone else having this issue?

Also, I enabled AH, and it was acting strange, so I tried to switch it off, but it wouldn't respond either. I had to pound my Y-6 into the ground to keep it from going skyward. I broke a landing gear, but it is easily fixed.

I think that Firmware 4.0 still is not ready for prime time.....
Last edited by ross_badger; Apr 08, 2012 at 10:13 AM.
Sign up now
to remove ads between posts
Apr 07, 2012, 07:10 PM
A man with too many toys
Originally Posted by ross_badger
I think that Firmware 4.0 still is not ready for prime time.....
Youíve got that right

I think they tried to put way too many changes into V4 and itís not working out so well. A smaller incremental approach would have been much better and would probably have saved me a crash.

I think i will just park my GPS quad until V4.1 comes out and have seen some favorable reports.

For anyone with an expensive multi-rotor I would not recommend upgrading to V4 at this time.

Apr 07, 2012, 09:57 PM
aka Helidaho
AeroVideoUS's Avatar
I hate to say it but firmware 4 doesn't seem to work for me. I loaded it onto my green board with one switch and my gps board. It was a little breezy outside and it had a really hard time with the wind which isn't normal for my HFPro.

So I ran through the accelerometer calibration as well as the compass calibration and tried again. That's when I noticed flipping the AL switch didn't turn the HFPro LED blue. So I tried GPS and the led stayed green. All the while it was still having real difficulty with the wind. So I thought I would try the new ESC all at once calibration feature, zoiks! After I did that, the quad shook like crazy like I had the gains all the way up even though I lowered them almost to zero.

Still I hadn't made the connection that it was caused by the esc calibration I thought maybe I had some vibrations getting to the board so I took the boards out and while I had them out I used aluminum screws to put everything back together instead of the steel screws I had. Still wasn't flying well, doah!

So I loaded the highest 3.x version back onto the HFPro and GPS and it still performed terribly, shaking like crazy. This time I noticed the throttle response was terrible and decided to calibrate the escs again one by one on the Rx. With 3.x still loaded I went out and flew and everything was back to normal. Solid as a rock even with some breezes. AL, PH worked normally, led indicator worked normally and the camera gimbal responded normally.

So I decided to load 4.0 back on, the wind had gone so it was totally calm and it flew pretty well. Great I thought so I tried AL, no blue LED. Tried PH, nothing, RTH still nothing. I also noticed the camera gimbal, while really smooth now it was super slow and not keeping up with the quads movements. I tried flipping AL back and forth a few times and the led finally turned blue but when I turned it off the led stayed blue.

I know Ross in the 1st post mentioned he had a green board, I've got a green board, I wonder if this is only a problem with the green boards?

Sorry for the book, just trying to document everything I tried to get 4.0 to work.

Apr 07, 2012, 10:20 PM
aka Helidaho
AeroVideoUS's Avatar
Just loaded v3.2.629 back on and everything is working again. I'm going to leave that loaded so I can do some FPV flights tomorrow

Apr 07, 2012, 10:34 PM
Flight Instructor

No gps!

I've got exactly the same issues. Normal flight mode is great but no GPS. Blue light comes on for signal lock but no functionality. The setup client indicates everything is working correctly. My GPS was working great before the update. Whats wrong this time?
Apr 07, 2012, 10:50 PM
Flight Instructor

No Auto Leveling hence no GPS

I flew again to test the auto leveling. It doesn't seem to be working. The setup client says it works but I'm getting nothing. It flat out just acts like its turned off. I guess thats why the GPS isn't working.
Apr 07, 2012, 11:15 PM
Sky blue near dusk
S11D336B's Avatar
Sorry to hear about the issues. If you remove the GPS board does autoleveling work?

Also, make sure the Endpoints on your GPS switch are +-100%
Apr 07, 2012, 11:23 PM
Flight Instructor

I removed the GPS and AL works!

Originally Posted by S11D336B
Sorry to hear about the issues. If you remove the GPS board does autoleveling work?

Also, make sure the Endpoints on your GPS switch are +-100%
I removed the GPS board and the auto leveling works great! As a matter of fact it works awsome! But it doesn't work when the GPS board is attached.
Apr 07, 2012, 11:37 PM
Flight Instructor
It sounds like a little glitch in the GPS firmware. It's a nice night here for flying. Is there any other test you want me to try?
Apr 08, 2012, 01:31 AM
manual flying apologist
Adidas4275's Avatar
hey guys I was having an issue with the board (HFpro black) giving me the red...... green.. purple on start even though my Alt hold was off.

I went into the setup config and under pro I selected my Y-6 frame and after that it worked perfect.

I have not put my gps board on yet, but perhaps try selecting your frame type again in the setup config (not firmware updater) and see if that changes anything... it did for me.
Apr 08, 2012, 07:11 AM
SuperX Hex and X8 Flyer
ross_badger's Avatar
Originally Posted by Adidas4275
I have not put my gps board on yet, but perhaps try selecting your frame type again in the setup config (not firmware updater) and see if that changes anything... it did for me.
I tried selecting the frame type again (a couple of times) and that did not work for me with a GPS board. I'm sure there's a little software switch in the coding that wasn't "turned" on before release. I'm going back to 3.xx Firmware for the moment....
Apr 08, 2012, 08:52 AM
Registered User
In the Set-up Client, when you program the 3-way switch for switching between GPS functions, make sure when you set the EPA percentages on the switch for Position Hold and Return to Home, that Auto Level must be checked also. So when the switch is in the center position, Position Hold and Auto Level both should have check mark....When the switch is in bottom position, Return to Home and Auto Level should both be checked. This is not documented in the manual. I have discovered if the EPA percentages are not adjusted enough, Auto Level will not engage. You must adjust the EPA until Auto Level box is checked as well as Position Hold and Return to Home at the appropriate switch positions. Also when setting this up, make sure the Auto Level switch on your transmitter it set to off. I hope my explanation makes sense.

Apr 08, 2012, 09:08 AM
Registered User
This version 4.0 only works with HFP, if you have also installed the GPS does not work.

With HFP only, drive down the gain of AL and a well does not work very well, the tendency is to dump if you are not attentive to the movement of the frame.

With HFP and GPS not working AL, AH, PH, RTH.

The OSD does not mark well the battery voltage and does not mark the variometer.

All this has been tested with a quad and hexa +
Apr 08, 2012, 12:02 PM
Flight Instructor
Flying my HFP around without the GPS board everything works fine. When connecting the GPS board, AH, AL, PH, RTH all go away (don't work). There has to be a glitch in the code. On the setup client everything is working as it should. All GPS functions do show they activate correctly.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion OPTIC 6 SPORT 2.4 - Firmware update V1.02(0) A.T. Hitec/Multiplex USA 4 Apr 11, 2012 08:24 PM
Discussion Firmware 4.0 is now LIVE Triskelion Aerial Photography 14 Apr 08, 2012 09:10 AM
Alert OPTIC 6 SPORT 2.4 - Firmware update V1.02(0) A.T. Radios 0 Mar 05, 2012 03:58 AM
For Sale Attopilot 2.0 with GPS, thermopiles and GCS GradGuy Aircraft - General - Miscellaneous (FS/W) 1 Feb 29, 2012 08:02 AM
Discussion GPS not working with new firmware kuutee Aerial Photography 4 Jan 15, 2012 09:00 PM