Set up issue for first foamie build... - RC Groups
Thread Tools
Mar 31, 2012, 05:43 PM
Registered User

Set up issue for first foamie build...

I'm trying to set up the power system on my first foamie build before mounting everything in the plane. I hooked up everything on my bench to test and center servos.

If I plug a Rx battery into the Rx I can set up all three servos, (rudder, elev, ail) without any problems. But when I plug the flight pack into the Rx, things get wacky...

When using the flight pack, the Rx binds to the Tx and the ESC initializes fine. I can then control throttle and rudder fine. But when I move the ail or elev stick, the Rx starts blinking and the servos all start moving randomly. Even the rudder servo moves when I am only moving the elev or ail stick!

Would this be an ESC issue?

I'm using the following cheap components:
Orange Rx
Hextronic 9g & 5g servos
Mystery 12A ESC
Turnigy 2730-1500 motor
Rhino 3S 610mah battery

Any help is appreciated, thanks!
Sign up now
to remove ads between posts
Mar 31, 2012, 08:12 PM
Registered User
tacx's Avatar
When you say "If I plug a RX battery into the RX I can set up all three servos"

Assuming you are using a 4.8volt RX battery this would work as you say. You would be able to operate your servos normally because you are hitting them with a voltage they can take.

BUT you then say.."But, when I plug the flight pack into the RX, things get wacky".

Are you plugging in a higher voltage battery pack DIRECTLY into your RX??. You can't plug a flight pack battery directly into your RX. The RX can't take that high voltage and nether can your servos. You need to run the voltage through your ESC first. The ESC drops the voltage down to your RX and servos to a usable voltage level.
Mar 31, 2012, 08:50 PM
Registered User
No, sorry about the confusion. I plug the Rx pack (4.8V) into the Battery/Bind port or the flight pack (3S LiPo) into the ESC. When I have the flight pack plugged in I unplug the Rx pack and vice versa, so I only have one power source at a time.

I tried a spare receiver to see if that could be it but the same thing happens...I've also tried two different LiPos, so the only thing left is the ESC? Or my Tx, but I'd have no idea where to start with that...

Apr 01, 2012, 05:52 PM
Registered User
Well, I swapped the ESC with a spare and that fixed the problem. Not sure what would go wrong with an ESC to make that happen...
Apr 01, 2012, 08:23 PM
Registered User
tacx's Avatar
You could try reprogramming the ESC.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Rallyon's Flamewheel build and set up for FPV rallyon Multirotor Drone Talk 110 Jan 19, 2014 01:54 PM
Discussion First scratch foamy build kdmiller6679 Foamies (Scratchbuilt) 23 Mar 20, 2012 07:30 AM
Discussion Eurgle 9x - First time setting up neo__04 Radios 2 Mar 19, 2012 07:45 AM
Discussion Help with my first e power set up. Panther Power Systems 1 Mar 12, 2012 03:06 PM
Discussion setting up a giant for the first time Airplanedude Giant Scale Airplanes 3 Dec 06, 2011 12:13 AM