Thread Tools
Old Mar 28, 2012, 07:03 AM
MadridFlyer is offline
Find More Posts by MadridFlyer
Registered User
Discussion

Problem with new Bixler


Hi Guys,

I've got my new bixler and had a crash on the first flight Broke the prob and minor damage else where- it's all repaired new prop etc.

When I power it up now all the flying controls work in the correct way- I power up the throttle and the motor reaches full power then slowly reduces to a stop by its self....

I've tried a few fully charged batteries and checked all the connections.

Any other tips??

Thanks a million!
Sign up now
to remove ads between posts
Old Mar 28, 2012, 08:24 AM
swimman is offline
Find More Posts by swimman
Registered User
One thought would be to check all soldered connections. I had this happen on a ground vehicle where one of the wires came loose from the ESC. The truck would work for maybe a minute or two and then shut down. I soldered the wire back to the ESC and all is well.
Old Mar 28, 2012, 09:24 PM
cyclops2 is online now
Find More Posts by cyclops2
Registered User
If you can measure the battery voltage while running down ?

You should have a ESC battery lead problem. They run down smoothly.
A bad solder joint in any of the motor leads is usually a scheeching or juddering motor. Not a smooth slow down.

Swap ESCs. Then a motor with the original stuff.
Old Mar 30, 2012, 12:25 AM
asosestrom is offline
Find More Posts by asosestrom
Make sure you didn't damage your battery in the crash. Have you tried different batts?
Old Mar 30, 2012, 04:35 PM
MadridFlyer is offline
Find More Posts by MadridFlyer
Registered User
Hi,

I must have damaged the esc- i've tried everything else!

Cheers.
Old Mar 30, 2012, 07:09 PM
Legot is offline
Find More Posts by Legot
Build to Fly? FLY to BUILD!
Legot's Avatar
Quote:
Originally Posted by MadridFlyer View Post
Hi,

I must have damaged the esc- i've tried everything else!

Cheers.
It's very unlikely that the ESC itself is damaged from the crash. If you have a different battery, try the one that didn't crash. It is more likely that the battery was punctured and looses it's charge quickly, in which case you might smell a mildly sweet smell from the battery.

Inspect it well and report back please, good luck.
Old Mar 31, 2012, 07:36 PM
MadridFlyer is offline
Find More Posts by MadridFlyer
Registered User
Thanks- It seems my battery charger for whatever reason wasn't charging my batteries fully.

I've now ordered a new one!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Weird problem with New Y-6... Throttle works, but not Pitch Roll or Yaw Adidas4275 Hoverfly Technologies 4 Apr 02, 2012 12:21 PM
Discussion new bixler lipy Electric Plane Talk 4 Sep 04, 2011 07:23 AM