Shop our Airplanes Products Drone Products Sales
Thread Tools
Oct 21, 2003, 08:49 AM
-=Futaba RuLEz=-
t_predator90's Avatar

Can't see textures.... Can someone check?


Hi everyone. I've made a few models for FMS, but I can't see the textures. Could someone try downloading them and checking to see if it is just me, or the textures are bad? Go to here:

www.geocities.com/t_predator90

And go to the bottum of the page to download it.
Last edited by t_predator90; Oct 21, 2003 at 08:51 AM.
Sign up now
to remove ads between posts
Oct 21, 2003, 01:09 PM
Registered User
I don't know how to build models but I've been looking into the file structures because I'm trying to develop a model management tool.

All three of your .x (and .mqo) files use a really long relative path for the texture file. Changing this inside the file by hand did not fix the problem so I opened Metasequouia on the Dazzler model. Material mat6 shows the long relative pathname which is not on my system. When I removed all relative path stuff the "Show" button showed the file but did not show the texture mapped to the sphere in the upper left. When I used the "Ref" button to specify the location of the file on my system the texture then got mapped and showed up.

This appears to be a bug in Metasequouia that has to be worked around. Especially since while just playing with the path I crashed the program. It appears that the texture files need to be in the directory specified in the Configuration setup.

In addition your unicorn model refers to several texture files which are not included in your zip file. This happens to be a problem I uncovered with model management. Any name can be used for a texture file so people don't know what files go with what model without opening them up by hand!
Oct 21, 2003, 04:28 PM
Registered User
I figured out how to make the texture appear in Metasequoia but not in the .x file when using Save As, or in GeoFX when reading the .mqo file.

To get the texture to appear, and remove pathname information from the texture file name -- Set the system configuration tex path to the directory of your texture file. Open the model. In Material Props choose mat6, choose a DIFFERENT texture file and hit OK. Reopen material props and choose the correct texture file and hit OK. It now works for Metasequouia but no other programs.

This area of the tool could obviously use some work.
Oct 21, 2003, 06:09 PM
Registered User
Aha! I did a bunch of searching in the FMS Forum and found references to two good tutorials (in case other people want to see them).All comments about texture maps refer to square ones, usually 256x256 or 512x512. Yours is 1600x1200. I moved some sections of image around and resized down to 512x512 overall. Textures then showed up in FMS! Of course they need repositioning since they get moved in the bmp file.
Oct 22, 2003, 08:36 AM
-=Futaba RuLEz=-
t_predator90's Avatar
Thanx Keith! Could you send me them?
t_predator90@hotmail.com

Thanx
Oct 22, 2003, 11:47 AM
Registered User
On the way.
Oct 22, 2003, 12:24 PM
-=Futaba RuLEz=-
t_predator90's Avatar
Thanx
Oct 23, 2003, 06:13 AM
-=Futaba RuLEz=-
t_predator90's Avatar
Just wanted to say thanx to Keith. Problem solved.... When I saved the .x file, I forgot to check the UV mapping....