What's WRONG with my new TX?????? - RC Groups
Thread Tools
Oct 21, 2003, 12:22 AM
I told them, I was drunk.
temp_oct's Avatar
Help!

What's WRONG with my new TX??????



My TX was about a month old. I've just tried the control throw of my spitfire. I add some down elevator trim, it was too much so I press the up trim.
?????
Nothing happens.
I press it again
!!!!!!!!!!!!!!!!!!!! OH NO!!!
The up trim is totally dead!!!!!!!
I tried to put some up trim to other model memory. No response .

I am so sad now since I had not been flying since Friday. I plan to fly tomorrow with my new mod on the spitfire.

Anybody has any idea on this?????? Am I mess up with some program??????? I am so sad now......

I think I wait several weeks for that
Sign up now
to remove ads between posts
Oct 21, 2003, 12:24 AM
The One....
genovia's Avatar
Check your servo throw make sure that the arms are centered. BTW: What type of TX do you have?
Oct 21, 2003, 12:28 AM
I told them, I was drunk.
temp_oct's Avatar
JR 8103 airplane version.
It is not the servo, it is the TX
Usually it will display how much trim I have, but can adjust it only one way (down elevator only). All other digital trim (rudder and aileron) are fine
Any suggestion?
Oct 21, 2003, 12:30 AM
The One....
genovia's Avatar
Have you tried it with other rx and servo to see if it works? If your Rudder and elev is fine. try the servo, just to make sure.
Oct 21, 2003, 12:35 AM
I told them, I was drunk.
temp_oct's Avatar
The trim on the display as well as the servo doesn't move
I tried swap the channels, the servo works fine.


WHERE IS THAT DARN RECEIPT???
Oct 21, 2003, 12:39 AM
Tacoma, WA, USA
William A's Avatar
Gotta be the switch contacts in the 'up' trim button then.
If it's a separate wired component, maybe a broken wire.
Pop the cover and take a look-see.
Oct 21, 2003, 12:42 AM
I told them, I was drunk.
temp_oct's Avatar
I agree but I don't have parts.
There is a separate PCB for each digital trim switch. The soldering seems to be fine. I didn't check the contact on the switch yet (I've just broke my fuse in the DMM yesterday. What a bad luck!)
Oct 21, 2003, 02:23 AM
I told them, I was drunk.
temp_oct's Avatar
PROBLEM FIXED:
Thank you everybody.
The up-elevator trim switch is OK, however, there is a piece of plastic that suppose to push the switch when I press up trim that is not doing its job. I tighten the screw and it is working fine
So, I will definately fly tomorrow