Thread Tools
Old Mar 11, 2012, 09:39 AM
Patriot2373 is offline
Find More Posts by Patriot2373
Mankato MN
Discussion

my new traxxas slash not working


Hey guys....decided to dabble in trucks as I have been in helis and planes for the last 12 years......so I picked up a traxxas slash 4*4 brushless .....I am loving it until yesterday.....I M running stock setup with a 3 cell lipo....I changed the sec to the low voltage mode......after ripping around in the grass...it started to shutter and eventually stopped moving.....now it won't move at all......the steering servo still works.....but no toward or backward....did I burn up the esc? I hooked the motor up to another esc and it works....been reading that the vxl esc aren't good........any ideas?.....will traxxas take care of it?
Last edited by Patriot2373; Mar 11, 2012 at 10:03 AM.
Sign up now
to remove ads between posts
Old Mar 11, 2012, 10:41 AM
rangamatchstic is offline
Find More Posts by rangamatchstic
Registered User
unfortunatley it does sound like a ESC problem, well at the very least car ESC's arent expensive =) eg and ezrun from hobbywing which i will say is better than the vxl mainly in terms of racing as it stays sooo cool and has loads of options and only cost's $40.
Old Mar 11, 2012, 05:11 PM
wparsons is offline
Find More Posts by wparsons
Registered User
wparsons's Avatar
Did you charge the battery after that?
Old Mar 11, 2012, 05:57 PM
kistner is offline
Find More Posts by kistner
Registered Basher
kistner's Avatar
Traxxas is very good about warranty work. And I also wondered if the battery went dead
Old Mar 11, 2012, 07:03 PM
Balr14 is offline
Find More Posts by Balr14
Cranky old fart
Balr14's Avatar
I run a Stampeded 4 x 4 in 3S, but it has much bigger tires, so effective gearing is taller. I also have an ESC fan cooler, heat sinks on the motor and cooling scoops cut into the body for more air circulation. It still gets plenty warm. I'd say running a Slash with 3S and no other precautions would be pressing your luck.
Old Mar 11, 2012, 08:27 PM
Patriot2373 is offline
Find More Posts by Patriot2373
Mankato MN
Yep... battery is fully charged...i am pretty sure the esc burned up....
the plastic has some warping on the bottom and it smells like burnt electronics.... nice...
Is it normal for all lights to still be on and the steering servo work with a burned up esc???
Old Mar 11, 2012, 09:29 PM
wparsons is offline
Find More Posts by wparsons
Registered User
wparsons's Avatar
Are all the motor connectors fully connected? Can you get it to re-program?

It does sound fried, but it's a bit weird that the BEC side is totally fine still.
Old Mar 11, 2012, 09:50 PM
Patriot2373 is offline
Find More Posts by Patriot2373
Mankato MN
Yeah....it won't reprogram....I have checked all connections...just the smell of it tells me something fried
Old Mar 12, 2012, 11:58 AM
wparsons is offline
Find More Posts by wparsons
Registered User
wparsons's Avatar
Call traxxas and explain what happened, you might get lucky!
Old Mar 12, 2012, 03:29 PM
Patriot2373 is offline
Find More Posts by Patriot2373
Mankato MN
Called Traxxas.... told them what happened.... He didn;t even troubleshoot it...
He told me to pack up the esc and motor and send it in which i did....
Obviously its a well known problem with the esc...
Old Mar 14, 2012, 08:33 AM
Y2kGTP is offline
Find More Posts by Y2kGTP
Car Junkie trying to fly
Y2kGTP's Avatar
My kids truck did the same thing, it was just a bad motor. Almost 3 years of hard bashing I could not complain. I was still getting voltage at the ESC motor wires.

Had the exact same symptoms and replacing the motor did the trick.
Old Mar 14, 2012, 01:05 PM
wparsons is offline
Find More Posts by wparsons
Registered User
wparsons's Avatar
^^ He mentioned trying the motor with a different ESC and it works fine.
Old Mar 14, 2012, 01:10 PM
Y2kGTP is offline
Find More Posts by Y2kGTP
Car Junkie trying to fly
Y2kGTP's Avatar
Quote:
Originally Posted by wparsons View Post
^^ He mentioned trying the motor with a different ESC and it works fine.
Ahh...my mistake.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Just bought my first RC...Traxxas Slash, but have a question flyhighr Off-road Cars 8 Mar 10, 2012 11:40 PM
Help! My motor's not working!!! vineet_p Power Systems 7 Oct 22, 2011 05:58 AM
Help! My new Savage XS not working Mikegt92 Electric Power Cars 4 Oct 16, 2011 10:14 PM
Help My New Phoenix 35 Throttle Is not Working Even with My Programmer? Joe Elston Castle Creations 10 Jun 13, 2005 05:49 PM