Thread Tools
Old Feb 27, 2012, 09:32 PM
gmwahl is offline
Find More Posts by gmwahl
Registered User
Help!

FS-TH9X won't bind to reciever!


Hi guys, I'm sure this MUST have happened to alot of you guys, and I'm wondering what you've done to solve this problem.

My TX will bind just fine to my ct6 receivers, but absolutely WILL NOT bind to the FS-R8B receivers (three of them) that came with it.

I'm open to the idea that I'm just doing something wrong, but for the life of me I can't figure out what. It's driving me insane! Any suggestions? I would sure love to be able to use it with 8 channels.

Thanks in advance!
Mike
Sign up now
to remove ads between posts
Old Feb 28, 2012, 11:48 AM
Lonemountain is offline
Find More Posts by Lonemountain
Lonemountain's Avatar
Here is the step-by-step binding procedure for the Fly Sky 8 channel Rx.

1) Turn on transmitter and set code mode to PPM. Turn off transmitter.
2) Insert pairing plug into BIND port of receiver.
3) Insert battery into receiverís BATT port. Two LEDs of the receiver will blink showing that the receiver is ready for binding.
4) Press and hold the BIND button on the transmitter module. Turn on the transmitter power. Do not release the BIND button.
5) Observe the LEDs on the receiver. Binding is successful if the LEDs stay lit. This process may take 10 seconds.
6) Release the BIND button on the transmitter.
7) Unplug the receiver BIND plug.
8) Connect a servo and test.
9) If the test fails, repeat the pairing process.
10) If the test passes, pairing is completed.
11) In use, turn on the transmitter, then the receiver. After use, turn off the receiver, then the transmitter.

This is the process that works for me. Others may have a better method. I hope this helps.
Old Feb 28, 2012, 01:50 PM
jaas75 is online now
Find More Posts by jaas75
Registered User
jaas75's Avatar
same happen to me with v911 heli, solution was after lights beging to light at a slower pace, release the binding button (at the transmitter) and turn it off then back on again and the heli was binded.
Old Feb 28, 2012, 06:19 PM
gmwahl is offline
Find More Posts by gmwahl
Registered User
Thanks lonemountain! I don't know why I was having a hard time, but I just couldn't get the 8 channel receiver to bind, but the 6 channel receiver was no problem. Oh well, I'm happy now. Thanks again.
Old Feb 28, 2012, 07:18 PM
Lonemountain is offline
Find More Posts by Lonemountain
Lonemountain's Avatar
Happy to oblige! Glad it worked for you. I don't know why all the manufacturers insist on doing things "their way". A little standardization would be nice.
Old May 27, 2012, 07:21 AM
peterillawarra is offline
Find More Posts by peterillawarra
Registered User
Hi,
Can I ask a question about this as I am also having problems. When I follow the proceedure outlined and unplug the binding plug the led goes out. When I attempt to then test with the transmitter I have not response what so ever. ?
Have tried it with 3 different receivers and all the same result.
Should i be seeing that led alight and steady even after the binding plug has been removed ?
Thanks
P
Old Aug 17, 2012, 02:06 AM
JRBII is offline
Find More Posts by JRBII
Registered User

fs r8a curcit board in a fs r8b case?


I have 3 fs r8b receivers with fs r8a ciucirt boards in them why? won't bind to my fs th9x trans even the one that came with it won't bind help
Old Dec 01, 2012, 09:27 AM
General660 is offline
Find More Posts by General660
Registered User
I tried this, not working. I bought the Witespy Flip quad, got the FS-TH9X radio, and have been trying to get it to bind for over a day now. The quad uses the AR6100e rx, I have been pouring over the net and forums trying to find a solution. So far, nothing seems to work. I am totally new to RC, but doing my best to work through the problem. The radio came with a receiver unit, but it is 1/8 inch thicker, and one has aux,gear, thr, abbreviations on it, other is designated by channels, so have no idea how to plug it in even if it fit in the frame.
I want to fly this, not diagnose it. Binding seems to be my major hurdle right now.Any help appreciated.
Old Dec 01, 2012, 09:59 AM
Daedalus66 is offline
Find More Posts by Daedalus66
60 years of RC flying
Daedalus66's Avatar
The AR6100 is a Spektrum receiver. The 9x comes with a FlySky module. They are simply not compatible.

You can either use a FlySky/HobbyKing compatible receiver. Or you can modify the transmitter with different module and firmware to work with the Spektrum receiver. The former is the cheap solution at about $9.

http://www.hobbyking.com/hobbyking/s...er_6Ch_V2.html

The latter will get you a radio with very advanced capabilities, but at a cost of $40-100 and some effort.

http://9xforums.com/wiki/index.php/Nutshell
Last edited by Daedalus66; Dec 01, 2012 at 10:05 AM.
Old Dec 01, 2012, 10:06 AM
Daedalus66 is offline
Find More Posts by Daedalus66
60 years of RC flying
Daedalus66's Avatar
Quote:
Originally Posted by JRBII View Post
I have 3 fs r8b receivers with fs r8a circuit boards in them why? won't bind to my fs th9x trans even the one that came with it won't bind help
Have you followed the instructions above?
Old Dec 01, 2012, 12:24 PM
General660 is offline
Find More Posts by General660
Registered User
Daedalus66, thank you very much for the information. Witespy said on the site it was compatible with all Spectrum class transmitters, so I assumed the FS-Th9X would be a good radio for it, my mistake. I didn't want to buy a cheap radio, so went for the Fly Sky, it was $75 on sale. This saves me more hours of beating my head against a wall. The TH9X came with a receiver, but it is 1/8 inch too tall to fit. I will call Witespy, see if using small washers to widen the gap will fit the other receiver. Now have to figure out how to swap the wires over.
Old Aug 15, 2015, 01:21 AM
jeter.kurtis is offline
Find More Posts by jeter.kurtis
Registered User
I have the same issue as peterillawarra. Same exact procedure except when I go to unplug the Rx binding plug I loose all power from the system.

The user seems to be long gone so maybe others know of a fix for this issue.

I am running just from the battery to the esc, then to the receiver. Then trying to test one servo.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Hobby Zone Champ won't bind or respond to transmitter Paul Parkflyers 2 Sep 21, 2011 01:31 PM
Discussion Hobby King orange Rx won't bind Berkie Radios 2 Jun 15, 2011 11:00 PM
Discussion DSM2 6ch OrangeRX won't bind--won't even flash the LED horseflesh Radios 12 Jun 09, 2011 12:06 AM
Discussion AR6100e Won't Bind jer291113 Radios 3 Apr 12, 2011 04:30 PM
Help! new 5G6 2.4Ghz reciever won't bind?!? Bugman Jeff Coaxial Helicopters 4 Oct 06, 2008 08:23 PM