Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
This thread is privately moderated by timecop, who may elect to delete unwanted replies.
Old Mar 08, 2012, 10:58 AM
timecop is offline
Find More Posts by timecop
Suspended Account
warnings are fine. linker errors are not. unfortunately, I'm not sure how to solve those.
Sign up now
to remove ads between posts
Old Mar 08, 2012, 11:32 AM
oddcopter is offline
Find More Posts by oddcopter
Quadcopter Addict
TC,

I noticed the code has:

cfg.minthrottle = 1150;
cfg.maxthrottle = 1850;

Do know if that is how it was configured back in the 0224 release?

Thanks
Old Mar 08, 2012, 11:42 AM
timecop is offline
Find More Posts by timecop
Suspended Account
Yes, those are defaults.
Use reflashed ESCs and those work fine with it.
I took the numbers from #define MINTHROTTLE/MAXTHROTTLE and copied them.
Old Mar 08, 2012, 11:46 AM
f5soh is offline
Find More Posts by f5soh
Registered User
f5soh's Avatar
Hi,

TC, do you test Baro function in MultiWii v2 code ?
I fly again with this version and no changes in motor Rpm (P at 20)
https://www.rcgroups.com/forums/show...&postcount=614
Old Mar 08, 2012, 11:47 AM
timecop is offline
Find More Posts by timecop
Suspended Account
I test it to the point of seeing it move when I blow on the sensor, beyond that its standard multiwii, so if it doens't work there, it won't work here, either.
Old Mar 08, 2012, 11:51 AM
icedfusion is offline
Find More Posts by icedfusion
Registered User
Quote:
Originally Posted by timecop View Post
Of course anyone not using PPM in 2012 can just screw themselves.
Yes, that is all well and good. However, I had not heard of PPM when I bought my 'not that cheap' Hitec Aurora 9 - which, as far as I am aware, does not support PPM. It has all the other bells and whistles - but not that, maybe they will do a firmware upgrade in the future as I don't intend replacing it anytime soon.

Cheers

ice.
Old Mar 08, 2012, 11:52 AM
CrazyLittle is offline
Find More Posts by CrazyLittle
Registered User
CrazyLittle's Avatar
Quote:
Originally Posted by oddcopter View Post
I get these errors when I try to compile:

AfroFlight32.elf section `.text' will not fit in region `FLASH' AfroFlight32 C/C++ Problem
That error is the most telling. The only time I ran into that was when I was playing around with the optimization settings.
Under the project properties / C/C++ Build / Settings / ARM Sourcery Windows GCC C Compiler / Optimization: Optimization level [Optimize size (-Os)]

Is yours set to something else? Otherwise, are you sure you got the codebase properly? Copy the entire console output into notepad, save the file and attach it to your post.
Old Mar 08, 2012, 12:11 PM
oddcopter is offline
Find More Posts by oddcopter
Quadcopter Addict
It was set wrong, so I changed it and now I get these errors:

make: *** [lib/CMSIS/CM3/CoreSupport/core_cm3.o] Error 1

registers may not be the same -- `strexb r0,r0,[r1]' line 492, external location: C:\Users\ADMINI~1\AppData\Local\Temp\ccKykBnA.s

registers may not be the same -- `strexh r0,r0,[r1]' line 516, external location: C:\Users\ADMINI~1\AppData\Local\Temp\ccKykBnA.s

I don't have a file called core_cm3.o in that directory, btw. Does it have to do with the optimization? Maybe I didn't install everything right.


Quote:
Originally Posted by CrazyLittle View Post
That error is the most telling. The only time I ran into that was when I was playing around with the optimization settings.
Under the project properties / C/C++ Build / Settings / ARM Sourcery Windows GCC C Compiler / Optimization: Optimization level [Optimize size (-Os)]

Is yours set to something else? Otherwise, are you sure you got the codebase properly? Copy the entire console output into notepad, save the file and attach it to your post.
Last edited by oddcopter; Mar 08, 2012 at 12:16 PM.
Old Mar 08, 2012, 12:19 PM
CrazyLittle is offline
Find More Posts by CrazyLittle
Registered User
CrazyLittle's Avatar
Do a "clean project" to make sure that everything gets recompiled. If you already attempted to build once with wrong settings and the object files are left behind, Eclipse will try to reuse them first.

Also, your console should be referencing "cs-make" not "make." That means you didn't pick the right toolchain from what I can tell. Make sure that you're building with CodeSourcery's toolchain.

Please do a "clean project" and then attach the console output like I did below:
Old Mar 08, 2012, 12:20 PM
timecop is offline
Find More Posts by timecop
Suspended Account
See this post about a patch on github for strexh stuff:
https://www.rcgroups.com/forums/show...&postcount=711
I guess I should probably just merge that patch?
Old Mar 08, 2012, 12:52 PM
lebrett is offline
Find More Posts by lebrett
Registered User
Quote:
Originally Posted by oddcopter View Post
Does MultiWii have anything similar to CopterControl where you can set a throttle value where each motor starts spinnning? (E.g. Motor 1 = 1112, Motor 2 = 1138, Motor 3 = 1108, Motor 4 = 1117)
Check the Minthrottle settings, but I'm not sure we can do it like in our CC board.





I'm trying to port OP on the Naze32, hard learning curve for me, btw.
As soon as I can, I'll ask for some help over there.


@TC : if you want, I could write the help file for the cli.
Old Mar 08, 2012, 12:55 PM
Levinemax is offline
Find More Posts by Levinemax
Registered User

Compass is 180 off


In "baseflight-20120306.zip" the compass orientation is wrong, in WinGui and MultiWiiConfig, when pointing North it show South, other than that seems to work fine.
Old Mar 08, 2012, 01:06 PM
oddcopter is offline
Find More Posts by oddcopter
Quadcopter Addict
Hmm, this one has more in it. Deleted the old one.
Old Mar 08, 2012, 01:18 PM
oddcopter is offline
Find More Posts by oddcopter
Quadcopter Addict
That would be really cool. It is easy to understand, configure and fly.

Quote:
Originally Posted by lebrett View Post

I'm trying to port OP on the Naze32, hard learning curve for me, btw.
As soon as I can, I'll ask for some help over there.
Old Mar 08, 2012, 01:33 PM
IceWind is offline
Find More Posts by IceWind
throw new IOPilotException();
IceWind's Avatar
Quote:
Originally Posted by oddcopter View Post
It was set wrong, so I changed it and now I get these errors:

make: *** [lib/CMSIS/CM3/CoreSupport/core_cm3.o] Error 1

registers may not be the same -- `strexb r0,r0,[r1]' line 492, external location: C:\Users\ADMINI~1\AppData\Local\Temp\ccKykBnA.s

registers may not be the same -- `strexh r0,r0,[r1]' line 516, external location: C:\Users\ADMINI~1\AppData\Local\Temp\ccKykBnA.s

I don't have a file called core_cm3.o in that directory, btw. Does it have to do with the optimization? Maybe I didn't install everything right.
You get your answer two pages back.

https://www.rcgroups.com/forums/show...&postcount=731

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Sen. Coburn $9 Trillion plan- Now we're talking SPEED-E-FLYER Life, The Universe, and Politics 7 Jul 20, 2011 05:43 PM