Shop our Airplanes Products Drone Products Sales
Thread Tools
Jun 08, 2012, 11:30 AM
I feel the need for speed!
scorpion1's Avatar
Still Lovin' that motor Jan?
Sign up now
to remove ads between posts
Jun 08, 2012, 01:00 PM
Registered User
stiks's Avatar
Quote:
Before giving up try it with a 6s pack or a couple of 4s in series to make 8.
Does it make a spark (charging the caps) when you plug the pack in?
Bill, i will give that a try tonight. Using the single 5cell 5000mah pack i get a slight spark...barely noticeable!

Quote:
If its the 240a hv(same as the Swordfish) I give full throttle while turning switch on and then it gives a little "song", I release to neutral.

Do you know yours has a switch?
Scorp, yep..i see the on off switch and in the process outlined by Bill and the directions...i turn it on at the appropriate time..but nothing.

I am going to try Bills suggestion later and see what that does. I also have a 2cell lipo and bec so i will use that to power the rx...instead of my little tired 6v nimh ...
Jun 08, 2012, 01:51 PM
Registered User
stiks's Avatar

new pictures


Here i am ...all dressed up with no were to go...fkin esc!! This is the new "travel" stand my buddy from the field helped me build.

He is the same person that did the plexi-glass work on the cowling and exhaust cover...
Jun 09, 2012, 03:40 PM
Boaters are nice people.
Quote:
Originally Posted by scorpion1
Still Lovin' that motor Jan?
Yep, I've got a raceday tomorrow and tests earlier this week showed a blisteringly fast boat with that motor and the 45 mm three-blade on 4S.

Hope I can keep it together in tomorrows races.

Regards, Jan.
Jun 09, 2012, 04:49 PM
I feel the need for speed!
scorpion1's Avatar
Wow, that is a strong motor spinnin' a 45mm 3 blade on 4s!! You may want to get your cg forward a half inch or so.................??

Good Luck!!
Jun 09, 2012, 10:46 PM
Registered User
stiks's Avatar
Bill, i used 2 4cells series together...I then went through the power on sequence and i the motor moved...but i got no beeps from the esc..

I turned everything off and tried the process again. I plugged in my rx battery and then plugged in the series batteries into the esc. I then turned on the controller then the switch on the esc..and that is when the motor jumped....

But now it wont do that either...this is really frustrating....i will give it another shot tomorrow...
Last edited by stiks; Jun 09, 2012 at 10:47 PM. Reason: spelling
Jun 09, 2012, 11:34 PM
I feel the need for speed!
scorpion1's Avatar
Quote:
Originally Posted by stiks
I plugged in my rx battery and then plugged in the series batteries into the esc. I then turned on the controller then the switch on the esc..and that is when the motor jumped....
I dont see the part about: Pulling full throttle, then turning on the switch?

Also I never plug up anything til the TX is on.
Jun 10, 2012, 08:31 AM
Registered User
All of my Swordfishes work fine.
Turn on transmitter
Plug in good rec. batt
Plug in main power batts
Turn on esc switch

2 to 5 sec delay while Esc checks system then beeps.
Jun 11, 2012, 11:23 AM
Registered User
stiks's Avatar
Jim/Bill/Scorp, i tried it all again and nothing. I went back into the programing of the esc and changed it to the default and tried it and still nothing from the esc or motor.

I tried different combinations and connecting the batteries and esc and powering on the controller; while holding the throttle down...and still nothing.

Any other ideas? HK is pretty much unresponsive...

Anybody got a "real" swordfish for sale?...

Bill/Scorp..do either of you have the actual turnigy aquastar 240..?
Jun 13, 2012, 11:36 AM
Registered User
stiks's Avatar

ESC update


Scorp..just before i got ready to send it off to you i got an email from HK. I got a RMA# from them to send the esc back. So, i am going to send it into them and see what happens. If they end up sending it back then we will go with the original plan.

But if by some miracle the replace it ..then we can go from there.

So for now i am kinda stalled!! If i mount up the motor i will just have to pull it out to put "a" esc back in. In the meantime i will setup the battery bay area and lock in the servos. I can also do my leak test....

I will keep you all posted...thanks for all the help...
Last edited by stiks; Jun 13, 2012 at 11:37 AM. Reason: additional info
Jun 13, 2012, 11:56 AM
I feel the need for speed!
scorpion1's Avatar
Oh gosh!! I cringe at the thought of sending them anything, you consider still letting me take a peek first and possibly save yourself a nightmare.
Jun 13, 2012, 12:58 PM
Registered User
stiks's Avatar
umm...too late...!!! i will keep on top of it....and let you know.
Jun 19, 2012, 09:20 AM
Registered User
stiks's Avatar

ESC update


After several days of watching the hk website for an update on my RMA it finally reflected my return....that was today Tuesday..

Yesterday on Monday i waited on their online chat for customer service during my normal working lunch. After i finally got on with someone they said the package never arrived....hmm...thats not a good sign.. Anyway i explained that i had shipped it fedex 2 day and that it should have been there..but of course i didnt have the tracking info with me...when asked for it. Well as it goes i couldnt find the tracking info at all. I must have accidentally thrown it out when i was cleaning out my mobile office..

Well anyway, after a trip down the the fedex office that i shipped the package from a very nice lady helped me locate the package using the date of the shipment and the destination..YAY!!! FEDEX!!!

So long story shortHK now has the "broken" esc...lets see what happens next...
Jun 20, 2012, 11:24 AM
Registered User
stiks's Avatar

ESC update


As noted before the status of my return was just updated yesterday showing that hk had received it and was starting the inspections process.

I managed to get in contact with someone and they said the inspection/return process can take weeks...so im thinking..here we go!?!

Well just poking around today i checked the hk site and my account and .....low and behold... They gave me a $215.00 dollar credit!!...no emoticon available for that...not really sure how to feel?l.

The notes only say that my esc was faulty!!!

Anyway, i sent them a question...asking..if, ..if i wanted to how would i go about getting a full refund..that is if i wanted to??

So Question:

Should i just get another one from them..with the credit... Or maybe get a refund (yeah right)... Or maybe even barter something off the site for someone with some cash???
Last edited by stiks; Jun 20, 2012 at 11:26 AM. Reason: additional info
Jun 20, 2012, 11:59 AM
Redneck Injuneer
bill34207's Avatar
Might as well forget the refund. That's not going to happen with HK.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Exceed Racing 49" Hydro velyter Racing Boats - Internal Combustion 19 Aug 09, 2012 08:09 AM
Build Log Scorps 50" Hydro build scorpion1 Racing Boats - Electric 360 Feb 04, 2012 03:01 PM
Discussion Brushless Hydro Build kruiser7 Racing Boats - Electric 17 Sep 15, 2011 09:51 PM
Discussion 4 Cell 34" OutRigger Hydro Build / Photos / Design Details / 720P Video ryan_t888 Racing Boats - Electric 13 Jul 07, 2011 10:39 AM
Discussion build manual for Hydro Glider dlysell Foamies (Scratchbuilt) 4 Apr 27, 2011 10:22 AM