3DHS Fanatics! - Page 633 - RC Groups
Thread Tools
Oct 07, 2012, 11:36 AM
Certified Wingnut
LanceMc's Avatar

omega bearings


Hi guys. I'm running an Omega 130 in my 47" Extra. The motor is making some strange sounds. I think the bearings are going/gone. I searched the forums for a bearing replacement and found Boca bearings. My question is What is the difference between the regular bearings and ceramic? Which do you recommend?
Thanks
Lance
Sign up now
to remove ads between posts
Oct 07, 2012, 12:07 PM
Registered User
nebwake's Avatar
The ceramic will last longer. I replaced my stock 130's bearings with ceramic bocas and am happy although I haven't noticed a difference in performance.
Oct 07, 2012, 12:12 PM
Well, now that you know ...
Bigster's Avatar
I replaced the bearings with Boca's ceramics in my Omega 103. It was much quieter until I had a prop strike. I found another company that sells replacements for a couple bucks (non ceramic) and figured I'd try them. I haven't pulled the motor out and borrowed the arbor press to try them yet though.
Oct 07, 2012, 12:52 PM
Certified Wingnut
LanceMc's Avatar
Quote:
Originally Posted by nebwake
The ceramic will last longer. I replaced my stock 130's bearings with ceramic bocas and am happy although I haven't noticed a difference in performance.
Quote:
Originally Posted by Bigster
I replaced the bearings with Boca's ceramics in my Omega 103. It was much quieter until I had a prop strike. I found another company that sells replacements for a couple bucks (non ceramic) and figured I'd try them. I haven't pulled the motor out and borrowed the arbor press to try them yet though.
Thanks guys. I took a video of the situation. Could you please take a look/listen, and tell me if this is a bearing problem?
Omega 130 (0 min 21 sec)

Thanks again
Lance
Oct 07, 2012, 01:04 PM
Well, now that you know ...
Bigster's Avatar
The 130 in my 47" Edge and 103 in my Slick sound exactly like that. The 130 in my Vyper is perfectly quiet. The advice I was given was "Fly it.".
Oct 07, 2012, 01:11 PM
No, I won't ship it. Don't ask
quadracer's Avatar
Quote:
Originally Posted by LanceMc
Thanks guys. I took a video of the situation. Could you please take a look/listen, and tell me if this is a bearing problem?
http://www.youtube.com/watch?v=0uk8Q9EAFv0
Thanks again
Lance
Is your prop balanced? Sounds like it might be a bit heavy on one end.
Oct 07, 2012, 01:57 PM
Certified Wingnut
LanceMc's Avatar
Quote:
Originally Posted by Bigster
The 130 in my 47" Edge and 103 in my Slick sound exactly like that. The 130 in my Vyper is perfectly quiet. The advice I was given was "Fly it.".
That's good to know The 130 I have in my Osiris is perfectly quiet, and this one started quiet, so I thought something was wrong

Quote:
Originally Posted by quadracer
Is your prop balanced? Sounds like it might be a bit heavy on one end.
Yes the prop is balanced, but The spinner isn't. Perhaps that's the problem? Maybe, I'll try it without the spinner?

Thanks guys
Lance
Oct 07, 2012, 02:23 PM
3DHS 'native'
going4speed's Avatar
sounds like a possible timing issue
Oct 07, 2012, 03:02 PM
Registered User
Quote:
Originally Posted by LanceMc
Thanks guys. I took a video of the situation. Could you please take a look/listen, and tell me if this is a bearing problem?
http://www.youtube.com/watch?v=0uk8Q9EAFv0
Thanks again
Lance
you my friend have the "omega knock" I have seen this in several different omegas, just fly it, I have seen them last a long time with that noise and I have had one snap in half and another that burned up with that noise, for now on I buy hacker or Motrolfly
Oct 07, 2012, 03:25 PM
ride hard and fly low
H.D.'s Avatar
yep, it's the "omega knock"
Oct 07, 2012, 04:00 PM
Honeybadger don't care...
Luv3d's Avatar
Might be dirty bearings. You can clean the bearings, repack and replace, or I have a video about how to replace them here:

How to replace Omega130 bearings (5 min 0 sec)


I believe Boca Bearings Ceramics run smoother- I would recommend the ABEC 5 bearings. I put them in my Omega, and no more rattle- it was very smooth last time I flew it.
Oct 07, 2012, 07:21 PM
Addicted to 3DHS and EF
3Daddict's Avatar
my airplane rack.
Name: IMG_3143.jpg
Views: 105
Size: 236.3 KB
Description:
Oct 07, 2012, 07:22 PM
No, I won't ship it. Don't ask
quadracer's Avatar
Quote:
Originally Posted by 3Daddict
my airplane rack.
Attachment 5214211
That looks like some of my landings in the past.... LOL
Oct 07, 2012, 07:29 PM
Addicted to 3DHS and EF
3Daddict's Avatar
You must have some rough landings then
Oct 07, 2012, 07:30 PM
No, I won't ship it. Don't ask
quadracer's Avatar
I've hung them in the trees a couple times.... Don't hate.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Unofficial NQD Tear Into Jet Boat Mod Thread Energy Jet Drive Boats 15840 Nov 15, 2017 06:26 PM
Discussion Banana Hobby Customer Support Request/Q and A Thread! banana hobby Banana Hobby 1192 Oct 17, 2017 07:26 PM
Discussion The Official AirWare Q&A Thread AndyKunz Radios 104 Dec 29, 2016 06:18 PM
Discussion THE FIRST UNOFFICIAL Parkzone Sukhoi mods thread!!!! bluemeane Micro Ready-to-Fly 27 Aug 18, 2009 12:23 AM
Megatech H2O unofficial thread and first rewiew. grk65 Racing Boats - Electric 7 Mar 05, 2007 01:09 AM