Suppo osd - Page 5 - RC Groups
Thread Tools
Aug 27, 2012, 12:42 AM
Great Britain
MrBen.'s Avatar
just ordered one
Sign up now
to remove ads between posts
Aug 29, 2012, 01:48 AM
Unregistered User
cmanley_nl's Avatar
Finally an OSD with decent sized connectors instead of those huge molex connectors used on other OSDs. I think I'm going to order one for my smaller models.
Sep 03, 2012, 05:59 PM
It's a job...
747Pilot's Avatar
GPS Question.

Would it be possible to attach a different GPS sensor?
One that is 10 Hz, for better accuracy. Like this one. EBAY

Also has anyone had success using a 5v camera with this?
Either supplied from a separate power source (ie Vtx, UBEC or VR)

Thanks
Sep 03, 2012, 07:02 PM
I'm a Registered User
Quote:
Originally Posted by 747Pilot
Also has anyone had success using a 5v camera with this?
Either supplied from a separate power source (ie Vtx, UBEC or VR)

Thanks
I'm using a 5V camera(a fatshark/Immersion setup). All I had to do was run the video out wire from the camera to the OSD, then from the OSD to the Vtx. The camera + and - still go to the Immersion Vtx for power and ground.
Sep 03, 2012, 07:08 PM
I'm a Registered User
I've noticed something odd with my OSD, wondering if anyone else has seen it too. When I set "home," my altitude reading zeros out like it should. But, after that, every time I plug it in, the altitude reads 300m and goes up from there. Anyone else experience this? My OSD is buried inside the fuse, so I can't really reset it every time I fly.
Sep 03, 2012, 10:13 PM
It's a job...
747Pilot's Avatar
Just a hunch, but I believe the altitude display is taken from GPS and not pressure altitude (barometric pressure).

So given the town you live in, the display is reading correctly according to GPS altitude which is a reference to sea level. Evansville is ~300m above sea level.

I believe you said the altitude was reading zero before. Is it capable of being "zero'd out"? Don't own this yet but I do plan on buying one. I just confirmed with a friend today that you can throw on another gps sensor (10hz) for higher accuracy.
Sep 03, 2012, 10:27 PM
I'm a Registered User
Quote:
Originally Posted by 747Pilot

I believe you said the altitude was reading zero before. Is it capable of being "zero'd out"?
Yes, if I press the "home" button, it zeros out at my current altitude, and behaves like an altimeter should, using my "home" location as it's zero reference until it's unplugged. I zeroed it today, but if I go plug in the OSD right now, it will read 300m. While it remembers my location just fine, it does seem to remember my altitude.
Sep 04, 2012, 11:43 AM
Semper Fi
greedyg76's Avatar
Just like 747 said, when the OSD is first powered up, the altitude displayed defaults to the current GPS location. "home" should be reset every flight to zero the alt to your current location.
Sep 05, 2012, 02:23 PM
Semper Fi
greedyg76's Avatar

Quick to ship


Quote:
Originally Posted by Widelec
will be shipped morning.
ordered on 8/21, just received 9/5 . 2 weeks Turkey to California - Thanks Widelec and BambuCopter!
Sep 06, 2012, 03:48 AM
Simple is the best
Quote:
Originally Posted by greedyg76
ordered on 8/21, just received 9/5 . 2 weeks Turkey to California - Thanks Widelec and BambuCopter!

You are welcome

Some oversea package shipped from HK.
Europa package shipped from Turkey
Sep 10, 2012, 03:27 PM
It's a job...
747Pilot's Avatar
Quote:
Originally Posted by Bugman Jeff
Yes, if I press the "home" button, it zeros out at my current altitude, and behaves like an altimeter should, using my "home" location as it's zero reference until it's unplugged. I zeroed it today, but if I go plug in the OSD right now, it will read 300m. While it remembers my location just fine, it does seem to remember my altitude.
Any luck with it the altitude? What does the manual say? How in depth is it?
I just ordered one 3 days ago from JustGoRc (Not sure why) I think I should have gone with Bamboo.
Sep 10, 2012, 04:14 PM
Great Britain
MrBen.'s Avatar
Mine arrived in about 8 days to the UK, I just wired it up and its very straight forward. A couple of questions though.

1) On boot up it states Suppo OSD 2.0, does this mean I dont have the 2.3 version? Also noticed I dont have the option to change between feet & metres which is 2.3 only?

2) I am powering the OSD through the VTX power, the voltage displayed is 11.4v when in fact a multimeter shows the lipo @ 12.4v, the main reason for buying the OSD is to monitor voltage on my quad so I know when to land, why is it so far out?
Sep 10, 2012, 05:19 PM
It's a job...
747Pilot's Avatar
From my understanding you would have the 2.0 version. The "big deal" with 2.3 is that you can choose ft.

http://www.suppomodel.com/FPV/OSD.html

So if you made an order for the 2.3 version and have a receipt for it, someone has some explaining to do. What website did you buy yours from?

Sorry can't help you on the voltage thing. Have you tried connecting it this way
Lipo--->OSD---->Vtx. The OSD diagram does show a dedicated +- connection on the OSD
for power in.

What I am having trouble with is understanding this wiring diagram. I believe there is an error. Please correct me if I'm wrong.
But to me it doesn't make sense the way they have drawn and labeled the blue wire between the Vtx and the OSD.

See attached pic.

-747
Last edited by 747Pilot; Sep 10, 2012 at 06:14 PM.
Sep 10, 2012, 07:53 PM
I'm a Registered User
Quote:
Originally Posted by 747Pilot
Sorry can't help you on the voltage thing. Have you tried connecting it this way
Lipo--->OSD---->Vtx. The OSD diagram does show a dedicated +- connection on the OSD
for power in.

What I am having trouble with is understanding this wiring diagram. I believe there is an error. Please correct me if I'm wrong.
But to me it doesn't make sense the way they have drawn and labeled the blue wire between the Vtx and the OSD.

See attached pic.

-747
You are correct, that is a misprint. Somewhere else of their website, it shows the correct wiring. The red should be power, black ground, blue video out(it's yellow on the V2.0)
Sep 10, 2012, 07:58 PM
I'm a Registered User
Quote:
Originally Posted by 747Pilot
Any luck with it the altitude? What does the manual say? How in depth is it?
I just ordered one 3 days ago from JustGoRc (Not sure why) I think I should have gone with Bamboo.
Manual? Ha! What you see on the website is it. It really is a decent OSD, particularly for what it cost. The altimeter works correctly, it just doesn't remember "home" so if I don't reset home every time, it starts at 300m(my altitude above sea level).


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion CL-OSD a open source osd software for E-OSD and G-OSD callelj FPV Equipment 4155 Jan 09, 2017 05:13 AM
Discussion Suppo ESC help??? rotorkilla Racing Boats - Electric 3 Apr 18, 2011 03:38 PM
Discussion Suppo Shuttering kuczy Power Systems 4 Apr 12, 2011 07:42 PM
Help! Looking for Suppo motor GuyP Power Systems 6 Mar 05, 2011 05:34 PM
Sold REDUCED - ESC's - NEW Suppo 60a Opto - Suppo 70a Opto+BEC - $17.50 each shipped. Wingwrecker Aircraft - Electric - Power Systems (FS/W) 4 Aug 26, 2009 06:41 PM